summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-02-28 08:18:16 -0800
committerKhem Raj <raj.khem@gmail.com>2022-03-01 09:06:56 -0800
commit42c0a75600aabb285024816a010d3c67218448ff (patch)
tree30ed3db58339abbf458a1b15690c9cb162b5a1fc /meta-python
parent9045feb0d91774ad5a192329e78438b27c3e6815 (diff)
downloadmeta-openembedded-42c0a75600aabb285024816a010d3c67218448ff.tar.gz
python3-sdnotify: patch to use setuptools
setup.py bdist_wheel does not work with distutils (which is deprecated anyway). Add a patch to switch to setuptools to allow the wheel to be built. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-sdnotify/0001-setup.py-switch-to-setuptools.patch31
-rw-r--r--meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb3
2 files changed, 33 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sdnotify/0001-setup.py-switch-to-setuptools.patch b/meta-python/recipes-devtools/python/python3-sdnotify/0001-setup.py-switch-to-setuptools.patch
new file mode 100644
index 000000000..cf7696aa6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sdnotify/0001-setup.py-switch-to-setuptools.patch
@@ -0,0 +1,31 @@
1From f662280b26eb1549890e88e8e9085f1937d7962d Mon Sep 17 00:00:00 2001
2From: Tim Orling <tim.orling@konsulko.com>
3Date: Mon, 28 Feb 2022 07:54:03 -0800
4Subject: [PATCH] setup.py: switch to setuptools
5
6In Python 3.10, 'distutils' is deprecated and is slated for removal in
7Python 3.12.
8
9Switch from distutils.core to setuptools. This also allows the 'wheel'
10binary archive format to be built with 'setup.py bdist_wheel'.
11
12Upstream-Status: Submitted [https://github.com/bb4242/sdnotify/pull/7]
13
14Signed-off-by: Tim Orling <tim.orling@konsulko.com>
15---
16 setup.py | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/setup.py b/setup.py
20index 433222c..32b5bd6 100644
21--- a/setup.py
22+++ b/setup.py
23@@ -1,4 +1,4 @@
24-from distutils.core import setup
25+from setuptools import setup
26
27 VERSION='0.3.2'
28
29--
302.30.2
31
diff --git a/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb b/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb
index 221a8c871..dc1961ac3 100644
--- a/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb
@@ -12,7 +12,8 @@ SECTION = "devel/python"
12LICENSE = "MIT" 12LICENSE = "MIT"
13LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cc572ccc4b18a4b7d13be5d01bc8213e" 13LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cc572ccc4b18a4b7d13be5d01bc8213e"
14 14
15SRC_URI[md5sum] = "749ddca1c70be1697fecc443fb1fdb16"
16SRC_URI[sha256sum] = "73977fc746b36cc41184dd43c3fe81323e7b8b06c2bb0826c4f59a20c56bb9f1" 15SRC_URI[sha256sum] = "73977fc746b36cc41184dd43c3fe81323e7b8b06c2bb0826c4f59a20c56bb9f1"
17 16
17SRC_URI += "file://0001-setup.py-switch-to-setuptools.patch"
18
18inherit setuptools3 pypi 19inherit setuptools3 pypi