diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python3-sdnotify/0001-setup.py-switch-to-setuptools.patch | 31 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb | 3 |
2 files changed, 33 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sdnotify/0001-setup.py-switch-to-setuptools.patch b/meta-python/recipes-devtools/python/python3-sdnotify/0001-setup.py-switch-to-setuptools.patch new file mode 100644 index 000000000..cf7696aa6 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-sdnotify/0001-setup.py-switch-to-setuptools.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From f662280b26eb1549890e88e8e9085f1937d7962d Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Orling <tim.orling@konsulko.com> | ||
3 | Date: Mon, 28 Feb 2022 07:54:03 -0800 | ||
4 | Subject: [PATCH] setup.py: switch to setuptools | ||
5 | |||
6 | In Python 3.10, 'distutils' is deprecated and is slated for removal in | ||
7 | Python 3.12. | ||
8 | |||
9 | Switch from distutils.core to setuptools. This also allows the 'wheel' | ||
10 | binary archive format to be built with 'setup.py bdist_wheel'. | ||
11 | |||
12 | Upstream-Status: Submitted [https://github.com/bb4242/sdnotify/pull/7] | ||
13 | |||
14 | Signed-off-by: Tim Orling <tim.orling@konsulko.com> | ||
15 | --- | ||
16 | setup.py | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/setup.py b/setup.py | ||
20 | index 433222c..32b5bd6 100644 | ||
21 | --- a/setup.py | ||
22 | +++ b/setup.py | ||
23 | @@ -1,4 +1,4 @@ | ||
24 | -from distutils.core import setup | ||
25 | +from setuptools import setup | ||
26 | |||
27 | VERSION='0.3.2' | ||
28 | |||
29 | -- | ||
30 | 2.30.2 | ||
31 | |||
diff --git a/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb b/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb index 221a8c871..dc1961ac3 100644 --- a/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb +++ b/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb | |||
@@ -12,7 +12,8 @@ SECTION = "devel/python" | |||
12 | LICENSE = "MIT" | 12 | LICENSE = "MIT" |
13 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cc572ccc4b18a4b7d13be5d01bc8213e" | 13 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cc572ccc4b18a4b7d13be5d01bc8213e" |
14 | 14 | ||
15 | SRC_URI[md5sum] = "749ddca1c70be1697fecc443fb1fdb16" | ||
16 | SRC_URI[sha256sum] = "73977fc746b36cc41184dd43c3fe81323e7b8b06c2bb0826c4f59a20c56bb9f1" | 15 | SRC_URI[sha256sum] = "73977fc746b36cc41184dd43c3fe81323e7b8b06c2bb0826c4f59a20c56bb9f1" |
17 | 16 | ||
17 | SRC_URI += "file://0001-setup.py-switch-to-setuptools.patch" | ||
18 | |||
18 | inherit setuptools3 pypi | 19 | inherit setuptools3 pypi |