summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2018-08-02 20:27:04 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-03 09:34:29 -0700
commit240b92343ea836b408bc5a0d9678bffa36d7a819 (patch)
treec28e09ad4389c6360e2a15aeb922b1fc5ec9d224 /meta-python
parent4dc3c05e72fb97800f3902b8a634f1df5a27193f (diff)
downloadmeta-openembedded-240b92343ea836b408bc5a0d9678bffa36d7a819.tar.gz
python-behave: Add Python 3 recipe
Fix broken dependencies of Python 2 recipe as well. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-behave.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-behave_1.2.6.bb16
-rw-r--r--meta-python/recipes-devtools/python/python3-behave_1.2.6.bb2
3 files changed, 24 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-behave.inc b/meta-python/recipes-devtools/python/python-behave.inc
new file mode 100644
index 000000000..ded75801d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-behave.inc
@@ -0,0 +1,15 @@
1SUMMARY = "A behavior-driven development framework, Python style"
2HOMEPAGE = "https://github.com/behave/behave"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d950439e8ea6ed233e4288f5e1a49c06"
5
6SRC_URI[md5sum] = "3f05c859a1c45f5ed33e925817ad887d"
7SRC_URI[sha256sum] = "b9662327aa53294c1351b0a9c369093ccec1d21026f050c3bd9b3e5cccf81a86"
8
9inherit pypi
10
11RDEPENDS_${PN} += " \
12 ${PYTHON_PN}-parse-type \
13 ${PYTHON_PN}-setuptools \
14 ${PYTHON_PN}-six \
15 "
diff --git a/meta-python/recipes-devtools/python/python-behave_1.2.6.bb b/meta-python/recipes-devtools/python/python-behave_1.2.6.bb
index 679730262..66221682a 100644
--- a/meta-python/recipes-devtools/python/python-behave_1.2.6.bb
+++ b/meta-python/recipes-devtools/python/python-behave_1.2.6.bb
@@ -1,10 +1,8 @@
1SUMMARY = "A behavior-driven development framework, Python style" 1inherit setuptools
2LICENSE = "BSD" 2require python-behave.inc
3LIC_FILES_CHKSUM = "file://LICENSE;md5=d950439e8ea6ed233e4288f5e1a49c06"
4 3
5SRC_URI[md5sum] = "3f05c859a1c45f5ed33e925817ad887d" 4RDEPENDS_${PN} += " \
6SRC_URI[sha256sum] = "b9662327aa53294c1351b0a9c369093ccec1d21026f050c3bd9b3e5cccf81a86" 5 ${PYTHON_PN}-argparse \
7 6 ${PYTHON_PN}-enum34 \
8RDEPENDS_${PN} += "python-difflib python-setuptools python-pkgutil python-misc python-argparse python-xml python-enum34 python-parse python-parse-type python-six" 7 ${PYTHON_PN}-traceback2 \
9 8 "
10inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python3-behave_1.2.6.bb b/meta-python/recipes-devtools/python/python3-behave_1.2.6.bb
new file mode 100644
index 000000000..1c55871b1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-behave_1.2.6.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-behave.inc