diff options
author | Trevor Gamblin <tgamblin@baylibre.com> | 2024-08-12 14:20:36 -0400 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-08-23 22:35:11 -0700 |
commit | d135ee1c0b4feaee338f476be9319759cd6feb94 (patch) | |
tree | fa41bdb0f2ac814bf26a3df8c2d489bf542284e1 /meta-python/recipes-devtools/python/python3-pandas_2.2.2.bb | |
parent | b0c91cdc2e1867545b566f8975ebad1d464187d1 (diff) | |
download | meta-openembedded-d135ee1c0b4feaee338f476be9319759cd6feb94.tar.gz |
python3-pandas: upgrade 2.0.3 -> 2.2.2
pandas 2.2.2 is the first version compatible with numpy 2.0.x.
The package now uses meson as the build backend, so change the recipe to
inherit that.
Its pyproject.toml pins required versions for Cython and meson, but
newer upstream pandas releases are using different versions and
compatibility strings, so just add an OE-specific patch to relax the
requirements a bit for us.
Changelog: https://pandas.pydata.org/pandas-docs/version/2.2.2/whatsnew/v2.2.2.html
Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pandas_2.2.2.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pandas_2.2.2.bb | 42 |
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas_2.2.2.bb b/meta-python/recipes-devtools/python/python3-pandas_2.2.2.bb new file mode 100644 index 000000000..ac8d46984 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pandas_2.2.2.bb | |||
@@ -0,0 +1,42 @@ | |||
1 | SUMMARY = "pandas library for high-performance data analysis tools" | ||
2 | DESCRIPTION = "pandas is an open source, BSD-licensed library providing \ | ||
3 | high-performance, easy-to-use data structures and data analysis tools for \ | ||
4 | the Python programming language." | ||
5 | HOMEPAGE = "http://pandas.pydata.org/" | ||
6 | LICENSE = "BSD-3-Clause" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=cb819092901ddb13a7d0a4f5e05f098a" | ||
8 | |||
9 | SRC_URI += " \ | ||
10 | file://0001-pyproject.toml-don-t-pin-dependency-versions.patch \ | ||
11 | " | ||
12 | |||
13 | SRC_URI[sha256sum] = "9e79019aba43cb4fda9e4d983f8e88ca0373adbb697ae9c6c43093218de28b54" | ||
14 | |||
15 | inherit pypi python_mesonpy | ||
16 | |||
17 | DEPENDS += " \ | ||
18 | python3-cython-native \ | ||
19 | python3-numpy-native \ | ||
20 | python3-versioneer-native \ | ||
21 | " | ||
22 | |||
23 | PACKAGESPLITFUNCS =+ "fix_cythonized_sources" | ||
24 | |||
25 | fix_cythonized_sources() { | ||
26 | for f in `grep -l -r -e '\/* Generated by Cython.*/$' ${PKGD}${TARGET_DBGSRC_DIR}`; do | ||
27 | if [ -e $f ]; then | ||
28 | sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' $f | ||
29 | fi | ||
30 | done | ||
31 | } | ||
32 | |||
33 | CFLAGS:append:toolchain-clang = " -Wno-error=deprecated-declarations" | ||
34 | |||
35 | RDEPENDS:${PN} += " \ | ||
36 | python3-json \ | ||
37 | python3-numpy \ | ||
38 | python3-dateutil \ | ||
39 | python3-dateutil-zoneinfo \ | ||
40 | python3-pytz \ | ||
41 | python3-profile \ | ||
42 | " | ||