summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas/0001-pyproject.toml-don-t-pin-dependency-versions.patch37
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas_2.2.2.bb (renamed from meta-python/recipes-devtools/python/python3-pandas_2.0.3.bb)8
2 files changed, 43 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas/0001-pyproject.toml-don-t-pin-dependency-versions.patch b/meta-python/recipes-devtools/python/python3-pandas/0001-pyproject.toml-don-t-pin-dependency-versions.patch
new file mode 100644
index 000000000..f60f43a5b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pandas/0001-pyproject.toml-don-t-pin-dependency-versions.patch
@@ -0,0 +1,37 @@
1From d46b8720a6bccb345f6bdd7ee2f5c357e7eb227b Mon Sep 17 00:00:00 2001
2From: Trevor Gamblin <tgamblin@baylibre.com>
3Date: Mon, 12 Aug 2024 11:27:36 -0400
4Subject: [PATCH] pyproject.toml: don't pin dependency versions
5
6Pandas will fail to build if the exact versions aren't found, but newer
7ones actually work. Since newer versions of pandas are adjusting the
8requires section of pyproject toml further, just patch it for us.
9
10Upstream-Status: Inappropriate [OE-Specific]
11
12Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
13---
14 pyproject.toml | 6 +++---
15 1 file changed, 3 insertions(+), 3 deletions(-)
16
17diff --git a/pyproject.toml b/pyproject.toml
18index db9f055799..5158d60f59 100644
19--- a/pyproject.toml
20+++ b/pyproject.toml
21@@ -2,10 +2,10 @@
22 # Minimum requirements for the build system to execute.
23 # See https://github.com/scipy/scipy/pull/12940 for the AIX issue.
24 requires = [
25- "meson-python==0.13.1",
26- "meson==1.2.1",
27+ "meson-python>=0.13.1",
28+ "meson>=1.2.1",
29 "wheel",
30- "Cython==3.0.5", # Note: sync with setup.py, environment.yml and asv.conf.json
31+ "Cython>=3.0.5", # Note: sync with setup.py, environment.yml and asv.conf.json
32 # Force numpy higher than 2.0rc1, so that built wheels are compatible
33 # with both numpy 1 and 2
34 "numpy>=2.0.0rc1",
35--
362.39.2
37
diff --git a/meta-python/recipes-devtools/python/python3-pandas_2.0.3.bb b/meta-python/recipes-devtools/python/python3-pandas_2.2.2.bb
index 91e76d991..ac8d46984 100644
--- a/meta-python/recipes-devtools/python/python3-pandas_2.0.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pandas_2.2.2.bb
@@ -6,9 +6,13 @@ HOMEPAGE = "http://pandas.pydata.org/"
6LICENSE = "BSD-3-Clause" 6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=cb819092901ddb13a7d0a4f5e05f098a" 7LIC_FILES_CHKSUM = "file://LICENSE;md5=cb819092901ddb13a7d0a4f5e05f098a"
8 8
9SRC_URI[sha256sum] = "c02f372a88e0d17f36d3093a644c73cfc1788e876a7c4bcb4020a77512e2043c" 9SRC_URI += " \
10 file://0001-pyproject.toml-don-t-pin-dependency-versions.patch \
11 "
10 12
11inherit pypi setuptools3 13SRC_URI[sha256sum] = "9e79019aba43cb4fda9e4d983f8e88ca0373adbb697ae9c6c43093218de28b54"
14
15inherit pypi python_mesonpy
12 16
13DEPENDS += " \ 17DEPENDS += " \
14 python3-cython-native \ 18 python3-cython-native \