summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-moteus
diff options
context:
space:
mode:
authorRichard Leitner <dev@g0hl1n.net>2024-02-04 00:03:55 +0100
committerKhem Raj <raj.khem@gmail.com>2024-02-03 19:16:35 -0800
commitfb98797c96470048962da897b084833874b7f3e6 (patch)
treee5f2f1fef1712977cdd9d3a3c5ffc024ab8a4750 /meta-python/recipes-devtools/python/python3-moteus
parent277501596746adba0e798e2b27b87cbd2c001476 (diff)
downloadmeta-openembedded-fb98797c96470048962da897b084833874b7f3e6.tar.gz
python3-moteus: add recipe for v0.3.67
moteus brushless controller library and tools. This recipe uses pypi as source: https://pypi.org/project/moteus/ Signed-off-by: Richard Leitner <dev@g0hl1n.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-moteus')
-rw-r--r--meta-python/recipes-devtools/python/python3-moteus/0001-lib-python-remove-self-import-from-setup.py.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-moteus/0001-lib-python-remove-self-import-from-setup.py.patch b/meta-python/recipes-devtools/python/python3-moteus/0001-lib-python-remove-self-import-from-setup.py.patch
new file mode 100644
index 000000000..10acd7b8c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-moteus/0001-lib-python-remove-self-import-from-setup.py.patch
@@ -0,0 +1,32 @@
1From 7490ac4629c7fe0dc329647e6e000d4bc13c610d Mon Sep 17 00:00:00 2001
2From: Richard Leitner <dev@g0hl1n.net>
3Date: Wed, 24 Jan 2024 00:49:45 +0100
4Subject: [PATCH] lib: python: remove self-import from setup.py
5
6Importing moteus itself within the setup.py creates some kind of a
7chicken-and-egg problem. Furthermore it isn't used anywhere within
8setup.py. Therefore remove the corresponding import.
9
10Signed-off-by: Richard Leitner <dev@g0hl1n.net>
11
12Upstream-Status: Backport [https://github.com/mjbots/moteus/commit/7490ac4629c7fe0dc329647e6e000d4bc13c610d]
13---
14 setup.py | 2 --
15 1 file changed, 2 deletions(-)
16
17diff --git a/setup.py b/setup.py
18index 2731685..6c6064d 100644
19--- a/setup.py
20+++ b/setup.py
21@@ -17,8 +17,6 @@
22 import setuptools
23 import pathlib
24
25-import moteus
26-
27 here = pathlib.Path(__file__).parent.resolve()
28
29 # Get the long description from the README file
30--
312.40.1
32