summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-gcovr/0001-pyproject.toml-Support-newer-versions.patch
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2025-03-04 15:54:16 +0200
committerKhem Raj <raj.khem@gmail.com>2025-03-06 06:58:00 -0800
commit94b44822d50274859c05f4cfb15480c7d262e308 (patch)
tree3cd2dc5ebcfb1d75c52d57935acc8b650fb72c74 /meta-python/recipes-devtools/python/python3-gcovr/0001-pyproject.toml-Support-newer-versions.patch
parent08e22ae5fd0a344a104d51a6a7699ef38d9f8c9f (diff)
downloadmeta-openembedded-94b44822d50274859c05f4cfb15480c7d262e308.tar.gz
python3-gcovr: Upgrade 8.2 -> 8.3
Upgrade to release 8.3: - Replace setup.py with hatchling. To install from source at least version 21.3 of pip is needed. - Drop support for Python 3.8. - Add condition coverage to text summary report. - Add --include to search files in search paths which should be added to report. - Add option to generate LCOV format produced by version 1.x of LCOV tool. - Extend logging for data merge errors with info about the data sources. - Add condition coverage merge mode option --merge-mode-conditions - Add --gcov-suspicious-hits-threshold to configure the value for detecting suspicious hits in GCOV files. - Renamed JSON element destination_blockno to destination_block_id. - Add --html-block-ids to show the block ids of the lines and branches in HTML report. - Fixed an error handling bug throwing a TypeError exception on a gcov merge assertion failure instead of reporting the error and (if requested by the user) continuing execution - Check format version of external generated gcov JSON files. - Fix crash on Windows when trying to fix the case of the files. - Fix LCOV report. Excluded lines where added with a count of 0. - Fix line exclusion not clearing all child coverage data. - Fix summary stats in JaCoCo report. - Fix path issue when reading/writing Coveralls report. - Fix issue with negative counters in GCOV JSON export. License-Update: Update year Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-gcovr/0001-pyproject.toml-Support-newer-versions.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-gcovr/0001-pyproject.toml-Support-newer-versions.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gcovr/0001-pyproject.toml-Support-newer-versions.patch b/meta-python/recipes-devtools/python/python3-gcovr/0001-pyproject.toml-Support-newer-versions.patch
new file mode 100644
index 0000000000..cf5ddf31cc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-gcovr/0001-pyproject.toml-Support-newer-versions.patch
@@ -0,0 +1,30 @@
1From 7963caede294c7615ab0a60900e37790731279cc Mon Sep 17 00:00:00 2001
2From: Leon Anavi <leon.anavi@konsulko.com>
3Date: Tue, 4 Mar 2025 13:30:48 +0000
4Subject: [PATCH] pyproject.toml: Support newer versions
5
6Support newer versions when building through bitbake.
7
8Upstream-Status: Inappropriate [oe specific]
9
10Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
11---
12 pyproject.toml | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/pyproject.toml b/pyproject.toml
16index e162ba062..89798fa23 100644
17--- a/pyproject.toml
18+++ b/pyproject.toml
19@@ -1,7 +1,7 @@
20
21 [build-system]
22 requires = [
23- "hatchling==1.26.1",
24+ "hatchling>=1.26.1",
25 "hatch-vcs==0.4.0",
26 "hatch-fancy-pypi-readme==24.1.0"
27 ]
28--
292.39.5
30