diff options
3 files changed, 62 insertions, 23 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gcovr/0001-pyproject.toml-Support-newer-versions.patch b/meta-python/recipes-devtools/python/python3-gcovr/0001-pyproject.toml-Support-newer-versions.patch new file mode 100644 index 0000000000..cf5ddf31cc --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-gcovr/0001-pyproject.toml-Support-newer-versions.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 7963caede294c7615ab0a60900e37790731279cc Mon Sep 17 00:00:00 2001 | ||
2 | From: Leon Anavi <leon.anavi@konsulko.com> | ||
3 | Date: Tue, 4 Mar 2025 13:30:48 +0000 | ||
4 | Subject: [PATCH] pyproject.toml: Support newer versions | ||
5 | |||
6 | Support newer versions when building through bitbake. | ||
7 | |||
8 | Upstream-Status: Inappropriate [oe specific] | ||
9 | |||
10 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | ||
11 | --- | ||
12 | pyproject.toml | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/pyproject.toml b/pyproject.toml | ||
16 | index e162ba062..89798fa23 100644 | ||
17 | --- a/pyproject.toml | ||
18 | +++ b/pyproject.toml | ||
19 | @@ -1,7 +1,7 @@ | ||
20 | |||
21 | [build-system] | ||
22 | requires = [ | ||
23 | - "hatchling==1.26.1", | ||
24 | + "hatchling>=1.26.1", | ||
25 | "hatch-vcs==0.4.0", | ||
26 | "hatch-fancy-pypi-readme==24.1.0" | ||
27 | ] | ||
28 | -- | ||
29 | 2.39.5 | ||
30 | |||
diff --git a/meta-python/recipes-devtools/python/python3-gcovr_8.2.bb b/meta-python/recipes-devtools/python/python3-gcovr_8.2.bb deleted file mode 100644 index bbafa36acf..0000000000 --- a/meta-python/recipes-devtools/python/python3-gcovr_8.2.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | DESCRIPTION = "generate GCC code coverage reports" | ||
2 | HOMEPAGE = "https://gcovr.com" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b307623752f2e1189349885b95b326e5" | ||
6 | |||
7 | SRC_URI = "git://github.com/gcovr/gcovr.git;branch=main;protocol=https" | ||
8 | SRCREV = "045fb8d51806bd7f9e3df4e4edffa3bb816cf77f" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
11 | |||
12 | inherit setuptools3 | ||
13 | |||
14 | RDEPENDS:${PN} += " \ | ||
15 | python3-colorlog \ | ||
16 | python3-jinja2 \ | ||
17 | python3-lxml \ | ||
18 | python3-multiprocessing \ | ||
19 | python3-pygments \ | ||
20 | python3-setuptools \ | ||
21 | " | ||
22 | |||
23 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-gcovr_8.3.bb b/meta-python/recipes-devtools/python/python3-gcovr_8.3.bb new file mode 100644 index 0000000000..a9b29a4458 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-gcovr_8.3.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | DESCRIPTION = "generate GCC code coverage reports" | ||
2 | HOMEPAGE = "https://gcovr.com" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ae27363fce24765bc79a095313a3b002" | ||
6 | |||
7 | SRC_URI = " \ | ||
8 | git://github.com/gcovr/gcovr.git;branch=main;protocol=https \ | ||
9 | file://0001-pyproject.toml-Support-newer-versions.patch \ | ||
10 | " | ||
11 | SRCREV = "fe536afac4da31e86909191ef31708755ab8cf83" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | inherit python_hatchling | ||
16 | |||
17 | DEPENDS += " \ | ||
18 | python3-hatchling-native \ | ||
19 | python3-hatch-vcs-native \ | ||
20 | python3-hatch-fancy-pypi-readme-native \ | ||
21 | " | ||
22 | |||
23 | RDEPENDS:${PN} += " \ | ||
24 | python3-colorlog \ | ||
25 | python3-jinja2 \ | ||
26 | python3-lxml \ | ||
27 | python3-multiprocessing \ | ||
28 | python3-pygments \ | ||
29 | python3-setuptools \ | ||
30 | " | ||
31 | |||
32 | BBCLASSEXTEND = "native nativesdk" | ||