summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2024-08-15 09:30:53 +0300
committerKhem Raj <raj.khem@gmail.com>2024-08-15 10:28:12 -0700
commite72396ae321609497d3329e047b21113fb11bc35 (patch)
treec61f02dea72d5660b0a199c88ab446edb8f74e8a /meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb
parent55bfe466db4e1489968f5b4841827ba6023e052c (diff)
downloadmeta-openembedded-e72396ae321609497d3329e047b21113fb11bc35.tar.gz
python3-dirty-equals: Upgrade 0.7.1 -> 0.8.0
Upgrade to release 0.8.0: - set requires-python to 3.8 - use zoneinfo instead of pytz where possible - No need to call datetime.replace for utc_now - Patch pprint to make pytest diffs nicer for big objects - uprev test, lint and docs dependencies - Support Python 3.13 - Uprev version Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb21
1 files changed, 0 insertions, 21 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb b/meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb
deleted file mode 100644
index ea9303b17..000000000
--- a/meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb
+++ /dev/null
@@ -1,21 +0,0 @@
1SUMMARY = "Doing dirty (but extremely useful) things with equals."
2DESCRIPTION = "dirty-equals is a python library that (mis)uses the \
3__eq__ method to make python code (generally unit tests) more \
4declarative and therefore easier to read and write.\
5\
6dirty-equals can be used in whatever context you like, but it comes \
7into its own when writing unit tests for applications where you're \
8commonly checking the response to API calls and the contents of a database."
9HOMEPAGE = "https://github.com/samuelcolvin/dirty-equals"
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=ab599c188b4a314d2856b3a55030c75c"
12
13SRC_URI[sha256sum] = "a580513f3285e93656a770a04e428f8bfc513848877bf278282dbfbb907fdbb4"
14
15S = "${WORKDIR}/dirty_equals-${PV}"
16
17inherit pypi python_hatchling
18
19PYPI_PACKAGE = "dirty_equals"
20
21RDEPENDS:${PN} += "python3-pytz"