summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb
diff options
context:
space:
mode:
authorGerbrand De Laender <gdelaende@gmail.com>2022-11-25 10:19:02 +0100
committerKhem Raj <raj.khem@gmail.com>2022-11-25 18:11:10 -0800
commitbd4208f1b767c172f3c555a95e3ae65fa6ee37fa (patch)
treeb04cdd848d5028f663d5be633e37eb1f67d9c871 /meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb
parent2392dc79254a223da260c4b3b639d738e81b06a5 (diff)
downloadmeta-openembedded-bd4208f1b767c172f3c555a95e3ae65fa6ee37fa.tar.gz
python3-aioserial: new package
Adds a recipe for aioserial - an asynchronous serial port library for Python Signed-off-by: Gerbrand De Laender <gdelaende@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb')
-rwxr-xr-xmeta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb b/meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb
new file mode 100755
index 000000000..7ef47a2f8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "An asynchronous serial port library for Python"
2HOMEPAGE = "https://github.com/changyuheng/aioserial.py"
3SECTION = "devel/python"
4
5LICENSE = "MPL-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=650b9179efef1ea560df5c08bc32b494"
7
8PYPI_PACKAGE = "aioserial"
9
10SRC_URI[sha256sum] = "702bf03b0eb84b8ef2d8dac5cb925e1e685dce98f77b125569bc6fd2b3b58228"
11
12inherit pypi setuptools3
13
14RDEPENDS:${PN} += "\
15 ${PYTHON_PN}-core \
16 ${PYTHON_PN}-pyserial \
17"