summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-08-08 13:06:37 +0300
committerKhem Raj <raj.khem@gmail.com>2024-08-09 14:25:26 -0700
commit09ebd00ca9591b0b525f6c5e3db4b0bad8af5cd6 (patch)
tree1fde9448848dbe90fb18818b06b42f5c9c54c51e /meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb
parent953000215ed4b1112a35e0724510400d2b80ccce (diff)
downloadmeta-openembedded-09ebd00ca9591b0b525f6c5e3db4b0bad8af5cd6.tar.gz
python3-aioserial: switch to PEP-517 build backend
- The project has a proper pyproject.toml which declares the poetry.core.masonry.api PEP-517 backend. - The PyPi package name (defaults to PN without the python3- prefix), so there is no need to set PYPI_PACKAGE as aioserial, it is by default. - The upstream pyproject.toml says it needs to be built with the Poetry frontend, but that's deprecated behaviour and it should use the Poetry Core API instead. Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb')
-rwxr-xr-xmeta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb b/meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb
index 8279f27044..5acbcbf974 100755
--- a/meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb
@@ -5,11 +5,10 @@ SECTION = "devel/python"
5LICENSE = "MPL-2.0" 5LICENSE = "MPL-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=650b9179efef1ea560df5c08bc32b494" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=650b9179efef1ea560df5c08bc32b494"
7 7
8PYPI_PACKAGE = "aioserial" 8SRC_URI += "file://0001-use-poetry-core-for-pyproject-base-build.patch"
9
10SRC_URI[sha256sum] = "702bf03b0eb84b8ef2d8dac5cb925e1e685dce98f77b125569bc6fd2b3b58228" 9SRC_URI[sha256sum] = "702bf03b0eb84b8ef2d8dac5cb925e1e685dce98f77b125569bc6fd2b3b58228"
11 10
12inherit pypi setuptools3 11inherit pypi python_poetry_core
13 12
14RDEPENDS:${PN} += " \ 13RDEPENDS:${PN} += " \
15 python3-asyncio \ 14 python3-asyncio \