summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-aioserial/0001-use-poetry-core-for-pyproject-base-build.patch29
-rwxr-xr-xmeta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb5
2 files changed, 31 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aioserial/0001-use-poetry-core-for-pyproject-base-build.patch b/meta-python/recipes-devtools/python/python3-aioserial/0001-use-poetry-core-for-pyproject-base-build.patch
new file mode 100644
index 000000000..139bdb4f5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aioserial/0001-use-poetry-core-for-pyproject-base-build.patch
@@ -0,0 +1,29 @@
1From 5798a250b465572d84a024389b173dc996690b03 Mon Sep 17 00:00:00 2001
2From: alperak <alperyasinak1@gmail.com>
3Date: Thu, 8 Aug 2024 12:56:31 +0300
4Subject: [PATCH] Use poetry-core for pyproject base build
5
6https://github.com/python-poetry/poetry-core#why-is-this-required
7
8Upstream-Status: Pending
9
10Signed-off-by: alperak <alperyasinak1@gmail.com>
11---
12 pyproject.toml | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/pyproject.toml b/pyproject.toml
16index 6243bff..06bc409 100644
17--- a/pyproject.toml
18+++ b/pyproject.toml
19@@ -15,5 +15,5 @@ python = "^3.6"
20 pyserial = "*"
21
22 [build-system]
23-requires = ["poetry>=0.12"]
24-build-backend = "poetry.masonry.api"
25+requires = ["poetry-core>=0.12"]
26+build-backend = "poetry.core.masonry.api"
27--
282.25.1
29
diff --git a/meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb b/meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb
index 8279f2704..5acbcbf97 100755
--- a/meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-aioserial_1.3.1.bb
@@ -5,11 +5,10 @@ SECTION = "devel/python"
5LICENSE = "MPL-2.0" 5LICENSE = "MPL-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=650b9179efef1ea560df5c08bc32b494" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=650b9179efef1ea560df5c08bc32b494"
7 7
8PYPI_PACKAGE = "aioserial" 8SRC_URI += "file://0001-use-poetry-core-for-pyproject-base-build.patch"
9
10SRC_URI[sha256sum] = "702bf03b0eb84b8ef2d8dac5cb925e1e685dce98f77b125569bc6fd2b3b58228" 9SRC_URI[sha256sum] = "702bf03b0eb84b8ef2d8dac5cb925e1e685dce98f77b125569bc6fd2b3b58228"
11 10
12inherit pypi setuptools3 11inherit pypi python_poetry_core
13 12
14RDEPENDS:${PN} += " \ 13RDEPENDS:${PN} += " \
15 python3-asyncio \ 14 python3-asyncio \