diff options
author | Armin Kuster <akuster808@gmail.com> | 2016-03-07 18:00:14 -0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-03-14 12:15:37 +0100 |
commit | 830607415dd63ca5244ab8e51f402e046b03ca85 (patch) | |
tree | 1b33e58f84ebbadcb3e542e38248fa52774c015c /meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb | |
parent | 75f87df26c4aa0b6ab5d4c35fdea8877ba8c1e86 (diff) | |
download | meta-openembedded-830607415dd63ca5244ab8e51f402e046b03ca85.tar.gz |
python-m2crypto: fix build issue
restore swig file fiddling:
tmp/sysroots/qemux86/usr/include/openssl/opensslconf.h:45: Error: Unable to find 'openssl/opensslconf-64.h'
error: command 'swig' failed with exit status 1
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb | 22 |
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb b/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb index af8ca0954..f6f0e1f0e 100644 --- a/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb +++ b/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb | |||
@@ -27,4 +27,26 @@ SWIG_FEATURES_x86-64 = "-D__x86_64__" | |||
27 | SWIG_FEATURES ?= "" | 27 | SWIG_FEATURES ?= "" |
28 | export SWIG_FEATURES | 28 | export SWIG_FEATURES |
29 | 29 | ||
30 | # Get around a problem with swig, but only if the | ||
31 | # multilib header file exists. | ||
32 | # | ||
33 | do_compile_prepend() { | ||
34 | if [ "${SITEINFO_BITS}" = "64" ];then | ||
35 | bit="64" | ||
36 | else | ||
37 | bit="32" | ||
38 | fi | ||
39 | |||
40 | if [ -e ${STAGING_INCDIR}/openssl/opensslconf-${bit}.h ] ;then | ||
41 | for i in SWIG/_ec.i SWIG/_evp.i; do | ||
42 | sed -i -e "s/opensslconf.*\./opensslconf-${bit}\./" "$i" | ||
43 | done | ||
44 | elif [ -e ${STAGING_INCDIR}/openssl/opensslconf-n${bit}.h ] ;then | ||
45 | for i in SWIG/_ec.i SWIG/_evp.i; do | ||
46 | sed -i -e "s/opensslconf.*\./opensslconf-n${bit}\./" "$i" | ||
47 | done | ||
48 | fi | ||
49 | } | ||
50 | |||
51 | |||
30 | BBCLASSEXTEND = "native" | 52 | BBCLASSEXTEND = "native" |