summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb b/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb
index af8ca0954..f6f0e1f0e 100644
--- a/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb
+++ b/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb
@@ -27,4 +27,26 @@ SWIG_FEATURES_x86-64 = "-D__x86_64__"
27SWIG_FEATURES ?= "" 27SWIG_FEATURES ?= ""
28export SWIG_FEATURES 28export SWIG_FEATURES
29 29
30# Get around a problem with swig, but only if the
31# multilib header file exists.
32#
33do_compile_prepend() {
34 if [ "${SITEINFO_BITS}" = "64" ];then
35 bit="64"
36 else
37 bit="32"
38 fi
39
40 if [ -e ${STAGING_INCDIR}/openssl/opensslconf-${bit}.h ] ;then
41 for i in SWIG/_ec.i SWIG/_evp.i; do
42 sed -i -e "s/opensslconf.*\./opensslconf-${bit}\./" "$i"
43 done
44 elif [ -e ${STAGING_INCDIR}/openssl/opensslconf-n${bit}.h ] ;then
45 for i in SWIG/_ec.i SWIG/_evp.i; do
46 sed -i -e "s/opensslconf.*\./opensslconf-n${bit}\./" "$i"
47 done
48 fi
49}
50
51
30BBCLASSEXTEND = "native" 52BBCLASSEXTEND = "native"