summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-grpcio
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-08 14:47:58 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-13 13:21:02 +0200
commit2d07918e9cc6e03f8f864605c84290b66b81e998 (patch)
tree5febba040f5c964b24e1ff2cb70d59c7c245cf37 /meta-python/recipes-devtools/python/python-grpcio
parentc1966a1b3f728aa1d6d861a2791ae0cc10ebb14a (diff)
downloadmeta-openembedded-2d07918e9cc6e03f8f864605c84290b66b81e998.tar.gz
python-grpcio: Do not hardcode compiler -std options
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-grpcio')
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
new file mode 100644
index 000000000..3686144b3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
@@ -0,0 +1,36 @@
1From b02be74a2eff8abc612ef84f30e0fbce6a7f65f5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 4 Aug 2017 09:04:07 -0700
4Subject: [PATCH] setup.py: Do not mix C and C++ compiler options
5
6EXTRA_ENV_COMPILE_ARGS is used both with CC and CXX
7so using -std=c++11 or -std=gnu99 together will cause
8build time errors espcially with clang
9
10error: invalid argument '-std=gnu99' not allowed with 'C++'
11
12gcc7 ( defaults are -std=gnu11 and -std=gnu++14 )
13 as well clang default to these standards mode or newer
14anyway
15
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18 setup.py | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/setup.py b/setup.py
22index cb85273..f79878d 100644
23--- a/setup.py
24+++ b/setup.py
25@@ -116,7 +116,7 @@ if EXTRA_ENV_COMPILE_ARGS is None:
26 elif 'win32' in sys.platform:
27 EXTRA_ENV_COMPILE_ARGS += ' -D_PYTHON_MSVC'
28 elif "linux" in sys.platform:
29- EXTRA_ENV_COMPILE_ARGS += ' -std=c++11 -std=gnu99 -fvisibility=hidden -fno-wrapv'
30+ EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv'
31 elif "darwin" in sys.platform:
32 EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv'
33
34--
352.13.4
36