summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch36
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb2
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
new file mode 100644
index 000000000..3686144b3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
@@ -0,0 +1,36 @@
1From b02be74a2eff8abc612ef84f30e0fbce6a7f65f5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 4 Aug 2017 09:04:07 -0700
4Subject: [PATCH] setup.py: Do not mix C and C++ compiler options
5
6EXTRA_ENV_COMPILE_ARGS is used both with CC and CXX
7so using -std=c++11 or -std=gnu99 together will cause
8build time errors espcially with clang
9
10error: invalid argument '-std=gnu99' not allowed with 'C++'
11
12gcc7 ( defaults are -std=gnu11 and -std=gnu++14 )
13 as well clang default to these standards mode or newer
14anyway
15
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18 setup.py | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/setup.py b/setup.py
22index cb85273..f79878d 100644
23--- a/setup.py
24+++ b/setup.py
25@@ -116,7 +116,7 @@ if EXTRA_ENV_COMPILE_ARGS is None:
26 elif 'win32' in sys.platform:
27 EXTRA_ENV_COMPILE_ARGS += ' -D_PYTHON_MSVC'
28 elif "linux" in sys.platform:
29- EXTRA_ENV_COMPILE_ARGS += ' -std=c++11 -std=gnu99 -fvisibility=hidden -fno-wrapv'
30+ EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv'
31 elif "darwin" in sys.platform:
32 EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv'
33
34--
352.13.4
36
diff --git a/meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb b/meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb
index 5412e0243..2446411a1 100644
--- a/meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb
+++ b/meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb
@@ -4,6 +4,8 @@ SECTION = "devel/python"
4 4
5DEPENDS = "python-protobuf" 5DEPENDS = "python-protobuf"
6 6
7SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \
8 "
7RDEPENDS_${PN} = "python-enum34 \ 9RDEPENDS_${PN} = "python-enum34 \
8 python-futures \ 10 python-futures \
9 python-protobuf \ 11 python-protobuf \