summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2025-04-19 19:45:27 -0700
committerKhem Raj <raj.khem@gmail.com>2025-04-19 19:46:45 -0700
commitb22026cd3785700052aefa90e709b92d8e7f74fc (patch)
treee75ea9b23d1e1c9c81f5c5512337f0e56bb389af /meta-python/recipes-devtools/python
parentc7073b467971f9f25f9c8012ca6ca7cf1ff36ad9 (diff)
downloadmeta-openembedded-master.tar.gz
python3-lief: Upgrade to 0.16.5 + tip of trunkHEADmaster
Drop upstreamed patch. Pydantic-core is now available for riscv32 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-lief/0001-Add-cstdio-include.patch134
-rw-r--r--meta-python/recipes-devtools/python/python3-lief/0001-build-requirements.txt-Allow-newer-versions.patch21
-rw-r--r--meta-python/recipes-devtools/python/python3-lief_0.16.5.bb (renamed from meta-python/recipes-devtools/python/python3-lief_0.16.4.bb)6
3 files changed, 9 insertions, 152 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lief/0001-Add-cstdio-include.patch b/meta-python/recipes-devtools/python/python3-lief/0001-Add-cstdio-include.patch
deleted file mode 100644
index 396e935ddd..0000000000
--- a/meta-python/recipes-devtools/python/python3-lief/0001-Add-cstdio-include.patch
+++ /dev/null
@@ -1,134 +0,0 @@
1From a9b7a9f5c5572fc839d05457da073dc817722ace Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 1 Apr 2025 17:27:46 -0700
4Subject: [PATCH] Add cstdio include
5
6This is needed for uintXX_t types, GCC-15 is defauling to C23 and will error
7about it.
8
9e.g.
10
11include/LIEF/PE/LoadConfigurations/VolatileMetadata.hpp:145:3: note: 'uint32_t' is defined in header '<cstdint>'; this is probably fixable by adding '#include <cstdint>'
12
13Upstream-Status: Submitted [https://github.com/lief-project/LIEF/pull/1184]
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 include/LIEF/DWARF/Scope.hpp | 1 +
17 include/LIEF/ObjC/Method.hpp | 1 +
18 include/LIEF/PDB/PublicSymbol.hpp | 1 +
19 include/LIEF/PDB/types/Attribute.hpp | 1 +
20 include/LIEF/PE/LoadConfigurations/VolatileMetadata.hpp | 1 +
21 include/LIEF/PE/Relocation.hpp | 1 +
22 include/LIEF/PE/signature/attributes/PKCS9AtSequenceNumber.hpp | 1 +
23 include/LIEF/PE/signature/attributes/SpcRelaxedPeMarkerCheck.hpp | 1 +
24 src/MachO/TrieNode.hpp | 1 +
25 9 files changed, 9 insertions(+)
26
27diff --git a/include/LIEF/DWARF/Scope.hpp b/include/LIEF/DWARF/Scope.hpp
28index 78752847..61977c21 100644
29--- a/include/LIEF/DWARF/Scope.hpp
30+++ b/include/LIEF/DWARF/Scope.hpp
31@@ -15,6 +15,7 @@
32 #ifndef LIEF_DWARF_SCOPE_H
33 #define LIEF_DWARF_SCOPE_H
34
35+#include <cstdint>
36 #include <memory>
37 #include <string>
38
39diff --git a/include/LIEF/ObjC/Method.hpp b/include/LIEF/ObjC/Method.hpp
40index b4e82c6e..b9f37288 100644
41--- a/include/LIEF/ObjC/Method.hpp
42+++ b/include/LIEF/ObjC/Method.hpp
43@@ -16,6 +16,7 @@
44 #define LIEF_OBJC_METHOD_H
45 #include <LIEF/visibility.h>
46
47+#include <cstdint>
48 #include <memory>
49 #include <string>
50
51diff --git a/include/LIEF/PDB/PublicSymbol.hpp b/include/LIEF/PDB/PublicSymbol.hpp
52index b8904a5b..0e105435 100644
53--- a/include/LIEF/PDB/PublicSymbol.hpp
54+++ b/include/LIEF/PDB/PublicSymbol.hpp
55@@ -14,6 +14,7 @@
56 */
57 #ifndef LIEF_PDB_PUBLIC_SYMBOL_H
58 #define LIEF_PDB_PUBLIC_SYMBOL_H
59+#include <cstdint>
60 #include <memory>
61 #include <string>
62 #include <ostream>
63diff --git a/include/LIEF/PDB/types/Attribute.hpp b/include/LIEF/PDB/types/Attribute.hpp
64index a41270c0..fc961be5 100644
65--- a/include/LIEF/PDB/types/Attribute.hpp
66+++ b/include/LIEF/PDB/types/Attribute.hpp
67@@ -17,6 +17,7 @@
68
69 #include "LIEF/visibility.h"
70
71+#include <cstdint>
72 #include <string>
73 #include <memory>
74
75diff --git a/include/LIEF/PE/LoadConfigurations/VolatileMetadata.hpp b/include/LIEF/PE/LoadConfigurations/VolatileMetadata.hpp
76index 41b9e36b..073ccabc 100644
77--- a/include/LIEF/PE/LoadConfigurations/VolatileMetadata.hpp
78+++ b/include/LIEF/PE/LoadConfigurations/VolatileMetadata.hpp
79@@ -15,6 +15,7 @@
80 */
81 #ifndef LIEF_PE_LOAD_CONFIGURATION_VOLATILE_METADATA_H
82 #define LIEF_PE_LOAD_CONFIGURATION_VOLATILE_METADATA_H
83+#include <cstdint>
84 #include <memory>
85 #include <string>
86 #include <vector>
87diff --git a/include/LIEF/PE/Relocation.hpp b/include/LIEF/PE/Relocation.hpp
88index a4cd2e96..cd81bf68 100644
89--- a/include/LIEF/PE/Relocation.hpp
90+++ b/include/LIEF/PE/Relocation.hpp
91@@ -15,6 +15,7 @@
92 */
93 #ifndef LIEF_PE_RELOCATION_H
94 #define LIEF_PE_RELOCATION_H
95+#include <cstdint>
96 #include <vector>
97 #include <ostream>
98 #include <memory>
99diff --git a/include/LIEF/PE/signature/attributes/PKCS9AtSequenceNumber.hpp b/include/LIEF/PE/signature/attributes/PKCS9AtSequenceNumber.hpp
100index a89901fa..32db1470 100644
101--- a/include/LIEF/PE/signature/attributes/PKCS9AtSequenceNumber.hpp
102+++ b/include/LIEF/PE/signature/attributes/PKCS9AtSequenceNumber.hpp
103@@ -15,6 +15,7 @@
104 */
105 #ifndef LIEF_PE_ATTRIBUTES_PKCS9_AT_SEQUENCE_NUMBER_H
106 #define LIEF_PE_ATTRIBUTES_PKCS9_AT_SEQUENCE_NUMBER_H
107+#include <cstdint>
108
109 #include "LIEF/visibility.h"
110 #include "LIEF/PE/signature/Attribute.hpp"
111diff --git a/include/LIEF/PE/signature/attributes/SpcRelaxedPeMarkerCheck.hpp b/include/LIEF/PE/signature/attributes/SpcRelaxedPeMarkerCheck.hpp
112index f84fbcbf..5cce98b4 100644
113--- a/include/LIEF/PE/signature/attributes/SpcRelaxedPeMarkerCheck.hpp
114+++ b/include/LIEF/PE/signature/attributes/SpcRelaxedPeMarkerCheck.hpp
115@@ -15,6 +15,7 @@
116 */
117 #ifndef LIEF_PE_ATTRIBUTES_SPC_RELAXED_PE_MARKER_CHECK_H
118 #define LIEF_PE_ATTRIBUTES_SPC_RELAXED_PE_MARKER_CHECK_H
119+#include <cstdint>
120
121 #include "LIEF/visibility.h"
122 #include "LIEF/PE/signature/Attribute.hpp"
123diff --git a/src/MachO/TrieNode.hpp b/src/MachO/TrieNode.hpp
124index f6c411b8..6bdde9ec 100644
125--- a/src/MachO/TrieNode.hpp
126+++ b/src/MachO/TrieNode.hpp
127@@ -15,6 +15,7 @@
128 */
129 #ifndef LIEF_MACHO_TRIE_NODE_H_
130 #define LIEF_MACHO_TRIE_NODE_H_
131+#include <cstdint>
132 #include <string>
133 #include <vector>
134 #include <memory>
diff --git a/meta-python/recipes-devtools/python/python3-lief/0001-build-requirements.txt-Allow-newer-versions.patch b/meta-python/recipes-devtools/python/python3-lief/0001-build-requirements.txt-Allow-newer-versions.patch
index e2d041dac7..9c61f0bdee 100644
--- a/meta-python/recipes-devtools/python/python3-lief/0001-build-requirements.txt-Allow-newer-versions.patch
+++ b/meta-python/recipes-devtools/python/python3-lief/0001-build-requirements.txt-Allow-newer-versions.patch
@@ -12,28 +12,23 @@ Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
12 api/python/build-requirements.txt | 14 +++++++------- 12 api/python/build-requirements.txt | 14 +++++++-------
13 1 file changed, 7 insertions(+), 7 deletions(-) 13 1 file changed, 7 insertions(+), 7 deletions(-)
14 14
15diff --git a/api/python/build-requirements.txt b/api/python/build-requirements.txt
16index 4c9004ca..fe0d1055 100644
17--- a/api/python/build-requirements.txt 15--- a/api/python/build-requirements.txt
18+++ b/api/python/build-requirements.txt 16+++ b/api/python/build-requirements.txt
19@@ -1,10 +1,10 @@ 17@@ -1,10 +1,10 @@
20-tomli==2.0.1 18-tomli==2.2.1
21-scikit-build-core==0.9.8 19-scikit-build-core==0.11.1
22+tomli>=2.0.1 20+tomli>=2.2.1
23+scikit-build-core>=0.9.8 21+scikit-build-core>=0.11.1
24 # For Ninja: msvc.msvc14_get_vc_env 22 # For Ninja: msvc.msvc14_get_vc_env
25-setuptools==70.2.0 23-setuptools==70.2.0
26+setuptools>=70.2.0 24+setuptools>=70.2.0
27 # For the "env" feature 25 # For the "env" feature
28-pydantic==2.8.2 26-pydantic==2.11.3
29+pydantic>=2.8.2 27+pydantic>=2.11.3
30 # Implicit from scikit-build-core 28 # Implicit from scikit-build-core
31-pathspec==0.12.1 29-pathspec==0.12.1
32-build==1.2.1 30-build==1.2.1
33-wheel==0.43.0 31-wheel==0.45.1
34+pathspec>=0.12.1 32+pathspec>=0.12.1
35+build>=1.2.1 33+build>=1.2.1
36+wheel>=0.43.0 34+wheel>=0.45.1
37--
382.39.5
39
diff --git a/meta-python/recipes-devtools/python/python3-lief_0.16.4.bb b/meta-python/recipes-devtools/python/python3-lief_0.16.5.bb
index 67bbcbf7b1..2166e3257f 100644
--- a/meta-python/recipes-devtools/python/python3-lief_0.16.4.bb
+++ b/meta-python/recipes-devtools/python/python3-lief_0.16.5.bb
@@ -9,10 +9,8 @@ SRC_URI = " \
9 git://github.com/lief-project/LIEF.git;protocol=https;branch=main \ 9 git://github.com/lief-project/LIEF.git;protocol=https;branch=main \
10 file://0001-build-requirements.txt-Allow-newer-versions.patch \ 10 file://0001-build-requirements.txt-Allow-newer-versions.patch \
11 file://0002-api-python-config-default.toml-Debug.patch \ 11 file://0002-api-python-config-default.toml-Debug.patch \
12 file://0001-Add-cstdio-include.patch \
13" 12"
14SRCREV = "1e9b12bd14cbe087d52355b8b9af578f1b04d8ca" 13SRCREV = "abcf929efb748c7846dd59007cbb807e108db311"
15
16PV .= "+git" 14PV .= "+git"
17 15
18S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
@@ -33,7 +31,5 @@ DEPENDS += "\
33" 31"
34# https://github.com/lief-project/LIEF/commit/3def579f75965aa19c021d840a759bce2afc0a31#r152197203 32# https://github.com/lief-project/LIEF/commit/3def579f75965aa19c021d840a759bce2afc0a31#r152197203
35COMPATIBLE_HOST:x86 = "null" 33COMPATIBLE_HOST:x86 = "null"
36# Needs pydantic and pydantic-core
37COMPATIBLE_HOST:riscv32 = "null"
38 34
39BBCLASSEXTEND = "native nativesdk" 35BBCLASSEXTEND = "native nativesdk"