summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2024-06-01 15:49:49 +0200
committerKhem Raj <raj.khem@gmail.com>2024-06-01 10:49:41 -0700
commit446560ab41de5e29ef5dfb556de1149e76a80367 (patch)
tree601f7231c139cf31bbdc9f8a3dbd6bb5af55ba43 /meta-python/recipes-devtools
parentdc942a392f550e1f4cbb467dd4163d3735c4ae6d (diff)
downloadmeta-openembedded-master.tar.gz
python3-icu: upgrade from 2.12 to 2.13.1 to fix build with icu-75HEADmaster
Version 2.13 -> 2.13.1 ---------------------- - change c++11 to c++17 in setup.py as current versions of ICU require it Version 2.12 -> 2.13 -------------------- - fixed build issues on Windows - added wrappers for MeasureUnit(locale, width) and getUnitDisplayName() - added wrappers for DateFormatSymbols.getEra|ZodiacNames() - added wrappers for DateFormatSymbols.getZoneStrings() - added wrappers for LocaleDisplayNames - fixed bug dealloc calling wrong destructor on most types (Fredrik Roubert) - added support for ICU 75.1 - added wrappers for LocalizedNumber|Range|Formatter.withoutLocale() - added wrappers for UIdentifierType, Char.hasIDType(), Char.getIDTypes() - added wrappers for UIdentifierStatus - added wrappers for UProperty.IDENTIFIER_TYPE, UProperty.IDENTIFIER_STATUS Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-icu_2.13.1.bb (renamed from meta-python/recipes-devtools/python/python3-icu_2.12.bb)6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-icu_2.12.bb b/meta-python/recipes-devtools/python/python3-icu_2.13.1.bb
index 6394db4e9..6a590de5f 100644
--- a/meta-python/recipes-devtools/python/python3-icu_2.12.bb
+++ b/meta-python/recipes-devtools/python/python3-icu_2.13.1.bb
@@ -8,8 +8,12 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=0724597863f1581ab01429e0423e779f"
8DEPENDS += "icu" 8DEPENDS += "icu"
9 9
10PYPI_PACKAGE = "PyICU" 10PYPI_PACKAGE = "PyICU"
11SRC_URI[sha256sum] = "bd7ab5efa93ad692e6daa29cd249364e521218329221726a113ca3cb281c8611" 11
12SRC_URI[sha256sum] = "d4919085eaa07da12bade8ee721e7bbf7ade0151ca0f82946a26c8f4b98cdceb"
12 13
13SRC_URI += "file://0001-Fix-host-contamination-of-include-files.patch" 14SRC_URI += "file://0001-Fix-host-contamination-of-include-files.patch"
14 15
15inherit pkgconfig pypi python_setuptools_build_meta 16inherit pkgconfig pypi python_setuptools_build_meta
17
18# it's lowercase pyicu instead of ${PYPI_PACKAGE} in this version
19S = "${WORKDIR}/pyicu-${PV}"