summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-05-11 23:36:03 -0700
committerKhem Raj <raj.khem@gmail.com>2024-05-12 21:51:32 -0700
commit61d407ad599c8057d8ca4020b87bb7a63d3c4494 (patch)
tree078a2a898ae3da260b6d10fb1ba81699c40162c1 /meta-oe
parent9e916094440d2530afc04da5455bec74563399d8 (diff)
downloadmeta-openembedded-61d407ad599c8057d8ca4020b87bb7a63d3c4494.tar.gz
rsyslog: Upgrade to 8.2404.0
Add a patch to fix build with gcc14+musl Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/rsyslog/rsyslog/0001-tests-tcpflood.c-Pass-correct-parameter-type-to-send.patch35
-rw-r--r--meta-oe/recipes-extended/rsyslog/rsyslog_8.2404.0.bb (renamed from meta-oe/recipes-extended/rsyslog/rsyslog_8.2402.0.bb)4
2 files changed, 37 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog/0001-tests-tcpflood.c-Pass-correct-parameter-type-to-send.patch b/meta-oe/recipes-extended/rsyslog/rsyslog/0001-tests-tcpflood.c-Pass-correct-parameter-type-to-send.patch
new file mode 100644
index 000000000..5df29e7d9
--- /dev/null
+++ b/meta-oe/recipes-extended/rsyslog/rsyslog/0001-tests-tcpflood.c-Pass-correct-parameter-type-to-send.patch
@@ -0,0 +1,35 @@
1From 1e0a77d8a5ae7cd0223afadf46cdbb540119774d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 11 May 2024 23:31:46 -0700
4Subject: [PATCH] tests/tcpflood.c: Pass correct parameter type to sendto()
5
6Fixes build with GCC-14 and musl
7
8../../rsyslog-8.2404.0/tests/tcpflood.c:811:70: error: passing argument 5 of 'sendto' from incompatible pointer type [-Wincompatible-pointer-types]
9 811 | lenSend = sendto(udpsockout, buf, lenBuf, 0, &udpRcvr, sizeof(udpRcvr));
10 | ^~~~~~~~
11 | |
12 | struct sockaddr_in *
13
14Upstream-Status: Pending
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16---
17 tests/tcpflood.c | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/tests/tcpflood.c b/tests/tcpflood.c
21index bd8edaf..0feda23 100644
22--- a/tests/tcpflood.c
23+++ b/tests/tcpflood.c
24@@ -808,7 +808,7 @@ int sendMessages(struct instdata *inst)
25 }
26 lenSend = sendPlainTCP(socknum, buf, lenBuf, &error_number);
27 } else if(transport == TP_UDP) {
28- lenSend = sendto(udpsockout, buf, lenBuf, 0, &udpRcvr, sizeof(udpRcvr));
29+ lenSend = sendto(udpsockout, buf, lenBuf, 0, (const struct sockaddr *)&udpRcvr, sizeof(udpRcvr));
30 error_number = errno;
31 } else if(transport == TP_TLS) {
32 if(sockArray[socknum] == -1) {
33--
342.45.0
35
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog_8.2402.0.bb b/meta-oe/recipes-extended/rsyslog/rsyslog_8.2404.0.bb
index af46cc14d..515298424 100644
--- a/meta-oe/recipes-extended/rsyslog/rsyslog_8.2402.0.bb
+++ b/meta-oe/recipes-extended/rsyslog/rsyslog_8.2404.0.bb
@@ -25,14 +25,14 @@ SRC_URI = "https://www.rsyslog.com/files/download/rsyslog/${BPN}-${PV}.tar.gz \
25 file://use-pkgconfig-to-check-libgcrypt.patch \ 25 file://use-pkgconfig-to-check-libgcrypt.patch \
26 file://run-ptest \ 26 file://run-ptest \
27 file://0001-tests-disable-the-check-for-inotify.patch \ 27 file://0001-tests-disable-the-check-for-inotify.patch \
28 file://0001-tests-tcpflood.c-Pass-correct-parameter-type-to-send.patch \
28" 29"
29 30
30SRC_URI:append:libc-musl = " \ 31SRC_URI:append:libc-musl = " \
31 file://0001-Include-sys-time-h.patch \ 32 file://0001-Include-sys-time-h.patch \
32 file://disable-omfile-outchannel.patch \ 33 file://disable-omfile-outchannel.patch \
33" 34"
34 35SRC_URI[sha256sum] = "30528d140ec1b1f079224081fa37df6e06587ff42b02e3e61f2daa0526c54d33"
35SRC_URI[sha256sum] = "acbdd8579489df36b4a383dc6909a61b7623807f0aff54c062115f2de7ea85ba"
36 36
37UPSTREAM_CHECK_URI = "https://github.com/rsyslog/rsyslog/releases" 37UPSTREAM_CHECK_URI = "https://github.com/rsyslog/rsyslog/releases"
38UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)" 38UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)"