summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-05-11 23:20:48 -0700
committerKhem Raj <raj.khem@gmail.com>2024-05-12 21:51:32 -0700
commit9e916094440d2530afc04da5455bec74563399d8 (patch)
tree4932370acc372dfc0f1450e7f693811b90594ab2 /meta-oe
parentf25bfcbf948cf2a3eaa34ad1afb1f87b27dc713a (diff)
downloadmeta-openembedded-9e916094440d2530afc04da5455bec74563399d8.tar.gz
libteam: Upgrade to 1.32 release
Drop upstreamed patches Fix build with GCC-14 on musl systems Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/libteam/libteam/0001-include-sys-select.h-for-fd_set-definition.patch30
-rw-r--r--meta-oe/recipes-support/libteam/libteam/0001-teamd-Include-missing-headers-for-strrchr-and-memcmp.patch46
-rw-r--r--meta-oe/recipes-support/libteam/libteam/0001-teamd-Pass-correct-parameter-type-to-accept-API.patch39
-rw-r--r--meta-oe/recipes-support/libteam/libteam/0002-teamd-Re-adjust-include-header-order.patch11
-rw-r--r--meta-oe/recipes-support/libteam/libteam_1.32.bb (renamed from meta-oe/recipes-support/libteam/libteam_1.31.bb)5
5 files changed, 43 insertions, 88 deletions
diff --git a/meta-oe/recipes-support/libteam/libteam/0001-include-sys-select.h-for-fd_set-definition.patch b/meta-oe/recipes-support/libteam/libteam/0001-include-sys-select.h-for-fd_set-definition.patch
deleted file mode 100644
index f0bd53ee8..000000000
--- a/meta-oe/recipes-support/libteam/libteam/0001-include-sys-select.h-for-fd_set-definition.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From 0ab69dc18a2057ff5bf41abcdf2b983b72d5a903 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 12 Jul 2017 15:34:49 -0700
4Subject: [PATCH 1/2] include sys/select.h for fd_set definition
5
6Fixes
7teamnl.c:160:2: error: unknown type name 'fd_set'; did you mean 'fpos_t'?
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11Upstream-Status: Pending
12
13 utils/teamnl.c | 1 +
14 1 file changed, 1 insertion(+)
15
16diff --git a/utils/teamnl.c b/utils/teamnl.c
17index e8de7e2..25129e8 100644
18--- a/utils/teamnl.c
19+++ b/utils/teamnl.c
20@@ -24,6 +24,7 @@
21 #include <getopt.h>
22 #include <errno.h>
23 #include <sys/signalfd.h>
24+#include <sys/select.h>
25 #include <signal.h>
26 #include <unistd.h>
27 #include <team.h>
28--
292.13.2
30
diff --git a/meta-oe/recipes-support/libteam/libteam/0001-teamd-Include-missing-headers-for-strrchr-and-memcmp.patch b/meta-oe/recipes-support/libteam/libteam/0001-teamd-Include-missing-headers-for-strrchr-and-memcmp.patch
deleted file mode 100644
index 5f8e56177..000000000
--- a/meta-oe/recipes-support/libteam/libteam/0001-teamd-Include-missing-headers-for-strrchr-and-memcmp.patch
+++ /dev/null
@@ -1,46 +0,0 @@
1From 49693cac37ee35ff673240c8060201efe0d999c2 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 24 Aug 2022 22:27:03 -0700
4Subject: [PATCH] teamd: Include missing headers for strrchr and memcmp
5
6Compiler does not see the prototype for these functions otherwise and
7build fails e.g.
8
9| ../../git/teamd/teamd_phys_port_check.c:52:10: error: call to undeclared library function 'strrchr' with type 'char *(const char *, int)'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
10| start = strrchr(link, '/');
11| ^
12
13Upstream-Status: Submitted [https://github.com/jpirko/libteam/pull/68]
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 teamd/teamd_phys_port_check.c | 1 +
17 teamd/teamd_runner_loadbalance.c | 1 +
18 2 files changed, 2 insertions(+)
19
20diff --git a/teamd/teamd_phys_port_check.c b/teamd/teamd_phys_port_check.c
21index 1eec129..c2454ab 100644
22--- a/teamd/teamd_phys_port_check.c
23+++ b/teamd/teamd_phys_port_check.c
24@@ -19,6 +19,7 @@
25
26 #include <stdio.h>
27 #include <errno.h>
28+#include <string.h>
29 #include <sys/types.h>
30 #include <sys/stat.h>
31 #include <unistd.h>
32diff --git a/teamd/teamd_runner_loadbalance.c b/teamd/teamd_runner_loadbalance.c
33index a581472..421a7c6 100644
34--- a/teamd/teamd_runner_loadbalance.c
35+++ b/teamd/teamd_runner_loadbalance.c
36@@ -17,6 +17,7 @@
37 * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
38 */
39
40+#include <string.h>
41 #include <sys/socket.h>
42 #include <linux/netdevice.h>
43 #include <team.h>
44--
452.37.2
46
diff --git a/meta-oe/recipes-support/libteam/libteam/0001-teamd-Pass-correct-parameter-type-to-accept-API.patch b/meta-oe/recipes-support/libteam/libteam/0001-teamd-Pass-correct-parameter-type-to-accept-API.patch
new file mode 100644
index 000000000..074060119
--- /dev/null
+++ b/meta-oe/recipes-support/libteam/libteam/0001-teamd-Pass-correct-parameter-type-to-accept-API.patch
@@ -0,0 +1,39 @@
1From e6ba4c16da808e47891241452a927b7f558a6420 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 11 May 2024 23:11:22 -0700
4Subject: [patch libteam] teamd: Pass correct parameter type to accept API
5
6accept() expects sockaddr as second parameter
7
8int accept (int, struct sockaddr *__restrict, socklen_t *__restrict);
9
10Fixes build with gcc-16 on musl systems
11| ../../git/teamd/teamd_usock.c: In function 'callback_usock':
12| ../../git/teamd/teamd_usock.c:280:40: error: passing argument 2 of 'accept' from incompatible pointer type [-Wincompatible-pointer-types]
13| 280 | sock = accept(ctx->usock.sock, &addr, &alen);
14| | ^~~~~
15| | |
16| | struct sockaddr_un *
17
18Upstream-Status: Submitted [https://lists.fedorahosted.org/archives/list/libteam@lists.fedorahosted.org/2024/5/]
19Signed-off-by: Khem Raj <raj.khem@gmail.com>
20---
21 teamd/teamd_usock.c | 2 +-
22 1 file changed, 1 insertion(+), 1 deletion(-)
23
24diff --git a/teamd/teamd_usock.c b/teamd/teamd_usock.c
25index 1adfdf8..5895124 100644
26--- a/teamd/teamd_usock.c
27+++ b/teamd/teamd_usock.c
28@@ -277,7 +277,7 @@ static int callback_usock(struct teamd_context *ctx, int events, void *priv)
29 int err;
30
31 alen = sizeof(addr);
32- sock = accept(ctx->usock.sock, &addr, &alen);
33+ sock = accept(ctx->usock.sock, (struct sockaddr *)&addr, &alen);
34 if (sock == -1) {
35 teamd_log_err("usock: Failed to accept connection.");
36 return -errno;
37--
382.45.0
39
diff --git a/meta-oe/recipes-support/libteam/libteam/0002-teamd-Re-adjust-include-header-order.patch b/meta-oe/recipes-support/libteam/libteam/0002-teamd-Re-adjust-include-header-order.patch
index ed877a721..030140ad4 100644
--- a/meta-oe/recipes-support/libteam/libteam/0002-teamd-Re-adjust-include-header-order.patch
+++ b/meta-oe/recipes-support/libteam/libteam/0002-teamd-Re-adjust-include-header-order.patch
@@ -17,19 +17,15 @@ Upstream-Status: Pending
17 teamd/teamd_runner_lacp.c | 2 +- 17 teamd/teamd_runner_lacp.c | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-) 18 1 file changed, 1 insertion(+), 1 deletion(-)
19 19
20diff --git a/teamd/teamd_runner_lacp.c b/teamd/teamd_runner_lacp.c
21index 9c77fae..8800854 100644
22--- a/teamd/teamd_runner_lacp.c 20--- a/teamd/teamd_runner_lacp.c
23+++ b/teamd/teamd_runner_lacp.c 21+++ b/teamd/teamd_runner_lacp.c
24@@ -23,6 +23,7 @@ 22@@ -23,12 +23,12 @@
25 #include <unistd.h> 23 #include <unistd.h>
26 #include <limits.h> 24 #include <limits.h>
27 #include <sys/ioctl.h> 25 #include <sys/ioctl.h>
28+#include <net/ethernet.h> 26+#include <net/ethernet.h>
29 #include <linux/if_ether.h>
30 #include <sys/socket.h> 27 #include <sys/socket.h>
31 #include <linux/netdevice.h> 28 #include <netinet/in.h>
32@@ -30,7 +31,6 @@
33 #include <errno.h> 29 #include <errno.h>
34 #include <team.h> 30 #include <team.h>
35 #include <private/misc.h> 31 #include <private/misc.h>
@@ -37,6 +33,3 @@ index 9c77fae..8800854 100644
37 33
38 #include "teamd.h" 34 #include "teamd.h"
39 #include "teamd_config.h" 35 #include "teamd_config.h"
40--
412.13.2
42
diff --git a/meta-oe/recipes-support/libteam/libteam_1.31.bb b/meta-oe/recipes-support/libteam/libteam_1.32.bb
index 6fe10abe0..508cbb13b 100644
--- a/meta-oe/recipes-support/libteam/libteam_1.31.bb
+++ b/meta-oe/recipes-support/libteam/libteam_1.32.bb
@@ -8,15 +8,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
8DEPENDS = "libnl libdaemon jansson" 8DEPENDS = "libnl libdaemon jansson"
9 9
10SRC_URI = "git://github.com/jpirko/libteam;branch=master;protocol=https \ 10SRC_URI = "git://github.com/jpirko/libteam;branch=master;protocol=https \
11 file://0001-include-sys-select.h-for-fd_set-definition.patch \
12 file://0002-teamd-Re-adjust-include-header-order.patch \ 11 file://0002-teamd-Re-adjust-include-header-order.patch \
13 file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \ 12 file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \
14 file://0001-team_basic_test.py-switch-to-python3.patch \ 13 file://0001-team_basic_test.py-switch-to-python3.patch \
15 file://0001-team_basic_test.py-check-the-return-value.patch \ 14 file://0001-team_basic_test.py-check-the-return-value.patch \
16 file://0001-teamd-Include-missing-headers-for-strrchr-and-memcmp.patch \ 15 file://0001-teamd-Pass-correct-parameter-type-to-accept-API.patch \
17 file://run-ptest \ 16 file://run-ptest \
18 " 17 "
19SRCREV = "3ee12c6d569977cf1cd30d0da77807a07aa77158" 18SRCREV = "8b843e93cee1dab61fb79b01791201cdad45e1d1"
20 19
21S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
22 21