summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-03-18 00:19:49 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-17 19:46:35 -0700
commit28dd862c927f3791b6e7e8409b6c3d02a28eb6ee (patch)
tree3c663bd93809a72682a11820ea5d998c76b79fc9 /meta-oe
parent81a32ac4808646d44929f33929b41e8b1524fff7 (diff)
downloadmeta-openembedded-28dd862c927f3791b6e7e8409b6c3d02a28eb6ee.tar.gz
flatbuffers: upgrade 1.11.0 -> 1.12.0
0001-Add-detection-of-strtoull_l-function.patch removed since it is included in 1.12.0 Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/flatbuffers/flatbuffers/0001-Add-detection-of-strtoull_l-function.patch38
-rw-r--r--meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.12.0.bb (renamed from meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.11.0.bb)8
2 files changed, 3 insertions, 43 deletions
diff --git a/meta-oe/recipes-devtools/flatbuffers/flatbuffers/0001-Add-detection-of-strtoull_l-function.patch b/meta-oe/recipes-devtools/flatbuffers/flatbuffers/0001-Add-detection-of-strtoull_l-function.patch
deleted file mode 100644
index f3e82101b..000000000
--- a/meta-oe/recipes-devtools/flatbuffers/flatbuffers/0001-Add-detection-of-strtoull_l-function.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From bff7ffbc5130cd46caf33b76b4bb0593fcd15066 Mon Sep 17 00:00:00 2001
2From: Vladimir Glavnyy <31897320+vglavnyy@users.noreply.github.com>
3Date: Fri, 10 May 2019 00:15:29 +0700
4Subject: [PATCH] Add detection of strtoull_l function (#5333) (#5337)
5
6Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
7[Retrieved from:
8https://github.com/google/flatbuffers/commit/bff7ffbc5130cd46caf33b76b4bb0593fcd15066]
9---
10 CMakeLists.txt | 12 +++++++++---
11 1 file changed, 9 insertions(+), 3 deletions(-)
12
13diff --git a/CMakeLists.txt b/CMakeLists.txt
14index 0640c37b5..30be238fe 100644
15--- a/CMakeLists.txt
16+++ b/CMakeLists.txt
17@@ -42,12 +42,18 @@ if(DEFINED FLATBUFFERS_MAX_PARSING_DEPTH)
18 message(STATUS "FLATBUFFERS_MAX_PARSING_DEPTH: ${FLATBUFFERS_MAX_PARSING_DEPTH}")
19 endif()
20
21-# Auto-detect locale-narrow 'strtod_l' function.
22+# Auto-detect locale-narrow 'strtod_l' and 'strtoull_l' functions.
23 if(NOT DEFINED FLATBUFFERS_LOCALE_INDEPENDENT)
24+ set(FLATBUFFERS_LOCALE_INDEPENDENT 0)
25 if(MSVC)
26- check_cxx_symbol_exists(_strtof_l stdlib.h FLATBUFFERS_LOCALE_INDEPENDENT)
27+ check_cxx_symbol_exists(_strtof_l stdlib.h FLATBUFFERS_HAS_STRTOF_L)
28+ check_cxx_symbol_exists(_strtoui64_l stdlib.h FLATBUFFERS_HAS_STRTOULL_L)
29 else()
30- check_cxx_symbol_exists(strtof_l stdlib.h FLATBUFFERS_LOCALE_INDEPENDENT)
31+ check_cxx_symbol_exists(strtof_l stdlib.h FLATBUFFERS_HAS_STRTOF_L)
32+ check_cxx_symbol_exists(strtoull_l stdlib.h FLATBUFFERS_HAS_STRTOULL_L)
33+ endif()
34+ if(FLATBUFFERS_HAS_STRTOF_L AND FLATBUFFERS_HAS_STRTOULL_L)
35+ set(FLATBUFFERS_LOCALE_INDEPENDENT 1)
36 endif()
37 endif()
38 add_definitions(-DFLATBUFFERS_LOCALE_INDEPENDENT=$<BOOL:${FLATBUFFERS_LOCALE_INDEPENDENT}>)
diff --git a/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.11.0.bb b/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.12.0.bb
index 529441de1..c31cef63c 100644
--- a/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.11.0.bb
+++ b/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.12.0.bb
@@ -8,13 +8,11 @@ PACKAGE_BEFORE_PN = "${PN}-compiler"
8RDEPENDS_${PN}-compiler = "${PN}" 8RDEPENDS_${PN}-compiler = "${PN}"
9RDEPENDS_${PN}-dev += "${PN}-compiler" 9RDEPENDS_${PN}-dev += "${PN}-compiler"
10 10
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a873c5645c184d51e0f9b34e1d7cf559" 11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
12 12
13SRCREV = "9e7e8cbe9f675123dd41b7c62868acad39188cae" 13SRCREV = "6df40a2471737b27271bdd9b900ab5f3aec746c7"
14 14
15SRC_URI = "git://github.com/google/flatbuffers.git \ 15SRC_URI = "git://github.com/google/flatbuffers.git"
16 file://0001-Add-detection-of-strtoull_l-function.patch \
17 "
18 16
19# Make sure C++11 is used, required for example for GCC 4.9 17# Make sure C++11 is used, required for example for GCC 4.9
20CXXFLAGS += "-std=c++11 -fPIC" 18CXXFLAGS += "-std=c++11 -fPIC"