summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-03-18 00:19:48 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-17 19:46:35 -0700
commit81a32ac4808646d44929f33929b41e8b1524fff7 (patch)
tree616704340a55a0a3b8f04417401a99cebe36590b /meta-oe
parenta0b1694970cd6e5b0b807f30417a2b9150d32a02 (diff)
downloadmeta-openembedded-81a32ac4808646d44929f33929b41e8b1524fff7.tar.gz
c-ares: upgrade 1.15.0 -> 1.16.0
add 0001-fix-configure-error-mv-libcares.pc.cmakein-to-libcar.patch to fix error of do_configure refresh cmake-install-libcares.pc.patch Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/c-ares/c-ares/0001-fix-configure-error-mv-libcares.pc.cmakein-to-libcar.patch27
-rw-r--r--meta-oe/recipes-support/c-ares/c-ares/cmake-install-libcares.pc.patch54
-rw-r--r--meta-oe/recipes-support/c-ares/c-ares_1.16.0.bb (renamed from meta-oe/recipes-support/c-ares/c-ares_1.15.0.bb)5
3 files changed, 43 insertions, 43 deletions
diff --git a/meta-oe/recipes-support/c-ares/c-ares/0001-fix-configure-error-mv-libcares.pc.cmakein-to-libcar.patch b/meta-oe/recipes-support/c-ares/c-ares/0001-fix-configure-error-mv-libcares.pc.cmakein-to-libcar.patch
new file mode 100644
index 000000000..8f15f8424
--- /dev/null
+++ b/meta-oe/recipes-support/c-ares/c-ares/0001-fix-configure-error-mv-libcares.pc.cmakein-to-libcar.patch
@@ -0,0 +1,27 @@
1From f2f1e134bf5d9d0789942848e03006af8d926cf8 Mon Sep 17 00:00:00 2001
2From: Wang Mingyu <wangmy@cn.fujitsu.com>
3Date: Tue, 17 Mar 2020 12:53:35 +0800
4Subject: [PATCH] fix configure error : mv libcares.pc.cmakein to
5 libcares.pc.cmake
6
7Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com>
8---
9 CMakeLists.txt | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/CMakeLists.txt b/CMakeLists.txt
13index 3a5878d..c2e5740 100644
14--- a/CMakeLists.txt
15+++ b/CMakeLists.txt
16@@ -563,7 +563,7 @@ IF (CARES_STATIC)
17 ENDIF()
18
19 # Write ares_config.h configuration file. This is used only for the build.
20-CONFIGURE_FILE (libcares.pc.cmakein ${PROJECT_BINARY_DIR}/libcares.pc @ONLY)
21+CONFIGURE_FILE (libcares.pc.cmake ${PROJECT_BINARY_DIR}/libcares.pc @ONLY)
22
23
24
25--
262.17.1
27
diff --git a/meta-oe/recipes-support/c-ares/c-ares/cmake-install-libcares.pc.patch b/meta-oe/recipes-support/c-ares/c-ares/cmake-install-libcares.pc.patch
index 8cadb2bba..0eb7e4bbb 100644
--- a/meta-oe/recipes-support/c-ares/c-ares/cmake-install-libcares.pc.patch
+++ b/meta-oe/recipes-support/c-ares/c-ares/cmake-install-libcares.pc.patch
@@ -12,39 +12,37 @@ update to 1.14.0, fix patch warning
12 12
13Signed-off-by: Changqing Li <changqing.li@windriver.com> 13Signed-off-by: Changqing Li <changqing.li@windriver.com>
14--- 14---
15 CMakeLists.txt | 23 +++++++++++++++++++++++ 15 CMakeLists.txt | 28 +++++++++++++++++++++++-----
16 libcares.pc.cmakein | 20 ++++++++++++++++++++ 16 1 file changed, 23 insertions(+), 5 deletions(-)
17 2 files changed, 43 insertions(+)
18 create mode 100644 libcares.pc.cmakein
19 17
20diff --git a/CMakeLists.txt b/CMakeLists.txt 18diff --git a/CMakeLists.txt b/CMakeLists.txt
21index 60a880c..71eaa53 100644 19index fd123e1..3a5878d 100644
22--- a/CMakeLists.txt 20--- a/CMakeLists.txt
23+++ b/CMakeLists.txt 21+++ b/CMakeLists.txt
24@@ -193,22 +193,30 @@ ADD_DEFINITIONS(${SYSFLAGS}) 22@@ -214,22 +214,25 @@ ADD_DEFINITIONS(${SYSFLAGS})
25 23
26 24
27 # Tell C-Ares about libraries to depend on 25 # Tell C-Ares about libraries to depend on
28+# Also pass these libraries to pkg-config file 26+# Also pass these libraries to pkg-config file
29+SET(CARES_PRIVATE_LIBS_LIST) 27+SET(CARES_PRIVATE_LIBS_LIST)
30 IF (HAVE_LIBRESOLV) 28 IF (HAVE_LIBRESOLV)
31 LIST (APPEND CARES_DEPENDENT_LIBS resolv) 29- LIST (APPEND CARES_DEPENDENT_LIBS resolv)
32+ LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lresolv") 30+ LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lresolv")
33 ENDIF () 31 ENDIF ()
34 IF (HAVE_LIBNSL) 32 IF (HAVE_LIBNSL)
35 LIST (APPEND CARES_DEPENDENT_LIBS nsl) 33- LIST (APPEND CARES_DEPENDENT_LIBS nsl)
36+ LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lnsl") 34+ LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lnsl")
37 ENDIF () 35 ENDIF ()
38 IF (HAVE_LIBSOCKET) 36 IF (HAVE_LIBSOCKET)
39 LIST (APPEND CARES_DEPENDENT_LIBS socket) 37- LIST (APPEND CARES_DEPENDENT_LIBS socket)
40+ LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lsocket") 38+ LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lsocket")
41 ENDIF () 39 ENDIF ()
42 IF (HAVE_LIBRT) 40 IF (HAVE_LIBRT)
43 LIST (APPEND CARES_DEPENDENT_LIBS rt) 41- LIST (APPEND CARES_DEPENDENT_LIBS rt)
44+ LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lrt") 42+ LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lrt")
45 ENDIF () 43 ENDIF ()
46 IF (WIN32) 44 IF (WIN32)
47 LIST (APPEND CARES_DEPENDENT_LIBS ws2_32) 45- LIST (APPEND CARES_DEPENDENT_LIBS ws2_32 Advapi32)
48+ LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lws2_32") 46+ LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lws2_32")
49 ENDIF () 47 ENDIF ()
50 48
@@ -52,7 +50,7 @@ index 60a880c..71eaa53 100644
52 50
53 # When checking for symbols, we need to make sure we set the proper 51 # When checking for symbols, we need to make sure we set the proper
54 # headers, libraries, and definitions for the detection to work properly 52 # headers, libraries, and definitions for the detection to work properly
55@@ -514,6 +522,15 @@ CONFIGURE_FILE (ares_build.h.cmake ${PROJECT_BINARY_DIR}/ares_build.h) 53@@ -554,6 +557,15 @@ CONFIGURE_FILE (ares_build.h.cmake ${PROJECT_BINARY_DIR}/ares_build.h)
56 # Write ares_config.h configuration file. This is used only for the build. 54 # Write ares_config.h configuration file. This is used only for the build.
57 CONFIGURE_FILE (ares_config.h.cmake ${PROJECT_BINARY_DIR}/ares_config.h) 55 CONFIGURE_FILE (ares_config.h.cmake ${PROJECT_BINARY_DIR}/ares_config.h)
58 56
@@ -68,8 +66,8 @@ index 60a880c..71eaa53 100644
68 66
69 # TRANSFORM_MAKEFILE_INC 67 # TRANSFORM_MAKEFILE_INC
70 # 68 #
71@@ -664,6 +681,12 @@ IF (CARES_INSTALL) 69@@ -728,6 +740,12 @@ IF (CARES_INSTALL)
72 INSTALL (FILES "${CMAKE_CURRENT_BINARY_DIR}/libcares.pc" DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig") 70 INSTALL (FILES "${CMAKE_CURRENT_BINARY_DIR}/libcares.pc" COMPONENT Devel DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
73 ENDIF () 71 ENDIF ()
74 72
75+# pkg-config file 73+# pkg-config file
@@ -81,32 +79,6 @@ index 60a880c..71eaa53 100644
81 # Legacy chain-building variables (provided for compatibility with old code). 79 # Legacy chain-building variables (provided for compatibility with old code).
82 # Don't use these, external code should be updated to refer to the aliases directly (e.g., Cares::cares). 80 # Don't use these, external code should be updated to refer to the aliases directly (e.g., Cares::cares).
83 SET (CARES_FOUND 1 CACHE INTERNAL "CARES LIBRARY FOUND") 81 SET (CARES_FOUND 1 CACHE INTERNAL "CARES LIBRARY FOUND")
84diff --git a/libcares.pc.cmakein b/libcares.pc.cmakein
85new file mode 100644
86index 0000000..3579256
87--- /dev/null
88+++ b/libcares.pc.cmakein
89@@ -0,0 +1,20 @@
90+#***************************************************************************
91+# Project ___ __ _ _ __ ___ ___
92+# / __|____ / _` | '__/ _ \/ __|
93+# | (_|_____| (_| | | | __/\__ \
94+# \___| \__,_|_| \___||___/
95+#
96+prefix=@CMAKE_INSTALL_PREFIX@
97+exec_prefix=@CMAKE_INSTALL_PREFIX@
98+libdir=@CMAKE_INSTALL_FULL_LIBDIR@
99+includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
100+
101+Name: c-ares
102+URL: http://daniel.haxx.se/projects/c-ares/
103+Description: asynchronous DNS lookup library
104+Version: @VERSION@
105+Requires:
106+Requires.private:
107+Cflags: -I${includedir} @CPPFLAG_CARES_STATICLIB@
108+Libs: -L${libdir} -lcares
109+Libs.private: @CARES_PRIVATE_LIBS@
110-- 82--
1112.7.4 832.17.1
112 84
diff --git a/meta-oe/recipes-support/c-ares/c-ares_1.15.0.bb b/meta-oe/recipes-support/c-ares/c-ares_1.16.0.bb
index d437529dc..e235b9b95 100644
--- a/meta-oe/recipes-support/c-ares/c-ares_1.15.0.bb
+++ b/meta-oe/recipes-support/c-ares/c-ares_1.16.0.bb
@@ -5,13 +5,14 @@ SECTION = "libs"
5LICENSE = "MIT" 5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.md;md5=fb997454c8d62aa6a47f07a8cd48b006" 6LIC_FILES_CHKSUM = "file://LICENSE.md;md5=fb997454c8d62aa6a47f07a8cd48b006"
7 7
8PV = "1.15.0+gitr${SRCPV}" 8PV = "1.16.0+gitr${SRCPV}"
9 9
10SRC_URI = "\ 10SRC_URI = "\
11 git://github.com/c-ares/c-ares.git \ 11 git://github.com/c-ares/c-ares.git \
12 file://cmake-install-libcares.pc.patch \ 12 file://cmake-install-libcares.pc.patch \
13 file://0001-fix-configure-error-mv-libcares.pc.cmakein-to-libcar.patch \
13" 14"
14SRCREV = "e982924acee7f7313b4baa4ee5ec000c5e373c30" 15SRCREV = "077a587dccbe2f0d8a1987fbd3525333705c2249"
15 16
16UPSTREAM_CHECK_GITTAGREGEX = "cares-(?P<pver>\d+_(\d_?)+)" 17UPSTREAM_CHECK_GITTAGREGEX = "cares-(?P<pver>\d+_(\d_?)+)"
17 18