diff options
author | Bartosz Golaszewski <bgolaszewski@baylibre.com> | 2020-09-28 14:45:26 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-10-05 10:47:38 -0700 |
commit | 1ea3e2c4d25c58efd1dc33d8a0e945ae069f673a (patch) | |
tree | fd6fab92a900b6b9cdec5441a65566813c606a4f /meta-oe | |
parent | e82caab8059c00a8313dfb10d7327e9f25f58ba2 (diff) | |
download | meta-openembedded-1ea3e2c4d25c58efd1dc33d8a0e945ae069f673a.tar.gz |
libgpiod: consolidate the recipe files
After dropping the support for v0.3.x, we no longer need the split into
.bb and .inc files. Let's move the contents of libgpiod.inc into
libgpiod_1.4.4.bb.
While at it: do some refactoring: let's use ${BPN} in the URL, consolidate
certain variables and add some explanatory comments.
Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/libgpiod/libgpiod.inc | 19 | ||||
-rw-r--r-- | meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb | 24 |
2 files changed, 19 insertions, 24 deletions
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod.inc b/meta-oe/recipes-support/libgpiod/libgpiod.inc deleted file mode 100644 index cae3145dd..000000000 --- a/meta-oe/recipes-support/libgpiod/libgpiod.inc +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | SUMMARY = "C library and tools for interacting with the linux GPIO character device" | ||
2 | |||
3 | LICENSE = "LGPLv2.1+" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de" | ||
5 | |||
6 | SRC_URI = "https://www.kernel.org/pub/software/libs/libgpiod/${BP}.tar.xz" | ||
7 | |||
8 | inherit autotools pkgconfig | ||
9 | |||
10 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev" | ||
11 | |||
12 | EXTRA_OECONF = "--enable-tools" | ||
13 | |||
14 | PACKAGES =+ " ${PN}-tools" | ||
15 | |||
16 | FILES_${PN}-tools = "${bindir}/*" | ||
17 | |||
18 | PACKAGES =+ "libgpiodcxx" | ||
19 | FILES_libgpiodcxx = "${libdir}/libgpiodcxx.so.*" | ||
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb b/meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb index b5a64a554..6433675ca 100644 --- a/meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb +++ b/meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb | |||
@@ -1,17 +1,31 @@ | |||
1 | require libgpiod.inc | 1 | SUMMARY = "C library and tools for interacting with the linux GPIO character device" |
2 | AUTHOR = "Bartosz Golaszewski <bgolaszewski@baylibre.com>" | ||
2 | 3 | ||
3 | DEPENDS += "autoconf-archive-native" | 4 | LICENSE = "LGPLv2.1+" |
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de" | ||
4 | 6 | ||
7 | SRC_URI = "https://www.kernel.org/pub/software/libs/${BPN}/${BP}.tar.xz" | ||
5 | SRC_URI[md5sum] = "064c2627397e6641c52de09a26951112" | 8 | SRC_URI[md5sum] = "064c2627397e6641c52de09a26951112" |
6 | SRC_URI[sha256sum] = "f1cda2789e6a13a92aefc012a76e5a7cc57a1b402d66f71df8719ee314b67699" | 9 | SRC_URI[sha256sum] = "f1cda2789e6a13a92aefc012a76e5a7cc57a1b402d66f71df8719ee314b67699" |
7 | 10 | ||
8 | # enable cxx bindings | 11 | inherit autotools pkgconfig python3native |
9 | PACKAGECONFIG ?= "cxx" | ||
10 | 12 | ||
13 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev" | ||
11 | PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx" | 14 | PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx" |
12 | PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3" | 15 | PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3" |
13 | 16 | ||
14 | inherit python3native | 17 | # Enable cxx bindings by default. |
18 | PACKAGECONFIG ?= "cxx" | ||
19 | |||
20 | # Always build tools - they don't have any additional | ||
21 | # requirements over the library. | ||
22 | EXTRA_OECONF = "--enable-tools" | ||
23 | |||
24 | DEPENDS += "autoconf-archive-native" | ||
25 | |||
26 | PACKAGES =+ "${PN}-tools libgpiodcxx" | ||
27 | FILES_${PN}-tools = "${bindir}/*" | ||
28 | FILES_libgpiodcxx = "${libdir}/libgpiodcxx.so.*" | ||
15 | 29 | ||
16 | PACKAGES =+ "${PN}-python" | 30 | PACKAGES =+ "${PN}-python" |
17 | FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" | 31 | FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" |