summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb')
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb24
1 files changed, 19 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb b/meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb
index b5a64a554..6433675ca 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb
+++ b/meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb
@@ -1,17 +1,31 @@
1require libgpiod.inc 1SUMMARY = "C library and tools for interacting with the linux GPIO character device"
2AUTHOR = "Bartosz Golaszewski <bgolaszewski@baylibre.com>"
2 3
3DEPENDS += "autoconf-archive-native" 4LICENSE = "LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
4 6
7SRC_URI = "https://www.kernel.org/pub/software/libs/${BPN}/${BP}.tar.xz"
5SRC_URI[md5sum] = "064c2627397e6641c52de09a26951112" 8SRC_URI[md5sum] = "064c2627397e6641c52de09a26951112"
6SRC_URI[sha256sum] = "f1cda2789e6a13a92aefc012a76e5a7cc57a1b402d66f71df8719ee314b67699" 9SRC_URI[sha256sum] = "f1cda2789e6a13a92aefc012a76e5a7cc57a1b402d66f71df8719ee314b67699"
7 10
8# enable cxx bindings 11inherit autotools pkgconfig python3native
9PACKAGECONFIG ?= "cxx"
10 12
13PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
11PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx" 14PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx"
12PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3" 15PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3"
13 16
14inherit python3native 17# Enable cxx bindings by default.
18PACKAGECONFIG ?= "cxx"
19
20# Always build tools - they don't have any additional
21# requirements over the library.
22EXTRA_OECONF = "--enable-tools"
23
24DEPENDS += "autoconf-archive-native"
25
26PACKAGES =+ "${PN}-tools libgpiodcxx"
27FILES_${PN}-tools = "${bindir}/*"
28FILES_libgpiodcxx = "${libdir}/libgpiodcxx.so.*"
15 29
16PACKAGES =+ "${PN}-python" 30PACKAGES =+ "${PN}-python"
17FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" 31FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"