summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-08-20 22:05:31 -0700
committerKhem Raj <raj.khem@gmail.com>2023-08-20 22:13:17 -0700
commitc817d19fa9b702dcf54e8f3f5bb7be4d05f86d1f (patch)
treebdc041ef10a5b80e91c89659fec98d6a7c1cb8d6 /meta-oe/recipes-support
parentc1dd0ff02dc804002cdf0a05b1742623612e524e (diff)
downloadmeta-openembedded-c817d19fa9b702dcf54e8f3f5bb7be4d05f86d1f.tar.gz
liburing: Upgrade to 2.4 release
- Upgrade to latest release 2.4 [1] - Drop a patch available in 2.4 release - Backport a parallel build race fix [1] https://github.com/axboe/liburing/releases/tag/liburing-2.4 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/liburing/liburing/0001-Fixes-build-failure-on-.-configure-make-shuffle-2836.patch34
-rw-r--r--meta-oe/recipes-support/liburing/liburing/0001-examples-test-Remove-unused-linux-errqueue.h.patch47
-rw-r--r--meta-oe/recipes-support/liburing/liburing_2.4.bb (renamed from meta-oe/recipes-support/liburing/liburing_2.3.bb)5
3 files changed, 36 insertions, 50 deletions
diff --git a/meta-oe/recipes-support/liburing/liburing/0001-Fixes-build-failure-on-.-configure-make-shuffle-2836.patch b/meta-oe/recipes-support/liburing/liburing/0001-Fixes-build-failure-on-.-configure-make-shuffle-2836.patch
new file mode 100644
index 000000000..0cf8548e4
--- /dev/null
+++ b/meta-oe/recipes-support/liburing/liburing/0001-Fixes-build-failure-on-.-configure-make-shuffle-2836.patch
@@ -0,0 +1,34 @@
1From c34dca74854cb6e7f2b09affa2a4ab0145e62371 Mon Sep 17 00:00:00 2001
2From: Kartik Mahajan <stonebrakert6@gmail.com>
3Date: Fri, 30 Jun 2023 11:34:07 +0530
4Subject: [PATCH] Fixes build failure on ./configure && make
5 --shuffle=2836571325
6
7./configure && make --shuffle=2836571325 fails.
8The build fails on parallel builds for me and above command reproduces it.
9Note that --shuffle options is available on make version >= 4.4
10Target ffi_libname in src/Makefile should have a additional dependency
11upon $(liburing_sobjs)
12
13Upstream-Status: Backport [https://github.com/axboe/liburing/commit/c34dca74854cb6e7f2b09affa2a4ab0145e62371]
14Signed-off-by: Kartik Mahajan <stonebrakert6@gmail.com>
15---
16 src/Makefile | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/src/Makefile b/src/Makefile
20index c4c28cb..7832095 100644
21--- a/src/Makefile
22+++ b/src/Makefile
23@@ -81,7 +81,7 @@ liburing-ffi.a: $(liburing_objs) $(liburing_ffi_objs)
24 $(libname): $(liburing_sobjs) liburing.map
25 $(QUIET_CC)$(CC) $(SO_CFLAGS) -shared -Wl,--version-script=liburing.map -Wl,-soname=$(soname) -o $@ $(liburing_sobjs) $(LINK_FLAGS)
26
27-$(ffi_libname): $(liburing_ffi_objs) $(liburing_ffi_sobjs) liburing-ffi.map
28+$(ffi_libname): $(liburing_ffi_objs) $(liburing_ffi_sobjs) $(liburing_sobjs) liburing-ffi.map
29 $(QUIET_CC)$(CC) $(SO_CFLAGS) -shared -Wl,--version-script=liburing-ffi.map -Wl,-soname=$(ffi_soname) -o $@ $(liburing_sobjs) $(liburing_ffi_sobjs) $(LINK_FLAGS)
30
31 install: $(all_targets)
32--
332.41.0
34
diff --git a/meta-oe/recipes-support/liburing/liburing/0001-examples-test-Remove-unused-linux-errqueue.h.patch b/meta-oe/recipes-support/liburing/liburing/0001-examples-test-Remove-unused-linux-errqueue.h.patch
deleted file mode 100644
index 21aaf8d99..000000000
--- a/meta-oe/recipes-support/liburing/liburing/0001-examples-test-Remove-unused-linux-errqueue.h.patch
+++ /dev/null
@@ -1,47 +0,0 @@
1From 0fbcc44fe1fb2dc6807660b2cff1c2995add095b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 18 Feb 2023 18:01:22 -0800
4Subject: [PATCH] examples,test: Remove unused linux/errqueue.h
5
6This header is not needed therefore remove it, this cleanup also helps
7compiling on musl/clang
8
9/usr/include/linux/errqueue.h:57:20: error: array has incomplete element typ
10e 'struct timespec'
11 struct timespec ts[3];
12 ^
13
14Upstream-Status: Submitted [https://github.com/axboe/liburing/pull/798]
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16---
17 examples/send-zerocopy.c | 1 -
18 test/send-zerocopy.c | 1 -
19 2 files changed, 2 deletions(-)
20
21diff --git a/examples/send-zerocopy.c b/examples/send-zerocopy.c
22index 6092af9..cf1fa8b 100644
23--- a/examples/send-zerocopy.c
24+++ b/examples/send-zerocopy.c
25@@ -13,7 +13,6 @@
26 #include <string.h>
27
28 #include <arpa/inet.h>
29-#include <linux/errqueue.h>
30 #include <linux/if_packet.h>
31 #include <linux/ipv6.h>
32 #include <linux/socket.h>
33diff --git a/test/send-zerocopy.c b/test/send-zerocopy.c
34index 86a31cd..5d578c6 100644
35--- a/test/send-zerocopy.c
36+++ b/test/send-zerocopy.c
37@@ -11,7 +11,6 @@
38 #include <string.h>
39
40 #include <arpa/inet.h>
41-#include <linux/errqueue.h>
42 #include <linux/if_packet.h>
43 #include <linux/ipv6.h>
44 #include <linux/socket.h>
45--
462.39.2
47
diff --git a/meta-oe/recipes-support/liburing/liburing_2.3.bb b/meta-oe/recipes-support/liburing/liburing_2.4.bb
index 7d8c2f596..e5dba70df 100644
--- a/meta-oe/recipes-support/liburing/liburing_2.3.bb
+++ b/meta-oe/recipes-support/liburing/liburing_2.4.bb
@@ -10,12 +10,11 @@ LICENSE = "LGPL-2.1-only | MIT"
10LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=2b0e9926530c269f5ae95560370195af" 10LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=2b0e9926530c269f5ae95560370195af"
11 11
12SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \ 12SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \
13 file://0001-examples-test-Remove-unused-linux-errqueue.h.patch" 13 file://0001-Fixes-build-failure-on-.-configure-make-shuffle-2836.patch"
14SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch " 14SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch "
15SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch " 15SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch "
16SRCREV = "f5cac78e621ab452d3035902085f66d2bf73243b" 16SRCREV = "298c083d75ecde5a8833366167b3b6abff0c8d39"
17 17
18PV .= "+2.4+git${SRCPV}"
19S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
20 19
21DEPENDS:append:libc-musl = " libucontext" 20DEPENDS:append:libc-musl = " libucontext"