summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/liburing/liburing_2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/liburing/liburing_2.4.bb')
-rw-r--r--meta-oe/recipes-support/liburing/liburing_2.4.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/liburing/liburing_2.4.bb b/meta-oe/recipes-support/liburing/liburing_2.4.bb
new file mode 100644
index 000000000..e5dba70df
--- /dev/null
+++ b/meta-oe/recipes-support/liburing/liburing_2.4.bb
@@ -0,0 +1,32 @@
1SUMMARY = "This is the io_uring library, liburing."
2DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \
3instances, and also a simplified interface for applications that don't need \
4(or want) to deal with the full kernel side implementation."
5HOMEPAGE = "https://github.com/axboe/liburing"
6BUGTRACKER = "https://github.com/axboe/liburing/issues"
7SECTION = "libs"
8
9LICENSE = "LGPL-2.1-only | MIT"
10LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=2b0e9926530c269f5ae95560370195af"
11
12SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \
13 file://0001-Fixes-build-failure-on-.-configure-make-shuffle-2836.patch"
14SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch "
15SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch "
16SRCREV = "298c083d75ecde5a8833366167b3b6abff0c8d39"
17
18S = "${WORKDIR}/git"
19
20DEPENDS:append:libc-musl = " libucontext"
21XCFLAGS = "-pthread"
22XCFLAGS:append:libc-musl = " -lucontext"
23
24EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'"
25do_configure() {
26 ${S}/configure --prefix=${prefix} --libdir=${libdir} --libdevdir=${libdir} --mandir=${mandir} --datadir=${datadir} --includedir=${includedir}
27}
28do_install () {
29 oe_runmake install DESTDIR=${D}
30}
31
32BBCLASSEXTEND = "native nativesdk"