summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/postgresql/postgresql-9.2.4
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/postgresql/postgresql-9.2.4
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/postgresql/postgresql-9.2.4')
-rw-r--r--meta-oe/recipes-support/postgresql/postgresql-9.2.4/ecpg-parallel-make-fix.patch31
-rw-r--r--meta-oe/recipes-support/postgresql/postgresql-9.2.4/remove.autoconf.version.check.patch15
2 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/postgresql/postgresql-9.2.4/ecpg-parallel-make-fix.patch b/meta-oe/recipes-support/postgresql/postgresql-9.2.4/ecpg-parallel-make-fix.patch
new file mode 100644
index 000000000..63615cd51
--- /dev/null
+++ b/meta-oe/recipes-support/postgresql/postgresql-9.2.4/ecpg-parallel-make-fix.patch
@@ -0,0 +1,31 @@
1Upstream-status: backport
2
3From 602070f9cce790debd8d1469254e7726ab499ae7 Mon Sep 17 00:00:00 2001
4From: Peter Eisentraut <peter_e@gmx.net>
5Date: Fri, 29 Mar 2013 21:39:55 -0400
6Subject: [PATCH] ecpg: Parallel make fix
7
8In some parallel make situations, the install-headers target could be
9called before the installation directories are created by installdirs,
10causing the installation to fail. Fix that by making install-headers
11depend on installdirs.
12---
13 src/interfaces/ecpg/include/Makefile | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/src/interfaces/ecpg/include/Makefile b/src/interfaces/ecpg/include/Makefile
17index eab833b..e92e56f 100644
18--- a/src/interfaces/ecpg/include/Makefile
19+++ b/src/interfaces/ecpg/include/Makefile
20@@ -18,7 +18,7 @@ ecpg_headers = ecpgerrno.h ecpglib.h ecpgtype.h sqlca.h sql3types.h ecpg_informi
21 sqlda.h sqlda-compat.h sqlda-native.h
22 informix_headers = datetime.h decimal.h sqltypes.h
23
24-install-headers: $(ecpg_headers) $(informix_headers)
25+install-headers: $(ecpg_headers) $(informix_headers) installdirs
26 $(INSTALL_DATA) $(addprefix $(srcdir)/,$(ecpg_headers)) '$(DESTDIR)$(includedir)/'
27 $(INSTALL_DATA) $(addprefix $(srcdir)/,$(informix_headers)) '$(DESTDIR)$(informix_esql_dir)/'
28 $(INSTALL_DATA) $(ecpg_config_h) '$(DESTDIR)$(includedir)'
29--
301.8.3.4
31
diff --git a/meta-oe/recipes-support/postgresql/postgresql-9.2.4/remove.autoconf.version.check.patch b/meta-oe/recipes-support/postgresql/postgresql-9.2.4/remove.autoconf.version.check.patch
new file mode 100644
index 000000000..022aa3d76
--- /dev/null
+++ b/meta-oe/recipes-support/postgresql/postgresql-9.2.4/remove.autoconf.version.check.patch
@@ -0,0 +1,15 @@
1Index: postgresql-9.2.4/configure.in
2===================================================================
3--- postgresql-9.2.4.orig/configure.in
4+++ postgresql-9.2.4/configure.in
5@@ -19,10 +19,6 @@ m4_pattern_forbid(^PGAC_)dnl to catch un
6
7 AC_INIT([PostgreSQL], [9.2.4], [pgsql-bugs@postgresql.org])
8
9-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.63], [], [m4_fatal([Autoconf version 2.63 is required.
10-Untested combinations of 'autoconf' and PostgreSQL versions are not
11-recommended. You can remove the check from 'configure.in' but it is then
12-your responsibility whether the result works or not.])])
13 AC_COPYRIGHT([Copyright (c) 1996-2012, PostgreSQL Global Development Group])
14 AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
15 AC_CONFIG_AUX_DIR(config)