summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/postgresql/postgresql-9.2.4/ecpg-parallel-make-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/postgresql/postgresql-9.2.4/ecpg-parallel-make-fix.patch')
-rw-r--r--meta-oe/recipes-support/postgresql/postgresql-9.2.4/ecpg-parallel-make-fix.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/postgresql/postgresql-9.2.4/ecpg-parallel-make-fix.patch b/meta-oe/recipes-support/postgresql/postgresql-9.2.4/ecpg-parallel-make-fix.patch
new file mode 100644
index 000000000..63615cd51
--- /dev/null
+++ b/meta-oe/recipes-support/postgresql/postgresql-9.2.4/ecpg-parallel-make-fix.patch
@@ -0,0 +1,31 @@
1Upstream-status: backport
2
3From 602070f9cce790debd8d1469254e7726ab499ae7 Mon Sep 17 00:00:00 2001
4From: Peter Eisentraut <peter_e@gmx.net>
5Date: Fri, 29 Mar 2013 21:39:55 -0400
6Subject: [PATCH] ecpg: Parallel make fix
7
8In some parallel make situations, the install-headers target could be
9called before the installation directories are created by installdirs,
10causing the installation to fail. Fix that by making install-headers
11depend on installdirs.
12---
13 src/interfaces/ecpg/include/Makefile | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/src/interfaces/ecpg/include/Makefile b/src/interfaces/ecpg/include/Makefile
17index eab833b..e92e56f 100644
18--- a/src/interfaces/ecpg/include/Makefile
19+++ b/src/interfaces/ecpg/include/Makefile
20@@ -18,7 +18,7 @@ ecpg_headers = ecpgerrno.h ecpglib.h ecpgtype.h sqlca.h sql3types.h ecpg_informi
21 sqlda.h sqlda-compat.h sqlda-native.h
22 informix_headers = datetime.h decimal.h sqltypes.h
23
24-install-headers: $(ecpg_headers) $(informix_headers)
25+install-headers: $(ecpg_headers) $(informix_headers) installdirs
26 $(INSTALL_DATA) $(addprefix $(srcdir)/,$(ecpg_headers)) '$(DESTDIR)$(includedir)/'
27 $(INSTALL_DATA) $(addprefix $(srcdir)/,$(informix_headers)) '$(DESTDIR)$(informix_esql_dir)/'
28 $(INSTALL_DATA) $(ecpg_config_h) '$(DESTDIR)$(includedir)'
29--
301.8.3.4
31