summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/compat-wireless
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-kernel/compat-wireless
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-kernel/compat-wireless')
-rw-r--r--meta-oe/recipes-kernel/compat-wireless/compat-wireless-all/0001-ath5k-fix-compilation-without-CONFIG_PCI.patch33
-rw-r--r--meta-oe/recipes-kernel/compat-wireless/compat-wireless-all_3.6.8.bb5
-rw-r--r--meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc33
3 files changed, 71 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all/0001-ath5k-fix-compilation-without-CONFIG_PCI.patch b/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all/0001-ath5k-fix-compilation-without-CONFIG_PCI.patch
new file mode 100644
index 000000000..3a51266d0
--- /dev/null
+++ b/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all/0001-ath5k-fix-compilation-without-CONFIG_PCI.patch
@@ -0,0 +1,33 @@
1From fb323acc0b01bcf1ecafb9330c4fbb41cf942139 Mon Sep 17 00:00:00 2001
2From: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
3Date: Wed, 18 Jul 2012 01:01:52 +0200
4Subject: [PATCH] ath5k: fix compilation without CONFIG_PCI
5
6Without that fix we have:
7 [...]/drivers/net/wireless/ath/ath5k/led.c: In function 'ath5k_init_leds':
8 [...]/drivers/net/wireless/ath/ath5k/led.c:179:2: error: implicit declaration of function 'pci_match_id' [-Werror=implicit-function-declaration]
9When CONFIG_PCI is not set.
10
11Upstream-Status: Pending: Not submitted yet.
12
13Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
14---
15 drivers/net/wireless/ath/ath5k/led.c | 2 +-
16 1 files changed, 1 insertions(+), 1 deletions(-)
17
18diff --git a/drivers/net/wireless/ath/ath5k/led.c b/drivers/net/wireless/ath/ath5k/led.c
19index c044476..a4de133 100644
20--- a/drivers/net/wireless/ath/ath5k/led.c
21+++ b/drivers/net/wireless/ath/ath5k/led.c
22@@ -173,7 +173,7 @@ int __devinit ath5k_init_leds(struct ath5k_hw *ah)
23 if (!ah->pdev)
24 return 0;
25
26-#ifdef CONFIG_ATHEROS_AR231X
27+#if defined(CONFIG_ATHEROS_AR231X) || !defined(CONFIG_PCI)
28 match = NULL;
29 #else
30 match = pci_match_id(&ath5k_led_devices[0], pdev);
31--
321.7.4.1
33
diff --git a/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all_3.6.8.bb b/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all_3.6.8.bb
new file mode 100644
index 000000000..0c407defc
--- /dev/null
+++ b/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all_3.6.8.bb
@@ -0,0 +1,5 @@
1include compat-wireless.inc
2PR = "${INC_PR}.0"
3
4SRC_URI[md5sum] = "f02849a795137438238b4d166609eacc"
5SRC_URI[sha256sum] = "9bbbc72bf0adf73012f377caa38147e90f6d77ef0369b52f9a687bc66bbfbcfa"
diff --git a/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc b/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc
new file mode 100644
index 000000000..398142601
--- /dev/null
+++ b/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc
@@ -0,0 +1,33 @@
1DESCRIPTION = "Latest wireless drivers"
2HOMEPAGE = "http://wireless.kernel.org/en/users/Download"
3SECTION = "kernel/modules"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=d7810fab7487fb0aad327b76f1be7cd7"
6RDEPENDS_${PN} = "wireless-tools"
7INC_PR = "r1"
8
9# depends on config options which are not enabled in qemu* MACHINEs by default
10# config.mk:25: *** "ERROR: your kernel has CONFIG_CFG80211=y, you should have it CONFIG_CFG80211=m if you want to use this thing.". Stop.
11EXCLUDE_FROM_WORLD = "1"
12
13COMPAT_WIRELESS_VERSION = "${PV}-1"
14SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
15
16SRC_URI = " \
17 http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v${SHRT_VER}/compat-wireless-${COMPAT_WIRELESS_VERSION}.tar.bz2 \
18 file://0001-ath5k-fix-compilation-without-CONFIG_PCI.patch \
19"
20
21S = "${WORKDIR}/compat-wireless-${COMPAT_WIRELESS_VERSION}"
22
23inherit module
24
25EXTRA_OEMAKE = "KLIB_BUILD=${STAGING_KERNEL_DIR} KLIB=${D}"
26
27do_configure_append() {
28 sed -i "s#@./scripts/update-initramfs## " Makefile
29}
30
31do_install() {
32 oe_runmake DEPMOD=echo DESTDIR="${D}" INSTALL_MOD_PATH="${D}" LDFLAGS="" install-modules
33}