diff options
author | Ben Guan <ben.guan@cn.bosch.com> | 2018-08-07 16:15:14 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-08-19 16:09:28 -0700 |
commit | 864eb0024f6f8cf91b3484fb002bf89f94fbb1ea (patch) | |
tree | 3295c4149d7538581024b6e89a8a23d20b081ab2 /meta-oe/recipes-graphics | |
parent | e88b38a9d214c3296892e0e6f6c6b444d1d48a54 (diff) | |
download | meta-openembedded-864eb0024f6f8cf91b3484fb002bf89f94fbb1ea.tar.gz |
directfb: fix tslib version check in configure.in
The patch makes sure that the old as well as the new tslib pkg-config
metadata file naming style is handled correctly.
tslib 0.0 to 1.0 created only a tslib-<VERSION>.pc pkg-config metadata
file.
With tslib 1.1 the tslib-<VERSION>.pc phase out was started.
Additionally, the pkg-config metadata file tslib.pc was added.
Since tslib 1.6 the tslib-<VERSION>.pc metadata file is deprecated.
Now, there is only a tslib.pc.
Signed-off-by: Ben Guan <ben.guan@cn.bosch.com>
Signed-off-by: Mark Jonas <mark.jonas@de.bosch.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r-- | meta-oe/recipes-graphics/directfb/directfb.inc | 1 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/directfb/directfb/fix-tslib-version-check.patch | 38 |
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/directfb/directfb.inc b/meta-oe/recipes-graphics/directfb/directfb.inc index bd66a28207..96aa31117f 100644 --- a/meta-oe/recipes-graphics/directfb/directfb.inc +++ b/meta-oe/recipes-graphics/directfb/directfb.inc | |||
@@ -20,6 +20,7 @@ SRC_URI = "http://downloads.yoctoproject.org/mirror/sources/DirectFB-${PV}.tar.g | |||
20 | file://union-sigval.patch \ | 20 | file://union-sigval.patch \ |
21 | file://use-PTHREAD_MUTEX_RECURSIVE.patch \ | 21 | file://use-PTHREAD_MUTEX_RECURSIVE.patch \ |
22 | file://fix-client-gfx_state-initialisation.patch \ | 22 | file://fix-client-gfx_state-initialisation.patch \ |
23 | file://fix-tslib-version-check.patch \ | ||
23 | " | 24 | " |
24 | 25 | ||
25 | S = "${WORKDIR}/DirectFB-${PV}" | 26 | S = "${WORKDIR}/DirectFB-${PV}" |
diff --git a/meta-oe/recipes-graphics/directfb/directfb/fix-tslib-version-check.patch b/meta-oe/recipes-graphics/directfb/directfb/fix-tslib-version-check.patch new file mode 100644 index 0000000000..352bfaf201 --- /dev/null +++ b/meta-oe/recipes-graphics/directfb/directfb/fix-tslib-version-check.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | fix tslib version check in configure.in | ||
2 | |||
3 | The patch makes sure that the old as well as the new tslib pkg-config | ||
4 | metadata file naming style is handled correctly. | ||
5 | |||
6 | tslib 0.0 to 1.0 created only a tslib-<VERSION>.pc pkg-config metadata | ||
7 | file. | ||
8 | |||
9 | With tslib 1.1 the tslib-<VERSION>.pc phase out was started. | ||
10 | Additionally, the pkg-config metadata file tslib.pc was added. | ||
11 | |||
12 | Since tslib 1.6 the tslib-<VERSION>.pc metadata file is deprecated. | ||
13 | Now, there is only a tslib.pc. | ||
14 | |||
15 | Upstream-Status: Inappropriate [no upstream] | ||
16 | Signed-off-by: Ben Guan <ben.guan@cn.bosch.com> | ||
17 | Signed-off-by: Mark Jonas <mark.jonas@de.bosch.com> | ||
18 | |||
19 | diff -Nru DirectFB-1.7.7.orig/configure.in DirectFB-1.7.7/configure.in | ||
20 | --- DirectFB-1.7.7.orig/configure.in 2015-02-10 01:16:46.000000000 +0800 | ||
21 | +++ DirectFB-1.7.7/configure.in 2018-06-06 17:19:18.472143103 +0800 | ||
22 | @@ -2459,10 +2459,13 @@ | ||
23 | |||
24 | enable_tslib=no | ||
25 | if test "$checkfor_tslib" = "yes"; then | ||
26 | - PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0.0], [enable_tslib=yes], [enable_tslib=no]) | ||
27 | + PKG_CHECK_MODULES([TSLIB], [tslib >= 1.1], [enable_tslib=yes], [enable_tslib=no]) | ||
28 | if test "$enable_tslib" = "no"; then | ||
29 | - PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [enable_tslib=yes], [enable_tslib=no | ||
30 | - AC_MSG_WARN([*** no tslib -- tslib driver will not be built.])]) | ||
31 | + PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0], [enable_tslib=yes], [enable_tslib=no]) | ||
32 | + if test "$enable_tslib" = "no"; then | ||
33 | + PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [enable_tslib=yes], [enable_tslib=no | ||
34 | + AC_MSG_WARN([*** no tslib -- tslib driver will not be built.])]) | ||
35 | + fi | ||
36 | fi | ||
37 | fi | ||
38 | |||