summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Guan <ben.guan@cn.bosch.com>2018-08-07 16:15:14 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-19 16:09:28 -0700
commit864eb0024f6f8cf91b3484fb002bf89f94fbb1ea (patch)
tree3295c4149d7538581024b6e89a8a23d20b081ab2
parente88b38a9d214c3296892e0e6f6c6b444d1d48a54 (diff)
downloadmeta-openembedded-864eb0024f6f8cf91b3484fb002bf89f94fbb1ea.tar.gz
directfb: fix tslib version check in configure.in
The patch makes sure that the old as well as the new tslib pkg-config metadata file naming style is handled correctly. tslib 0.0 to 1.0 created only a tslib-<VERSION>.pc pkg-config metadata file. With tslib 1.1 the tslib-<VERSION>.pc phase out was started. Additionally, the pkg-config metadata file tslib.pc was added. Since tslib 1.6 the tslib-<VERSION>.pc metadata file is deprecated. Now, there is only a tslib.pc. Signed-off-by: Ben Guan <ben.guan@cn.bosch.com> Signed-off-by: Mark Jonas <mark.jonas@de.bosch.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/directfb/directfb.inc1
-rw-r--r--meta-oe/recipes-graphics/directfb/directfb/fix-tslib-version-check.patch38
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/directfb/directfb.inc b/meta-oe/recipes-graphics/directfb/directfb.inc
index bd66a2820..96aa31117 100644
--- a/meta-oe/recipes-graphics/directfb/directfb.inc
+++ b/meta-oe/recipes-graphics/directfb/directfb.inc
@@ -20,6 +20,7 @@ SRC_URI = "http://downloads.yoctoproject.org/mirror/sources/DirectFB-${PV}.tar.g
20 file://union-sigval.patch \ 20 file://union-sigval.patch \
21 file://use-PTHREAD_MUTEX_RECURSIVE.patch \ 21 file://use-PTHREAD_MUTEX_RECURSIVE.patch \
22 file://fix-client-gfx_state-initialisation.patch \ 22 file://fix-client-gfx_state-initialisation.patch \
23 file://fix-tslib-version-check.patch \
23 " 24 "
24 25
25S = "${WORKDIR}/DirectFB-${PV}" 26S = "${WORKDIR}/DirectFB-${PV}"
diff --git a/meta-oe/recipes-graphics/directfb/directfb/fix-tslib-version-check.patch b/meta-oe/recipes-graphics/directfb/directfb/fix-tslib-version-check.patch
new file mode 100644
index 000000000..352bfaf20
--- /dev/null
+++ b/meta-oe/recipes-graphics/directfb/directfb/fix-tslib-version-check.patch
@@ -0,0 +1,38 @@
1fix tslib version check in configure.in
2
3The patch makes sure that the old as well as the new tslib pkg-config
4metadata file naming style is handled correctly.
5
6tslib 0.0 to 1.0 created only a tslib-<VERSION>.pc pkg-config metadata
7file.
8
9With tslib 1.1 the tslib-<VERSION>.pc phase out was started.
10Additionally, the pkg-config metadata file tslib.pc was added.
11
12Since tslib 1.6 the tslib-<VERSION>.pc metadata file is deprecated.
13Now, there is only a tslib.pc.
14
15Upstream-Status: Inappropriate [no upstream]
16Signed-off-by: Ben Guan <ben.guan@cn.bosch.com>
17Signed-off-by: Mark Jonas <mark.jonas@de.bosch.com>
18
19diff -Nru DirectFB-1.7.7.orig/configure.in DirectFB-1.7.7/configure.in
20--- DirectFB-1.7.7.orig/configure.in 2015-02-10 01:16:46.000000000 +0800
21+++ DirectFB-1.7.7/configure.in 2018-06-06 17:19:18.472143103 +0800
22@@ -2459,10 +2459,13 @@
23
24 enable_tslib=no
25 if test "$checkfor_tslib" = "yes"; then
26- PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0.0], [enable_tslib=yes], [enable_tslib=no])
27+ PKG_CHECK_MODULES([TSLIB], [tslib >= 1.1], [enable_tslib=yes], [enable_tslib=no])
28 if test "$enable_tslib" = "no"; then
29- PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [enable_tslib=yes], [enable_tslib=no
30- AC_MSG_WARN([*** no tslib -- tslib driver will not be built.])])
31+ PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0], [enable_tslib=yes], [enable_tslib=no])
32+ if test "$enable_tslib" = "no"; then
33+ PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [enable_tslib=yes], [enable_tslib=no
34+ AC_MSG_WARN([*** no tslib -- tslib driver will not be built.])])
35+ fi
36 fi
37 fi
38