diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2018-04-03 17:57:09 +0000 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-04-13 12:41:06 -0700 |
commit | 1d663545cb921a4bd0c92c7dcc722886a67e8154 (patch) | |
tree | fb93b23da7e45dd8e3495c0d111456db9f666500 /meta-oe/recipes-extended/sblim-sfcb | |
parent | ed70b4f91f5fd6776f120cd5c9f915a8b999adfd (diff) | |
download | meta-openembedded-1d663545cb921a4bd0c92c7dcc722886a67e8154.tar.gz |
rarpd, sblim-sfcb, openct: inherit systemd unconditionally
* the inherit was controlled by VIRTUAL-RUNTIME_init_manager and the installation
of .service files by DISTRO_FEATURES and systemd was in DISTRO_FEATURES but not
in VIRTUAL-RUNTIME_init_manager it was causing QA issues about unpackaged
.service files
ERROR: rarpd-ss981107-r0 do_package: QA Issue: rarpd: Files/directories
were installed but not shipped in any package:
/lib
/lib/systemd
/lib/systemd/system
/lib/systemd/system/rarpd.service
ERROR: sblim-sfcb-1.4.9-r0 do_package: QA Issue: sblim-sfcb:
Files/directories were installed but not shipped in any package:
/lib
/lib/systemd
/lib/systemd/system
/lib/systemd/system/sblim-sfcb.service
ERROR: sblim-sfcb-1.4.9-r0 do_package: QA Issue: sblim-sfcb:
Files/directories were installed but not shipped in any package:
/lib
/lib/systemd
/lib/systemd/system
/lib/systemd/system/sblim-sfcb.service
* systemd.bbclass will take care of removing /lib/systemd when systemd
isn't in DISTRO_FEATURES, so we can remove both conditions
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/sblim-sfcb')
-rw-r--r-- | meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb | 8 |
1 files changed, 3 insertions, 5 deletions
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb index 152ae22902..10ffaaa31b 100644 --- a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb +++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb | |||
@@ -31,7 +31,7 @@ SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30" | |||
31 | SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd" | 31 | SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd" |
32 | 32 | ||
33 | inherit autotools | 33 | inherit autotools |
34 | inherit ${@bb.utils.filter('VIRTUAL-RUNTIME_init_manager', 'systemd', d)} | 34 | inherit systemd |
35 | 35 | ||
36 | SYSTEMD_PACKAGES = "${PN}" | 36 | SYSTEMD_PACKAGES = "${PN}" |
37 | SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service" | 37 | SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service" |
@@ -56,10 +56,8 @@ do_install() { | |||
56 | 56 | ||
57 | oe_runmake DESTDIR=${D} install | 57 | oe_runmake DESTDIR=${D} install |
58 | 58 | ||
59 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | 59 | install -d ${D}${systemd_unitdir}/system |
60 | install -d ${D}${systemd_unitdir}/system | 60 | install -m 0644 ${WORKDIR}/sfcb.service ${D}${systemd_unitdir}/system/sblim-sfcb.service |
61 | install -m 0644 ${WORKDIR}/sfcb.service ${D}${systemd_unitdir}/system/sblim-sfcb.service | ||
62 | fi | ||
63 | 61 | ||
64 | install -d ${D}${sysconfdir}/init.d | 62 | install -d ${D}${sysconfdir}/init.d |
65 | mv ${D}${sysconfdir}/init.d/sfcb ${D}${sysconfdir}/init.d/sblim-sfcb | 63 | mv ${D}${sysconfdir}/init.d/sfcb ${D}${sysconfdir}/init.d/sblim-sfcb |