diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2018-04-03 17:57:09 +0000 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-04-13 12:41:06 -0700 |
commit | 1d663545cb921a4bd0c92c7dcc722886a67e8154 (patch) | |
tree | fb93b23da7e45dd8e3495c0d111456db9f666500 /meta-oe | |
parent | ed70b4f91f5fd6776f120cd5c9f915a8b999adfd (diff) | |
download | meta-openembedded-1d663545cb921a4bd0c92c7dcc722886a67e8154.tar.gz |
rarpd, sblim-sfcb, openct: inherit systemd unconditionally
* the inherit was controlled by VIRTUAL-RUNTIME_init_manager and the installation
of .service files by DISTRO_FEATURES and systemd was in DISTRO_FEATURES but not
in VIRTUAL-RUNTIME_init_manager it was causing QA issues about unpackaged
.service files
ERROR: rarpd-ss981107-r0 do_package: QA Issue: rarpd: Files/directories
were installed but not shipped in any package:
/lib
/lib/systemd
/lib/systemd/system
/lib/systemd/system/rarpd.service
ERROR: sblim-sfcb-1.4.9-r0 do_package: QA Issue: sblim-sfcb:
Files/directories were installed but not shipped in any package:
/lib
/lib/systemd
/lib/systemd/system
/lib/systemd/system/sblim-sfcb.service
ERROR: sblim-sfcb-1.4.9-r0 do_package: QA Issue: sblim-sfcb:
Files/directories were installed but not shipped in any package:
/lib
/lib/systemd
/lib/systemd/system
/lib/systemd/system/sblim-sfcb.service
* systemd.bbclass will take care of removing /lib/systemd when systemd
isn't in DISTRO_FEATURES, so we can remove both conditions
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb | 8 | ||||
-rw-r--r-- | meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb | 8 | ||||
-rw-r--r-- | meta-oe/recipes-support/openct/openct_0.6.20.bb | 8 |
3 files changed, 9 insertions, 15 deletions
diff --git a/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb b/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb index 4025b8087e..7c9f2df9db 100644 --- a/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb +++ b/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb | |||
@@ -38,13 +38,11 @@ do_install() { | |||
38 | install -m 644 rarpd.8 ${D}${mandir}/man8/rarpd.8 | 38 | install -m 644 rarpd.8 ${D}${mandir}/man8/rarpd.8 |
39 | install -m 644 ${WORKDIR}/ethers.sample ${D}${sysconfdir}/ethers | 39 | install -m 644 ${WORKDIR}/ethers.sample ${D}${sysconfdir}/ethers |
40 | 40 | ||
41 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | 41 | install -d ${D}${systemd_unitdir}/system |
42 | install -d ${D}${systemd_unitdir}/system | 42 | install -m 0644 ${WORKDIR}/rarpd.service ${D}${systemd_unitdir}/system/ |
43 | install -m 0644 ${WORKDIR}/rarpd.service ${D}${systemd_unitdir}/system/ | ||
44 | fi | ||
45 | } | 43 | } |
46 | 44 | ||
47 | inherit ${@bb.utils.filter('VIRTUAL-RUNTIME_init_manager', 'systemd', d)} | 45 | inherit systemd |
48 | 46 | ||
49 | SYSTEMD_PACKAGES = "${PN}" | 47 | SYSTEMD_PACKAGES = "${PN}" |
50 | SYSTEMD_SERVICE_${PN} = "rarpd.service" | 48 | SYSTEMD_SERVICE_${PN} = "rarpd.service" |
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb index 152ae22902..10ffaaa31b 100644 --- a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb +++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb | |||
@@ -31,7 +31,7 @@ SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30" | |||
31 | SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd" | 31 | SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd" |
32 | 32 | ||
33 | inherit autotools | 33 | inherit autotools |
34 | inherit ${@bb.utils.filter('VIRTUAL-RUNTIME_init_manager', 'systemd', d)} | 34 | inherit systemd |
35 | 35 | ||
36 | SYSTEMD_PACKAGES = "${PN}" | 36 | SYSTEMD_PACKAGES = "${PN}" |
37 | SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service" | 37 | SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service" |
@@ -56,10 +56,8 @@ do_install() { | |||
56 | 56 | ||
57 | oe_runmake DESTDIR=${D} install | 57 | oe_runmake DESTDIR=${D} install |
58 | 58 | ||
59 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | 59 | install -d ${D}${systemd_unitdir}/system |
60 | install -d ${D}${systemd_unitdir}/system | 60 | install -m 0644 ${WORKDIR}/sfcb.service ${D}${systemd_unitdir}/system/sblim-sfcb.service |
61 | install -m 0644 ${WORKDIR}/sfcb.service ${D}${systemd_unitdir}/system/sblim-sfcb.service | ||
62 | fi | ||
63 | 61 | ||
64 | install -d ${D}${sysconfdir}/init.d | 62 | install -d ${D}${sysconfdir}/init.d |
65 | mv ${D}${sysconfdir}/init.d/sfcb ${D}${sysconfdir}/init.d/sblim-sfcb | 63 | mv ${D}${sysconfdir}/init.d/sfcb ${D}${sysconfdir}/init.d/sblim-sfcb |
diff --git a/meta-oe/recipes-support/openct/openct_0.6.20.bb b/meta-oe/recipes-support/openct/openct_0.6.20.bb index c7d7203eda..913290cd97 100644 --- a/meta-oe/recipes-support/openct/openct_0.6.20.bb +++ b/meta-oe/recipes-support/openct/openct_0.6.20.bb | |||
@@ -25,7 +25,7 @@ SRC_URI[sha256sum] = "6cd3e2933d29eb1f875c838ee58b8071fd61f0ec8ed5922a86c01c805d | |||
25 | LICENSE = "LGPLv2+" | 25 | LICENSE = "LGPLv2+" |
26 | LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1" | 26 | LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1" |
27 | 27 | ||
28 | inherit ${@bb.utils.filter('VIRTUAL-RUNTIME_init_manager', 'systemd', d)} | 28 | inherit systemd |
29 | SYSTEMD_SERVICE_${PN} += "openct.service " | 29 | SYSTEMD_SERVICE_${PN} += "openct.service " |
30 | SYSTEMD_AUTO_ENABLE = "enable" | 30 | SYSTEMD_AUTO_ENABLE = "enable" |
31 | 31 | ||
@@ -77,10 +77,8 @@ do_install () { | |||
77 | install -Dpm 755 ${WORKDIR}/openct.init ${D}/etc/init.d/openct | 77 | install -Dpm 755 ${WORKDIR}/openct.init ${D}/etc/init.d/openct |
78 | install -Dpm 644 ${WORKDIR}/openct.sysconfig ${D}/etc/sysconfig/openct | 78 | install -Dpm 644 ${WORKDIR}/openct.sysconfig ${D}/etc/sysconfig/openct |
79 | 79 | ||
80 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | 80 | install -d ${D}/${systemd_unitdir}/system |
81 | install -d ${D}/${systemd_unitdir}/system | 81 | install -m 644 ${WORKDIR}/openct.service ${D}/${systemd_unitdir}/system |
82 | install -m 644 ${WORKDIR}/openct.service ${D}/${systemd_unitdir}/system | ||
83 | fi | ||
84 | 82 | ||
85 | so=$(find ${D} -name \*.so | sed "s|^${D}||") | 83 | so=$(find ${D} -name \*.so | sed "s|^${D}||") |
86 | sed -i -e 's|\\(LIBPATH\\s*\\).*|\\1$so|' etc/reader.conf | 84 | sed -i -e 's|\\(LIBPATH\\s*\\).*|\\1$so|' etc/reader.conf |