summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/jq
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-09-30 15:30:14 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-05 18:21:13 +0200
commit8b68ed985b36a01d23d83330cb8d0576d6ad13fb (patch)
treee673732c1c5fe6c0c757fad438d7e262c622d915 /meta-oe/recipes-devtools/jq
parentdacf9a88c360f65bdcdb4ecad85ed28c6b1f585e (diff)
downloadmeta-openembedded-8b68ed985b36a01d23d83330cb8d0576d6ad13fb.tar.gz
jq: add support for jq-native + misc minor fixes
- Add PACKAGECONFIG options for docs, maintainer-mode and oniguruma Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/jq')
-rw-r--r--meta-oe/recipes-devtools/jq/jq/Support-without-oniguruma.patch68
-rw-r--r--meta-oe/recipes-devtools/jq/jq_1.5.bb21
2 files changed, 82 insertions, 7 deletions
diff --git a/meta-oe/recipes-devtools/jq/jq/Support-without-oniguruma.patch b/meta-oe/recipes-devtools/jq/jq/Support-without-oniguruma.patch
new file mode 100644
index 0000000000..1dfd955f0d
--- /dev/null
+++ b/meta-oe/recipes-devtools/jq/jq/Support-without-oniguruma.patch
@@ -0,0 +1,68 @@
1From 18b4b18b41f5ed396d73449ce8d6ec408d95d6b2 Mon Sep 17 00:00:00 2001
2From: David Tolnay <dtolnay@gmail.com>
3Date: Sat, 21 Nov 2015 10:05:37 -0800
4Subject: [PATCH] Support --without-oniguruma
5
6Upstream-Status: Backport
7
8Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
9
10---
11 configure.ac | 41 ++++++++++++++++++++---------------------
12 1 file changed, 20 insertions(+), 21 deletions(-)
13
14diff --git a/configure.ac b/configure.ac
15index 9e2c8cf..7f6be34 100644
16--- a/configure.ac
17+++ b/configure.ac
18@@ -52,27 +52,26 @@ fi
19 AC_ARG_WITH([oniguruma],
20 [AS_HELP_STRING([--with-oniguruma=prefix],
21 [try this for a non-standard install prefix of the oniguruma library])],
22- [ONIGURUMAPATHSET=1],
23- [ONIGURUMAPATHSET=0])
24-
25-if test $ONIGURUMAPATHSET = 1; then
26- CFLAGS="$CFLAGS -I${with_oniguruma}/include"
27- LDFLAGS="$LDFLAGS -L${with_oniguruma}/lib"
28-fi
29-
30-# check for ONIGURUMA library
31-HAVE_ONIGURUMA=0
32-AC_CHECK_HEADER("oniguruma.h",
33- AC_CHECK_LIB([onig],[onig_version],[LIBS="$LIBS -lonig"; HAVE_ONIGURUMA=1;]))
34-
35-# handle check results
36-if test $HAVE_ONIGURUMA != 1; then
37- AC_MSG_NOTICE([Oniguruma was not found.])
38- AC_MSG_NOTICE([ Try setting the location using '--with-oniguruma=PREFIX' ])
39-else
40- AC_DEFINE([HAVE_ONIGURUMA],1,[Define to 1 if Oniguruma is installed])
41-fi
42-
43+ [],
44+ [with_oniguruma=yes])
45+
46+AS_IF([test "x$with_oniguruma" != xno], [
47+ AS_IF([test "x$with_oniguruma" != xyes], [
48+ CFLAGS="$CFLAGS -I${with_oniguruma}/include"
49+ LDFLAGS="$LDFLAGS -L${with_oniguruma}/lib"
50+ ])
51+ # check for ONIGURUMA library
52+ have_oniguruma=0
53+ AC_CHECK_HEADER("oniguruma.h",
54+ AC_CHECK_LIB([onig],[onig_version],[LIBS="$LIBS -lonig"; have_oniguruma=1;]))
55+ # handle check results
56+ AS_IF([test $have_oniguruma = 1], [
57+ AC_DEFINE([HAVE_ONIGURUMA], 1, [Define to 1 if Oniguruma is installed])
58+ ], [
59+ AC_MSG_NOTICE([Oniguruma was not found.])
60+ AC_MSG_NOTICE([Try setting the location using '--with-oniguruma=PREFIX'])
61+ ])
62+])
63
64 dnl Check for valgrind
65 AC_CHECK_PROGS(valgrind_cmd, valgrind)
66--
671.9.1
68
diff --git a/meta-oe/recipes-devtools/jq/jq_1.5.bb b/meta-oe/recipes-devtools/jq/jq_1.5.bb
index 612eaf3960..0f40815ccd 100644
--- a/meta-oe/recipes-devtools/jq/jq_1.5.bb
+++ b/meta-oe/recipes-devtools/jq/jq_1.5.bb
@@ -2,16 +2,14 @@ SUMMARY = "Lightweight and flexible command-line JSON processor"
2DESCRIPTION = "jq is like sed for JSON data, you can use it to slice and \ 2DESCRIPTION = "jq is like sed for JSON data, you can use it to slice and \
3 filter and map and transform structured data with the same \ 3 filter and map and transform structured data with the same \
4 ease that sed, awk, grep and friends let you play with text." 4 ease that sed, awk, grep and friends let you play with text."
5HOMEPAGE = "http://stedolan.github.io/jq/" 5HOMEPAGE = "https://stedolan.github.io/jq/"
6BUGTRACKER = "https://github.com/stedolan/jq/issues" 6BUGTRACKER = "https://github.com/stedolan/jq/issues"
7SECTION = "utils" 7SECTION = "utils"
8
9LICENSE = "MIT" 8LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=29dd0c35d7e391bb8d515eacf7592e00" 9LIC_FILES_CHKSUM = "file://COPYING;md5=29dd0c35d7e391bb8d515eacf7592e00"
11 10
12DEPENDS = "flex-native bison-native onig" 11SRC_URI = "https://github.com/stedolan/${BPN}/releases/download/${BP}/${BP}.tar.gz \
13 12 file://Support-without-oniguruma.patch \
14SRC_URI = "https://github.com/stedolan/${BPN}/releases/download/${BPN}-${PV}/${BPN}-${PV}.tar.gz \
15" 13"
16 14
17SRC_URI[md5sum] = "0933532b086bd8b6a41c1b162b1731f9" 15SRC_URI[md5sum] = "0933532b086bd8b6a41c1b162b1731f9"
@@ -19,5 +17,14 @@ SRC_URI[sha256sum] = "c4d2bfec6436341113419debf479d833692cc5cdab7eb0326b5a4d4fbe
19 17
20inherit autotools 18inherit autotools
21 19
22# Don't build documentation (generation requires ruby) 20PACKAGECONFIG ?= "oniguruma"
23EXTRA_OECONF = "--disable-docs --disable-maintainer-mode" 21
22PACKAGECONFIG[docs] = "--enable-docs,--disable-docs,ruby-native"
23PACKAGECONFIG[maintainer-mode] = "--enable-maintainer-mode,--disable-maintainer-mode,flex-native bison-native"
24PACKAGECONFIG[oniguruma] = "--with-oniguruma,--without-oniguruma,onig"
25
26OE_EXTRACONF += " \
27 --disable-valgrind \
28"
29
30BBCLASSEXTEND = "native"