summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/jq/jq/Support-without-oniguruma.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/jq/jq/Support-without-oniguruma.patch')
-rw-r--r--meta-oe/recipes-devtools/jq/jq/Support-without-oniguruma.patch68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/jq/jq/Support-without-oniguruma.patch b/meta-oe/recipes-devtools/jq/jq/Support-without-oniguruma.patch
new file mode 100644
index 0000000000..1dfd955f0d
--- /dev/null
+++ b/meta-oe/recipes-devtools/jq/jq/Support-without-oniguruma.patch
@@ -0,0 +1,68 @@
1From 18b4b18b41f5ed396d73449ce8d6ec408d95d6b2 Mon Sep 17 00:00:00 2001
2From: David Tolnay <dtolnay@gmail.com>
3Date: Sat, 21 Nov 2015 10:05:37 -0800
4Subject: [PATCH] Support --without-oniguruma
5
6Upstream-Status: Backport
7
8Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
9
10---
11 configure.ac | 41 ++++++++++++++++++++---------------------
12 1 file changed, 20 insertions(+), 21 deletions(-)
13
14diff --git a/configure.ac b/configure.ac
15index 9e2c8cf..7f6be34 100644
16--- a/configure.ac
17+++ b/configure.ac
18@@ -52,27 +52,26 @@ fi
19 AC_ARG_WITH([oniguruma],
20 [AS_HELP_STRING([--with-oniguruma=prefix],
21 [try this for a non-standard install prefix of the oniguruma library])],
22- [ONIGURUMAPATHSET=1],
23- [ONIGURUMAPATHSET=0])
24-
25-if test $ONIGURUMAPATHSET = 1; then
26- CFLAGS="$CFLAGS -I${with_oniguruma}/include"
27- LDFLAGS="$LDFLAGS -L${with_oniguruma}/lib"
28-fi
29-
30-# check for ONIGURUMA library
31-HAVE_ONIGURUMA=0
32-AC_CHECK_HEADER("oniguruma.h",
33- AC_CHECK_LIB([onig],[onig_version],[LIBS="$LIBS -lonig"; HAVE_ONIGURUMA=1;]))
34-
35-# handle check results
36-if test $HAVE_ONIGURUMA != 1; then
37- AC_MSG_NOTICE([Oniguruma was not found.])
38- AC_MSG_NOTICE([ Try setting the location using '--with-oniguruma=PREFIX' ])
39-else
40- AC_DEFINE([HAVE_ONIGURUMA],1,[Define to 1 if Oniguruma is installed])
41-fi
42-
43+ [],
44+ [with_oniguruma=yes])
45+
46+AS_IF([test "x$with_oniguruma" != xno], [
47+ AS_IF([test "x$with_oniguruma" != xyes], [
48+ CFLAGS="$CFLAGS -I${with_oniguruma}/include"
49+ LDFLAGS="$LDFLAGS -L${with_oniguruma}/lib"
50+ ])
51+ # check for ONIGURUMA library
52+ have_oniguruma=0
53+ AC_CHECK_HEADER("oniguruma.h",
54+ AC_CHECK_LIB([onig],[onig_version],[LIBS="$LIBS -lonig"; have_oniguruma=1;]))
55+ # handle check results
56+ AS_IF([test $have_oniguruma = 1], [
57+ AC_DEFINE([HAVE_ONIGURUMA], 1, [Define to 1 if Oniguruma is installed])
58+ ], [
59+ AC_MSG_NOTICE([Oniguruma was not found.])
60+ AC_MSG_NOTICE([Try setting the location using '--with-oniguruma=PREFIX'])
61+ ])
62+])
63
64 dnl Check for valgrind
65 AC_CHECK_PROGS(valgrind_cmd, valgrind)
66--
671.9.1
68