summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/wvdial
diff options
context:
space:
mode:
authorMario Domenech Goulart <mario@ossystems.com.br>2013-10-04 17:18:31 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-05 12:36:23 +0200
commit915810274467cef4f97fd2dff3fc85f9565abea2 (patch)
tree1526097b4d6f05b75137cf34381e75a166095a78 /meta-oe/recipes-connectivity/wvdial
parent73a68490efe05cdbec540ec6f17782816632a24d (diff)
downloadmeta-openembedded-915810274467cef4f97fd2dff3fc85f9565abea2.tar.gz
wvstreams: add recipe for version 4.6.1
Recipe based on OE classic's recipe for version 4.4.1, as of 0585ccfa49f71a81652c7f63885202e952ebd0e9. Summary of changes against OE classic's recipe: * Apply some Debian patches from http://patch-tracker.debian.org/package/wvstreams/4.6.1-6 * Minor adjustments for the current build system (add LIC_FILES_CHKSUM, md5 and sha256 sums for SRC_URI, fix LICENSE, remove PR) * Add --without-valgrind to EXTRA_OECONF * Disable parallel make, since it was causing errors like Log data follows: | DEBUG: SITE files ['endian-little', 'bit-32', 'arm-common', 'common-linux', 'common-glibc', 'arm-linux', 'arm-linux-gnueabi', 'common'] | DEBUG: Executing shell function do_compile | NOTE: make -j 8 | ./CXX -c utils/wvbuffer | ./CXX -c utils/wvbufferstore | ./CXX -c utils/wvcont | /bin/bash: ./CXX: No such file or directory | /bin/bash: ./CXX: No such file or directory | /bin/bash: ./CXX: No such file or directory | * Generating CC using c | make: * Generating CXX using cc | *** [utils/wvbuffer.o] Error 127 | make: *** Waiting for unfinished jobs.... | make: *** [utils/wvbufferstore.o] Error 127 | make: *** [utils/wvcont.o] Error 127 | ERROR: oe_runmake failed | WARNING: .../tmp/work/armv7a-vfp-neon-oel-linux-gnueabi/wvstreams/4.6.1-r0/temp/run.do_compile.19302:1 exit 1 from | exit 1 | ERROR: Function failed: do_compile (log file is located at .../tmp/work/armv7a-vfp-neon-oel-linux-gnueabi/wvstreams/4.6.1-r0/temp/log.do_compile.19302) Signed-off-by: Mario Domenech Goulart <mario@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/wvdial')
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams/04_signed_request.diff13
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams/05_gcc.diff41
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams/06_gcc-4.7.diff18
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams/07_buildflags.diff32
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb42
5 files changed, 146 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/04_signed_request.diff b/meta-oe/recipes-connectivity/wvdial/wvstreams/04_signed_request.diff
new file mode 100644
index 000000000..5ab633bc3
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/04_signed_request.diff
@@ -0,0 +1,13 @@
1Index: wvstreams-4.6/crypto/wvx509.cc
2===================================================================
3--- wvstreams-4.6.orig/crypto/wvx509.cc 2009-07-29 11:58:16.000000000 -0400
4+++ wvstreams-4.6/crypto/wvx509.cc 2009-07-29 11:58:43.000000000 -0400
5@@ -325,7 +325,7 @@
6 }
7
8 int verify_result = X509_REQ_verify(certreq, pk);
9- if (verify_result == 0)
10+ if (verify_result == 0 || verify_result == -1)
11 {
12 debug(WvLog::Warning, "Self signed request failed");
13 X509_REQ_free(certreq);
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/05_gcc.diff b/meta-oe/recipes-connectivity/wvdial/wvstreams/05_gcc.diff
new file mode 100644
index 000000000..8e4fd0329
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/05_gcc.diff
@@ -0,0 +1,41 @@
1Index: wvstreams-4.6.1/crypto/wvx509.cc
2===================================================================
3--- wvstreams-4.6.1.orig/crypto/wvx509.cc 2011-05-20 00:02:38.119136584 +0200
4+++ wvstreams-4.6.1/crypto/wvx509.cc 2011-05-20 00:02:26.035136589 +0200
5@@ -1157,7 +1157,7 @@
6
7 if (ext)
8 {
9- X509V3_EXT_METHOD *method = X509V3_EXT_get(ext);
10+ X509V3_EXT_METHOD *method = (X509V3_EXT_METHOD *)X509V3_EXT_get(ext);
11 if (!method)
12 {
13 WvDynBuf buf;
14Index: wvstreams-4.6.1/ipstreams/wvunixdgsocket.cc
15===================================================================
16--- wvstreams-4.6.1.orig/ipstreams/wvunixdgsocket.cc 2011-05-20 00:02:38.391136584 +0200
17+++ wvstreams-4.6.1/ipstreams/wvunixdgsocket.cc 2011-05-20 00:02:35.283136585 +0200
18@@ -1,8 +1,6 @@
19 #include "wvunixdgsocket.h"
20-#ifdef MACOS
21 #include <sys/types.h>
22 #include <sys/stat.h>
23-#endif
24
25 WvUnixDGSocket::WvUnixDGSocket(WvStringParm filename, bool _server, int perms)
26 : socketfile(filename)
27Index: wvstreams-4.6.1/streams/wvatomicfile.cc
28===================================================================
29--- wvstreams-4.6.1.orig/streams/wvatomicfile.cc 2011-05-20 00:02:38.223136584 +0200
30+++ wvstreams-4.6.1/streams/wvatomicfile.cc 2011-05-20 00:02:31.619136587 +0200
31@@ -10,10 +10,7 @@
32 #include "wvatomicfile.h"
33 #include "wvfileutils.h"
34 #include "wvstrutils.h"
35-
36-#ifdef MACOS
37 #include <sys/stat.h>
38-#endif
39
40 WvAtomicFile::WvAtomicFile(WvStringParm filename, int flags, mode_t create_mode)
41 : tmp_file(WvString::null)
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/06_gcc-4.7.diff b/meta-oe/recipes-connectivity/wvdial/wvstreams/06_gcc-4.7.diff
new file mode 100644
index 000000000..a75067a10
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/06_gcc-4.7.diff
@@ -0,0 +1,18 @@
1Description: Fix FTBFS with gcc-4.7
2 Small header include change. This is borderlinde cosmetic, but still needed
3 to prevent the FTBFS.
4Author: Paul Tagliamonte <paultag@ubuntu.com>
5Origin: vendor
6Bug-Debian: http://bugs.debian.org/667418
7Last-Update: 2012-04-13
8
9--- wvstreams-4.6.1.orig/utils/wvuid.cc
10+++ wvstreams-4.6.1/utils/wvuid.cc
11@@ -33,6 +33,7 @@ wvuid_t wvgetuid()
12
13 #else // not WIN32
14
15+#include <unistd.h>
16
17 WvString wv_username_from_uid(wvuid_t uid)
18 {
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/07_buildflags.diff b/meta-oe/recipes-connectivity/wvdial/wvstreams/07_buildflags.diff
new file mode 100644
index 000000000..ec99dcd36
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/07_buildflags.diff
@@ -0,0 +1,32 @@
1Index: b/gen-cc
2===================================================================
3--- a/gen-cc
4+++ b/gen-cc
5@@ -15,6 +15,11 @@
6 shift
7 shift
8
9+ echo $CC \$MODE -o \$BASE.o \$BASE.$EXT \\
10+ -MMD -MF \$DEPFILE -MP -MQ \$BASE.o \\
11+ $CPPFLAGS \\
12+ $CFLAGS \\
13+ "\$@"
14 $CC \$MODE -o \$BASE.o \$BASE.$EXT \\
15 -MMD -MF \$DEPFILE -MP -MQ \$BASE.o \\
16 $CPPFLAGS \\
17Index: b/wvrules-posix.mk
18===================================================================
19--- a/wvrules-posix.mk
20+++ b/wvrules-posix.mk
21@@ -35,11 +35,6 @@
22 # Default compiler we use for linking
23 WVLINK_CC = $(CXX)
24
25-ifneq ("$(enable_optimization)", "no")
26- CXXFLAGS+=-O2
27- CFLAGS+=-O2
28-endif
29-
30 ifneq ("$(enable_warnings)", "no")
31 CXXFLAGS+=-Wall -Woverloaded-virtual
32 CFLAGS+=-Wall
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb
new file mode 100644
index 000000000..ce2b33740
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb
@@ -0,0 +1,42 @@
1HOMEPAGE = "http://alumnit.ca/wiki/index.php?page=WvStreams"
2DESCRIPTION = "WvStreams is a network programming library in C++"
3
4LICENSE = "LGPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
6
7DEPENDS = "zlib openssl (>= 0.9.8)"
8
9SRC_URI = "http://${PN}.googlecode.com/files/${PN}-${PV}.tar.gz \
10 file://04_signed_request.diff \
11 file://05_gcc.diff \
12 file://06_gcc-4.7.diff \
13 file://07_buildflags.diff \
14 "
15
16SRC_URI[md5sum] = "2760dac31a43d452a19a3147bfde571c"
17SRC_URI[sha256sum] = "8403f5fbf83aa9ac0c6ce15d97fd85607488152aa84e007b7d0621b8ebc07633"
18
19inherit autotools pkgconfig
20
21PARALLEL_MAKE = ""
22
23LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib"
24
25EXTRA_OECONF = " --without-tcl --without-qt --without-pam --without-valgrind"
26
27PACKAGES_prepend = "libuniconf libuniconf-dbg "
28PACKAGES_prepend = "uniconfd uniconfd-dbg "
29PACKAGES_prepend = "libwvstreams-base libwvstreams-base-dbg "
30PACKAGES_prepend = "libwvstreams-extras libwvstreams-extras-dbg "
31
32FILES_libuniconf = "${libdir}/libuniconf.so.*"
33FILES_libuniconf-dbg = "${libdir}/.debug/libuniconf.so.*"
34
35FILES_uniconfd = "${sbindir}/uniconfd ${sysconfdir}/uniconf.conf ${localstatedir}/uniconf"
36FILES_uniconfd-dbg = "${sbindir}/.debug/uniconfd"
37
38FILES_libwvstreams-base = "${libdir}/libwvutils.so.*"
39FILES_libwvstreams-base-dbg = "${libdir}/.debug/libwvutils.so.*"
40
41FILES_libwvstreams-extras = "${libdir}/libwvbase.so.* ${libdir}/libwvstreams.so.*"
42FILES_libwvstreams-extras-dbg = "${libdir}/.debug/libwvbase.so.* ${libdir}/.debug/libwvstreams.so.*"