summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/wvdial
diff options
context:
space:
mode:
authorMario Domenech Goulart <mario@ossystems.com.br>2013-09-24 12:43:57 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-05 12:36:23 +0200
commit73a68490efe05cdbec540ec6f17782816632a24d (patch)
tree7eea1efa44b2eab8c5dfebcc2f5a2fcfc653802f /meta-oe/recipes-connectivity/wvdial
parent6fd61c04df134fc9bbad03614d301256124250a8 (diff)
downloadmeta-openembedded-73a68490efe05cdbec540ec6f17782816632a24d.tar.gz
wvdial: add recipe for version 1.61
Recipe based on OE classic's recipe for version 1.60, as of ff0d06489db2e50353d72d24aada74c60bddb016. Summary of changes against OE classic's recipe: * Apply typo_pon.wvdial.1.patch patch from Debian's http://patch-tracker.debian.org/package/wvdial/1.61-4.1 * Fix Makefile in do_configure task * Add wvstreams' include dir to BUILD_CPPFLAGS * Minor adjustments for the current build system (add LIC_FILES_CHKSUM, md5 and sha256 sums for SRC_URI, fix LICENSE, remove PR) * Disable parallel make, since it was causing errors like Log data follows: | DEBUG: Executing shell function do_compile | NOTE: make -j 8 | * Generating CC | ./CXX -c wvdialer | * Generating CXX | ./CXX -c wvmodemscan | /bin/bash: ./CXX: No such file or directory | make: *** [wvdialer.o] Error 127 | make: *** Waiting for unfinished jobs.... | make: *** wait: No child processes. Stop. | ERROR: oe_runmake failed | WARNING: .../tmp/work/armv7a-vfp-neon-oel-linux-gnueabi/wvdial/1.61-r0/temp/run.do_compile.18676:1 exit 1 from | exit 1 Signed-off-by: Mario Domenech Goulart <mario@ossystems.com.br> Acked-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/wvdial')
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvdial/typo_pon.wvdial.1.patch20
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb30
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/wvdial/wvdial/typo_pon.wvdial.1.patch b/meta-oe/recipes-connectivity/wvdial/wvdial/typo_pon.wvdial.1.patch
new file mode 100644
index 000000000..eec5a5d64
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvdial/typo_pon.wvdial.1.patch
@@ -0,0 +1,20 @@
1Remove warnings found by lintian
2Last-Update: 2011-01-09
3Index: wvdial-1.61/pon.wvdial.1
4===================================================================
5--- wvdial-1.61.orig/pon.wvdial.1 2011-01-09 21:33:03.000000000 +0300
6+++ wvdial-1.61/pon.wvdial.1 2011-01-09 21:33:15.000000000 +0300
7@@ -8,13 +8,11 @@
8 .SH DESCRIPTION
9 .B pon.wvdial
10 .br
11-.TR
12 .B poff.wvdial
13 .br
14 .RS
15 Replacement scripts for pon and poff.
16 .RE
17-\."
18 .SH SEE ALSO
19 .BR wvdial (1),
20 .BR pon (1),
diff --git a/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb b/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb
new file mode 100644
index 000000000..af1ebf302
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb
@@ -0,0 +1,30 @@
1HOMEPAGE = "http://www.alumnit.ca/wiki/?WvDial"
2DESCRIPTION = "WvDial is a program that makes it easy to connect your Linux workstation to the Internet."
3
4LICENSE = "LGPLv2"
5LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605"
6
7DEPENDS = "wvstreams"
8RDEPENDS_${PN} = "ppp"
9
10SRC_URI = "http://${PN}.googlecode.com/files/${PN}-${PV}.tar.bz2 \
11 file://typo_pon.wvdial.1.patch \
12 "
13
14SRC_URI[md5sum] = "37e9a2d664effe4efd44c0e1a20136de"
15SRC_URI[sha256sum] = "99906d9560cbdbc97e1855e7b0a7169f1e11983be3ac539140423f09debced82"
16
17EXTRA_OEMAKE = ""
18export WVLINK="${LD}"
19
20PARALLEL_MAKE = ""
21
22BUILD_CPPFLAGS += "-I${STAGING_INCDIR}/wvstreams"
23
24do_configure() {
25 sed -i 's/LDFLAGS+=-luniconf/LIBS+=-luniconf/' ${S}/Makefile
26}
27
28do_install() {
29 oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install
30}