summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/loudmouth
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-connectivity/loudmouth
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/loudmouth')
-rw-r--r--meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/04-use-pkg-config-for-gnutls.patch23
-rw-r--r--meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/glib-2.32.patch10
-rw-r--r--meta-oe/recipes-connectivity/loudmouth/loudmouth_1.4.3.bb20
3 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/04-use-pkg-config-for-gnutls.patch b/meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/04-use-pkg-config-for-gnutls.patch
new file mode 100644
index 000000000..20f388e89
--- /dev/null
+++ b/meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/04-use-pkg-config-for-gnutls.patch
@@ -0,0 +1,23 @@
1Description: use pkg-config to detect gnutls
2Debian: http://bugs.debian.org/529835
3Origin: http://groups.google.com/group/loudmouth-dev/browse_thread/thread/3f78255837048daf#
4
5--- a/configure.ac.orig 2009-08-16 20:29:36.000000000 +0200
6+++ b/configure.ac 2009-08-16 20:30:43.000000000 +0200
7@@ -146,10 +146,12 @@ AC_ARG_WITH(openssl-libs,
8 enable_ssl=no
9 if test "x$ac_ssl" = "xgnutls"; then
10 dnl Look for GnuTLS
11- AM_PATH_LM_LIBGNUTLS($GNUTLS_REQUIRED, have_libgnutls=yes, have_libgnutls=no)
12- if test "x$have_libgnutls" = "xyes"; then
13- CFLAGS="$CFLAGS $LIBGNUTLS_CFLAGS"
14- LIBS="$LIBS $LIBGNUTLS_LIBS"
15+ PKG_CHECK_MODULES(GNUTLS, gnutls >= $GNUTLS_REQUIRED, have_gnutls=yes, have_gnutls=no)
16+ if test "x$have_gnutls" = "xyes"; then
17+ AC_SUBST(ASYNCNS_CFLAGS)
18+ AC_SUBST(ASYNCNS_LIBS)
19+ CFLAGS="$CFLAGS $GNUTLS_CFLAGS"
20+ LIBS="$LIBS $GNUTLS_LIBS"
21 AC_DEFINE(HAVE_GNUTLS, 1, [whether to use GnuTSL support.])
22 enable_ssl=GnuTLS
23 else
diff --git a/meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/glib-2.32.patch b/meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/glib-2.32.patch
new file mode 100644
index 000000000..b6c9422e8
--- /dev/null
+++ b/meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/glib-2.32.patch
@@ -0,0 +1,10 @@
1--- loudmouth-1.4.3.orig/loudmouth/lm-error.c 2008-10-29 21:48:15.000000000 +0100
2+++ loudmouth-1.4.3/loudmouth/lm-error.c 2012-05-06 08:27:07.455739440 +0200
3@@ -19,7 +19,6 @@
4 */
5
6 #include <config.h>
7-#include <glib/gerror.h>
8 #include "lm-error.h"
9
10 /**
diff --git a/meta-oe/recipes-connectivity/loudmouth/loudmouth_1.4.3.bb b/meta-oe/recipes-connectivity/loudmouth/loudmouth_1.4.3.bb
new file mode 100644
index 000000000..e51241909
--- /dev/null
+++ b/meta-oe/recipes-connectivity/loudmouth/loudmouth_1.4.3.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "Loudmouth is a lightweight and easy-to-use C library for programming with the Jabber protocol."
2HOMEPAGE = "http://www.loudmouth-project.org/"
3
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c4f38aef94828f6b280e00d1173be689"
6
7DEPENDS = "glib-2.0 libcheck openssl libidn"
8
9inherit gnomebase gtk-doc
10
11PR = "r2"
12
13SRC_URI += "file://04-use-pkg-config-for-gnutls.patch \
14 file://glib-2.32.patch"
15
16SRC_URI[archive.md5sum] = "55339ca42494690c3942ee1465a96937"
17SRC_URI[archive.sha256sum] = "95a93f5d009b71ea8193d994aa11f311bc330a3efe1b7cd74dc48f11c7f929e3"
18
19EXTRA_OECONF = "--with-ssl=openssl"
20