summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/04-use-pkg-config-for-gnutls.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/04-use-pkg-config-for-gnutls.patch')
-rw-r--r--meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/04-use-pkg-config-for-gnutls.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/04-use-pkg-config-for-gnutls.patch b/meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/04-use-pkg-config-for-gnutls.patch
new file mode 100644
index 000000000..20f388e89
--- /dev/null
+++ b/meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/04-use-pkg-config-for-gnutls.patch
@@ -0,0 +1,23 @@
1Description: use pkg-config to detect gnutls
2Debian: http://bugs.debian.org/529835
3Origin: http://groups.google.com/group/loudmouth-dev/browse_thread/thread/3f78255837048daf#
4
5--- a/configure.ac.orig 2009-08-16 20:29:36.000000000 +0200
6+++ b/configure.ac 2009-08-16 20:30:43.000000000 +0200
7@@ -146,10 +146,12 @@ AC_ARG_WITH(openssl-libs,
8 enable_ssl=no
9 if test "x$ac_ssl" = "xgnutls"; then
10 dnl Look for GnuTLS
11- AM_PATH_LM_LIBGNUTLS($GNUTLS_REQUIRED, have_libgnutls=yes, have_libgnutls=no)
12- if test "x$have_libgnutls" = "xyes"; then
13- CFLAGS="$CFLAGS $LIBGNUTLS_CFLAGS"
14- LIBS="$LIBS $LIBGNUTLS_LIBS"
15+ PKG_CHECK_MODULES(GNUTLS, gnutls >= $GNUTLS_REQUIRED, have_gnutls=yes, have_gnutls=no)
16+ if test "x$have_gnutls" = "xyes"; then
17+ AC_SUBST(ASYNCNS_CFLAGS)
18+ AC_SUBST(ASYNCNS_LIBS)
19+ CFLAGS="$CFLAGS $GNUTLS_CFLAGS"
20+ LIBS="$LIBS $GNUTLS_LIBS"
21 AC_DEFINE(HAVE_GNUTLS, 1, [whether to use GnuTSL support.])
22 enable_ssl=GnuTLS
23 else