summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2024-08-14 10:30:09 +0200
committerKhem Raj <raj.khem@gmail.com>2024-09-01 15:54:30 -0700
commit84d6e138cb558cea9155e5a392e2ff7647e2e688 (patch)
tree816a1e846cecedb61817337825a37c59fcd7edd8 /meta-oe/recipes-bsp
parentc8f4a786402063d160fa16284c16c8fca8165a5a (diff)
downloadmeta-openembedded-84d6e138cb558cea9155e5a392e2ff7647e2e688.tar.gz
cleanup after polkit fix
This commit removes the need to fix polkit permissions: https://git.openembedded.org/meta-openembedded/commit/?h=master-next&id=d5e90541f8e35916abc930b2da6de037b23d51a1 That allows to do some cleanup Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp')
-rw-r--r--meta-oe/recipes-bsp/fwupd/fwupd_1.9.24.bb13
1 files changed, 1 insertions, 12 deletions
diff --git a/meta-oe/recipes-bsp/fwupd/fwupd_1.9.24.bb b/meta-oe/recipes-bsp/fwupd/fwupd_1.9.24.bb
index 8b66084b7..15cde9f10 100644
--- a/meta-oe/recipes-bsp/fwupd/fwupd_1.9.24.bb
+++ b/meta-oe/recipes-bsp/fwupd/fwupd_1.9.24.bb
@@ -14,7 +14,7 @@ UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)"
14# Machine-specific as we examine MACHINE_FEATURES to decide whether to build the UEFI plugins 14# Machine-specific as we examine MACHINE_FEATURES to decide whether to build the UEFI plugins
15PACKAGE_ARCH = "${MACHINE_ARCH}" 15PACKAGE_ARCH = "${MACHINE_ARCH}"
16 16
17inherit meson vala gobject-introspection systemd bash-completion pkgconfig gi-docgen ptest manpages useradd 17inherit meson vala gobject-introspection systemd bash-completion pkgconfig gi-docgen ptest manpages
18 18
19GIDOCGEN_MESON_OPTION = 'docs' 19GIDOCGEN_MESON_OPTION = 'docs'
20GIDOCGEN_MESON_ENABLE_FLAG = 'enabled' 20GIDOCGEN_MESON_ENABLE_FLAG = 'enabled'
@@ -116,17 +116,6 @@ DISABLE_NON_X86:x86 = ""
116DISABLE_NON_X86:x86-64 = "" 116DISABLE_NON_X86:x86-64 = ""
117PACKAGECONFIG:remove = "${DISABLE_NON_X86}" 117PACKAGECONFIG:remove = "${DISABLE_NON_X86}"
118 118
119USERADD_PACKAGES = "${PN}"
120USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 --shell /bin/nologin polkitd"
121
122do_install:append() {
123 if ${@bb.utils.contains('PACKAGECONFIG', 'polkit', 'true', 'false', d)}; then
124 #Fix up permissions on polkit rules.d to work with rpm4 constraints
125 chmod 700 ${D}/${datadir}/polkit-1/rules.d
126 chown polkitd:root ${D}/${datadir}/polkit-1/rules.d
127 fi
128}
129
130FILES:${PN} += "${libdir}/fwupd-plugins-* \ 119FILES:${PN} += "${libdir}/fwupd-plugins-* \
131 ${libdir}/fwupd-${PV} \ 120 ${libdir}/fwupd-${PV} \
132 ${systemd_unitdir} \ 121 ${systemd_unitdir} \