diff options
8 files changed, 8 insertions, 86 deletions
diff --git a/meta-gnome/dynamic-layers/meta-security/recipes-gnome/gnome-remote-desktop/gnome-remote-desktop_46.2.bb b/meta-gnome/dynamic-layers/meta-security/recipes-gnome/gnome-remote-desktop/gnome-remote-desktop_46.2.bb index 59ae9383db..a16a02aa7b 100644 --- a/meta-gnome/dynamic-layers/meta-security/recipes-gnome/gnome-remote-desktop/gnome-remote-desktop_46.2.bb +++ b/meta-gnome/dynamic-layers/meta-security/recipes-gnome/gnome-remote-desktop/gnome-remote-desktop_46.2.bb | |||
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | |||
4 | 4 | ||
5 | GNOMEBASEBUILDCLASS = "meson" | 5 | GNOMEBASEBUILDCLASS = "meson" |
6 | 6 | ||
7 | inherit gnomebase gettext gsettings features_check useradd | 7 | inherit gnomebase gettext gsettings features_check |
8 | 8 | ||
9 | REQUIRED_DISTRO_FEATURES = "opengl polkit" | 9 | REQUIRED_DISTRO_FEATURES = "opengl polkit" |
10 | 10 | ||
@@ -36,15 +36,5 @@ PACKAGECONFIG[vnc] = "-Dvnc=true,-Dvnc=false,libvncserver" | |||
36 | PACKAGECONFIG[rdp] = "-Drdp=true,-Drdp=false,freerdp3 fuse3 libxkbcommon" | 36 | PACKAGECONFIG[rdp] = "-Drdp=true,-Drdp=false,freerdp3 fuse3 libxkbcommon" |
37 | PACKAGECONFIG[systemd] = "-Dsystemd=true,-Dsystemd=false,systemd" | 37 | PACKAGECONFIG[systemd] = "-Dsystemd=true,-Dsystemd=false,systemd" |
38 | 38 | ||
39 | USERADD_PACKAGES = "${PN}" | ||
40 | USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 polkitd" | ||
41 | |||
42 | do_install:append() { | ||
43 | if [ -d ${D}${datadir}/polkit-1/rules.d ]; then | ||
44 | chmod 700 ${D}${datadir}/polkit-1/rules.d | ||
45 | chown polkitd:root ${D}${datadir}/polkit-1/rules.d | ||
46 | fi | ||
47 | } | ||
48 | |||
49 | PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src" | 39 | PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src" |
50 | FILES:${PN} += "${systemd_user_unitdir} ${systemd_system_unitdir} ${datadir} ${libdir}/sysusers.d ${libdir}/tmpfiles.d" | 40 | FILES:${PN} += "${systemd_user_unitdir} ${systemd_system_unitdir} ${datadir} ${libdir}/sysusers.d ${libdir}/tmpfiles.d" |
diff --git a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.2.bb b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.2.bb index 152e803b5d..ae96caf94f 100644 --- a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.2.bb +++ b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.2.bb | |||
@@ -33,7 +33,7 @@ DEPENDS = " \ | |||
33 | upower \ | 33 | upower \ |
34 | " | 34 | " |
35 | 35 | ||
36 | inherit gtk-icon-cache pkgconfig gnomebase gsettings gettext upstream-version-is-even bash-completion features_check useradd | 36 | inherit gtk-icon-cache pkgconfig gnomebase gsettings gettext upstream-version-is-even bash-completion features_check |
37 | 37 | ||
38 | REQUIRED_DISTRO_FEATURES += "opengl polkit pulseaudio systemd x11" | 38 | REQUIRED_DISTRO_FEATURES += "opengl polkit pulseaudio systemd x11" |
39 | 39 | ||
@@ -52,16 +52,6 @@ EXTRA_OEMESON += "-Doe_sysroot=${STAGING_DIR_HOST}" | |||
52 | 52 | ||
53 | export XDG_DATA_DIRS = "${STAGING_DATADIR}" | 53 | export XDG_DATA_DIRS = "${STAGING_DATADIR}" |
54 | 54 | ||
55 | USERADD_PACKAGES = "${PN}" | ||
56 | USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 polkitd" | ||
57 | |||
58 | do_install:append() { | ||
59 | if [ -d ${D}${datadir}/polkit-1/rules.d ]; then | ||
60 | chmod 700 ${D}${datadir}/polkit-1/rules.d | ||
61 | chown polkitd:root ${D}${datadir}/polkit-1/rules.d | ||
62 | fi | ||
63 | } | ||
64 | |||
65 | PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src" | 55 | PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src" |
66 | 56 | ||
67 | FILES:${PN} += " \ | 57 | FILES:${PN} += " \ |
diff --git a/meta-gnome/recipes-gnome/gvfs/gvfs_1.54.0.bb b/meta-gnome/recipes-gnome/gvfs/gvfs_1.54.0.bb index 01cdb4eef5..6549b1900f 100644 --- a/meta-gnome/recipes-gnome/gvfs/gvfs_1.54.0.bb +++ b/meta-gnome/recipes-gnome/gvfs/gvfs_1.54.0.bb | |||
@@ -2,7 +2,7 @@ DESCRIPTION = "gvfs is a userspace virtual filesystem" | |||
2 | LICENSE = "LGPL-2.0-only" | 2 | LICENSE = "LGPL-2.0-only" |
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=05df38dd77c35ec8431f212410a3329e" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=05df38dd77c35ec8431f212410a3329e" |
4 | 4 | ||
5 | inherit gnomebase gsettings bash-completion gettext upstream-version-is-even features_check useradd | 5 | inherit gnomebase gsettings bash-completion gettext upstream-version-is-even features_check |
6 | 6 | ||
7 | DEPENDS += "\ | 7 | DEPENDS += "\ |
8 | dbus \ | 8 | dbus \ |
@@ -77,16 +77,7 @@ PACKAGECONFIG[fuse] = "-Dfuse=true, -Dfuse=false, fuse3" | |||
77 | # libcdio-paranoia recipe doesn't exist yet | 77 | # libcdio-paranoia recipe doesn't exist yet |
78 | PACKAGECONFIG[cdda] = "-Dcdda=true, -Dcdda=false, libcdio-paranoia" | 78 | PACKAGECONFIG[cdda] = "-Dcdda=true, -Dcdda=false, libcdio-paranoia" |
79 | 79 | ||
80 | USERADD_PACKAGES = "${PN}" | ||
81 | USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 polkitd" | ||
82 | |||
83 | do_install:append() { | 80 | do_install:append() { |
84 | if ${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'true', 'false', d)}; then | ||
85 | # Fix up permissions on polkit rules.d to work with rpm4 constraints | ||
86 | chmod 700 ${D}${datadir}/polkit-1/rules.d | ||
87 | chown polkitd:root ${D}${datadir}/polkit-1/rules.d | ||
88 | fi | ||
89 | |||
90 | # After rebuilds (not from scracth) it can happen that the executables in | 81 | # After rebuilds (not from scracth) it can happen that the executables in |
91 | # libexec ar missing executable permission flag. Not sure but it came up | 82 | # libexec ar missing executable permission flag. Not sure but it came up |
92 | # during transition to meson. Looked into build files and logs but could | 83 | # during transition to meson. Looked into build files and logs but could |
diff --git a/meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb b/meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb index 42e20cc9ed..e7f0987e0f 100644 --- a/meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb +++ b/meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb | |||
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | |||
4 | 4 | ||
5 | DEPENDS = "gtk+3 glib-2.0 bluez5 python3-pygobject python3-cython-native" | 5 | DEPENDS = "gtk+3 glib-2.0 bluez5 python3-pygobject python3-cython-native" |
6 | 6 | ||
7 | inherit meson gettext systemd gsettings pkgconfig python3native gtk-icon-cache useradd features_check python3targetconfig | 7 | inherit meson gettext systemd gsettings pkgconfig python3native gtk-icon-cache features_check python3targetconfig |
8 | 8 | ||
9 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" | 9 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
10 | 10 | ||
@@ -60,12 +60,3 @@ do_install:append() { | |||
60 | ${D}${bindir}/blueman-services \ | 60 | ${D}${bindir}/blueman-services \ |
61 | ${D}${bindir}/blueman-tray | 61 | ${D}${bindir}/blueman-tray |
62 | } | 62 | } |
63 | |||
64 | USERADD_PACKAGES = "${PN}" | ||
65 | USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 --shell /bin/nologin polkitd" | ||
66 | |||
67 | do_install:append() { | ||
68 | # Fix up permissions on polkit rules.d to work with rpm4 constraints | ||
69 | chmod 700 ${D}/${datadir}/polkit-1/rules.d | ||
70 | chown polkitd:root ${D}/${datadir}/polkit-1/rules.d | ||
71 | } | ||
diff --git a/meta-oe/recipes-bsp/fwupd/fwupd_1.9.24.bb b/meta-oe/recipes-bsp/fwupd/fwupd_1.9.24.bb index 8b66084b77..15cde9f100 100644 --- a/meta-oe/recipes-bsp/fwupd/fwupd_1.9.24.bb +++ b/meta-oe/recipes-bsp/fwupd/fwupd_1.9.24.bb | |||
@@ -14,7 +14,7 @@ UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)" | |||
14 | # Machine-specific as we examine MACHINE_FEATURES to decide whether to build the UEFI plugins | 14 | # Machine-specific as we examine MACHINE_FEATURES to decide whether to build the UEFI plugins |
15 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 15 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
16 | 16 | ||
17 | inherit meson vala gobject-introspection systemd bash-completion pkgconfig gi-docgen ptest manpages useradd | 17 | inherit meson vala gobject-introspection systemd bash-completion pkgconfig gi-docgen ptest manpages |
18 | 18 | ||
19 | GIDOCGEN_MESON_OPTION = 'docs' | 19 | GIDOCGEN_MESON_OPTION = 'docs' |
20 | GIDOCGEN_MESON_ENABLE_FLAG = 'enabled' | 20 | GIDOCGEN_MESON_ENABLE_FLAG = 'enabled' |
@@ -116,17 +116,6 @@ DISABLE_NON_X86:x86 = "" | |||
116 | DISABLE_NON_X86:x86-64 = "" | 116 | DISABLE_NON_X86:x86-64 = "" |
117 | PACKAGECONFIG:remove = "${DISABLE_NON_X86}" | 117 | PACKAGECONFIG:remove = "${DISABLE_NON_X86}" |
118 | 118 | ||
119 | USERADD_PACKAGES = "${PN}" | ||
120 | USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 --shell /bin/nologin polkitd" | ||
121 | |||
122 | do_install:append() { | ||
123 | if ${@bb.utils.contains('PACKAGECONFIG', 'polkit', 'true', 'false', d)}; then | ||
124 | #Fix up permissions on polkit rules.d to work with rpm4 constraints | ||
125 | chmod 700 ${D}/${datadir}/polkit-1/rules.d | ||
126 | chown polkitd:root ${D}/${datadir}/polkit-1/rules.d | ||
127 | fi | ||
128 | } | ||
129 | |||
130 | FILES:${PN} += "${libdir}/fwupd-plugins-* \ | 119 | FILES:${PN} += "${libdir}/fwupd-plugins-* \ |
131 | ${libdir}/fwupd-${PV} \ | 120 | ${libdir}/fwupd-${PV} \ |
132 | ${systemd_unitdir} \ | 121 | ${systemd_unitdir} \ |
diff --git a/meta-oe/recipes-extended/flatpak/flatpak_1.15.10.bb b/meta-oe/recipes-extended/flatpak/flatpak_1.15.10.bb index cf512c7cc6..c9d04e9261 100644 --- a/meta-oe/recipes-extended/flatpak/flatpak_1.15.10.bb +++ b/meta-oe/recipes-extended/flatpak/flatpak_1.15.10.bb | |||
@@ -12,7 +12,7 @@ SRCREV = "8b4f523c4f8287d57f1a84a3a8216efe200c5fbf" | |||
12 | 12 | ||
13 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
14 | 14 | ||
15 | inherit meson pkgconfig gettext systemd gtk-doc gobject-introspection python3native useradd mime features_check | 15 | inherit meson pkgconfig gettext systemd gtk-doc gobject-introspection python3native mime features_check |
16 | 16 | ||
17 | REQUIRED_DISTRO_FEATURES = "polkit" | 17 | REQUIRED_DISTRO_FEATURES = "polkit" |
18 | 18 | ||
@@ -76,12 +76,3 @@ EXTRA_OEMESON = " \ | |||
76 | " | 76 | " |
77 | 77 | ||
78 | FILES:${PN} += "${libdir} ${datadir}" | 78 | FILES:${PN} += "${libdir} ${datadir}" |
79 | |||
80 | USERADD_PACKAGES = "${PN}" | ||
81 | USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 polkitd" | ||
82 | |||
83 | do_install:append() { | ||
84 | chmod 0700 ${D}/${datadir}/polkit-1/rules.d | ||
85 | chown polkitd ${D}/${datadir}/polkit-1/rules.d | ||
86 | chgrp root ${D}/${datadir}/polkit-1/rules.d | ||
87 | } | ||
diff --git a/meta-oe/recipes-gnome/malcontent/malcontent.bb b/meta-oe/recipes-gnome/malcontent/malcontent.bb index c4bc50fa8e..b30d85080b 100644 --- a/meta-oe/recipes-gnome/malcontent/malcontent.bb +++ b/meta-oe/recipes-gnome/malcontent/malcontent.bb | |||
@@ -17,7 +17,7 @@ DEPENDS = " \ | |||
17 | 17 | ||
18 | GIR_MESON_OPTION = "" | 18 | GIR_MESON_OPTION = "" |
19 | 19 | ||
20 | inherit meson pkgconfig gobject-introspection gettext features_check useradd | 20 | inherit meson pkgconfig gobject-introspection gettext features_check |
21 | 21 | ||
22 | REQUIRED_DISTRO_FEATURES = "pam polkit gobject-introspection" | 22 | REQUIRED_DISTRO_FEATURES = "pam polkit gobject-introspection" |
23 | 23 | ||
@@ -26,15 +26,6 @@ PACKAGECONFIG[ui] = ",,,malcontent-ui" | |||
26 | 26 | ||
27 | EXTRA_OEMESON = "-Dui=disabled" | 27 | EXTRA_OEMESON = "-Dui=disabled" |
28 | 28 | ||
29 | USERADD_PACKAGES = "${PN}" | ||
30 | USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 --shell /bin/nologin polkitd" | ||
31 | |||
32 | do_install:append() { | ||
33 | # Fix up permissions on polkit rules.d to work with rpm4 constraints | ||
34 | chmod 700 ${D}/${datadir}/polkit-1/rules.d | ||
35 | chown polkitd:root ${D}/${datadir}/polkit-1/rules.d | ||
36 | } | ||
37 | |||
38 | FILES:${PN} += " \ | 29 | FILES:${PN} += " \ |
39 | ${libdir}/security/pam_malcontent.so \ | 30 | ${libdir}/security/pam_malcontent.so \ |
40 | ${datadir}/accountsservice \ | 31 | ${datadir}/accountsservice \ |
diff --git a/meta-oe/recipes-navigation/geoclue/geoclue_2.7.1.bb b/meta-oe/recipes-navigation/geoclue/geoclue_2.7.1.bb index 9fcd1e6f1e..5d247fb9c2 100644 --- a/meta-oe/recipes-navigation/geoclue/geoclue_2.7.1.bb +++ b/meta-oe/recipes-navigation/geoclue/geoclue_2.7.1.bb | |||
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=bdfdd4986a0853eb84eeba85f9d0c4d6" | |||
10 | 10 | ||
11 | DEPENDS = "glib-2.0 dbus json-glib libsoup-3.0 intltool-native" | 11 | DEPENDS = "glib-2.0 dbus json-glib libsoup-3.0 intltool-native" |
12 | 12 | ||
13 | inherit meson pkgconfig gtk-doc gobject-introspection vala useradd | 13 | inherit meson pkgconfig gtk-doc gobject-introspection vala |
14 | 14 | ||
15 | SRCREV = "8a24f60969d4c235d9918796c38a6a9c42e10131" | 15 | SRCREV = "8a24f60969d4c235d9918796c38a6a9c42e10131" |
16 | SRC_URI = "git://gitlab.freedesktop.org/geoclue/geoclue.git;protocol=https;branch=master \ | 16 | SRC_URI = "git://gitlab.freedesktop.org/geoclue/geoclue.git;protocol=https;branch=master \ |
@@ -36,17 +36,6 @@ EXTRA_OEMESON += " \ | |||
36 | -Ddbus-sys-dir=${sysconfdir}/dbus-1/system.d \ | 36 | -Ddbus-sys-dir=${sysconfdir}/dbus-1/system.d \ |
37 | " | 37 | " |
38 | 38 | ||
39 | USERADD_PACKAGES = "${PN}" | ||
40 | USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 --shell /bin/nologin polkitd" | ||
41 | |||
42 | do_install:append() { | ||
43 | if ${@bb.utils.contains('PACKAGECONFIG', 'modem-gps', 'true', 'false', d)}; then | ||
44 | # Fix up permissions on polkit rules.d to work with rpm4 constraints | ||
45 | chmod 700 ${D}/${datadir}/polkit-1/rules.d | ||
46 | chown polkitd:root ${D}/${datadir}/polkit-1/rules.d | ||
47 | fi | ||
48 | } | ||
49 | |||
50 | FILES:${PN} += " \ | 39 | FILES:${PN} += " \ |
51 | ${datadir}/dbus-1/system-services \ | 40 | ${datadir}/dbus-1/system-services \ |
52 | ${datadir}/polkit-1/rules.d \ | 41 | ${datadir}/polkit-1/rules.d \ |