summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp/ledmon
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2019-11-01 17:34:50 +0800
committerKhem Raj <raj.khem@gmail.com>2019-11-01 17:22:53 -0700
commit92de599596f7c20ead9b9a912ef3ee700b2f691b (patch)
tree320fc548c0e2231ee5feac7837ebb20a262e256b /meta-oe/recipes-bsp/ledmon
parente37c095560dde568435131fa338fe3f14bd862cd (diff)
downloadmeta-openembedded-92de599596f7c20ead9b9a912ef3ee700b2f691b.tar.gz
ledmon: upgrade to 0.93
1) inherit autotools as new version use autotools. 2) Add a patch to fix compile error. 0001-Don-t-build-with-Werror-to-fix-compile-error.patch 3) Modify do_install_append() function to fix do_package error as follows: ledmon-git-r0 do_package: SYSTEMD_SERVICE_ledmon value ledmon.service does not exist 4) Add ${S}/config in CFLAGS. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp/ledmon')
-rw-r--r--meta-oe/recipes-bsp/ledmon/ledmon/0001-Don-t-build-with-Werror-to-fix-compile-error.patch29
-rw-r--r--meta-oe/recipes-bsp/ledmon/ledmon_git.bb17
2 files changed, 41 insertions, 5 deletions
diff --git a/meta-oe/recipes-bsp/ledmon/ledmon/0001-Don-t-build-with-Werror-to-fix-compile-error.patch b/meta-oe/recipes-bsp/ledmon/ledmon/0001-Don-t-build-with-Werror-to-fix-compile-error.patch
new file mode 100644
index 000000000..b65f1a732
--- /dev/null
+++ b/meta-oe/recipes-bsp/ledmon/ledmon/0001-Don-t-build-with-Werror-to-fix-compile-error.patch
@@ -0,0 +1,29 @@
1Subject: [PATCH] Don't build with -Werror to fix compile error.
2
3| 550 | _dump_sgpio_amd(&amd_reg->amd);
4| | ^~~~~~~~~~~~~
5| amd_sgpio.c: In function '_write_amd_register':
6| amd_sgpio.c:558:18: error: taking address of packed member of 'struct amd_register' may result in an unaligned pointer value [-Werror=address-of-packed-member]
7
8Upstream-Status: Pending
9
10Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
11---
12 configure.ac | 1 -
13 1 file changed, 1 deletion(-)
14
15diff --git a/configure.ac b/configure.ac
16index 7bc20f8..7e01bd5 100644
17--- a/configure.ac
18+++ b/configure.ac
19@@ -22,7 +22,6 @@ AX_AM_CFLAGS_ADD([-Werror=format-truncation=1])
20 AX_AM_CFLAGS_ADD([-Werror=shift-negative-value])
21 AX_AM_CFLAGS_ADD([-Werror=alloca])
22 AX_AM_CFLAGS_ADD([-Werror=missing-field-initializers])
23-AX_AM_CFLAGS_ADD([-Werror])
24 AX_AM_CFLAGS_ADD([-Werror=format-signedness])
25
26 AC_SUBST([AM_CFLAGS])
27--
282.7.4
29
diff --git a/meta-oe/recipes-bsp/ledmon/ledmon_git.bb b/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
index 74ae56c67..f9ae9aad9 100644
--- a/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
+++ b/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
@@ -11,15 +11,17 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
11 11
12DEPENDS = "sg3-utils udev" 12DEPENDS = "sg3-utils udev"
13 13
14inherit systemd 14inherit autotools systemd
15 15
16SYSTEMD_SERVICE_${PN} = "ledmon.service" 16SYSTEMD_SERVICE_${PN} = "ledmon.service"
17 17
18# 0.93
18SRC_URI = "git://github.com/intel/ledmon;branch=master \ 19SRC_URI = "git://github.com/intel/ledmon;branch=master \
19 file://0002-include-sys-select.h-and-sys-types.h.patch \ 20 file://0002-include-sys-select.h-and-sys-types.h.patch \
21 file://0001-Don-t-build-with-Werror-to-fix-compile-error.patch \
20 " 22 "
21 23
22SRCREV = "ad1304ca1363d727425a1f23703c523e21feae4f" 24SRCREV = "1d72f9cb5c9163b2ecdf19709935720e65f5b90e"
23 25
24COMPATIBLE_HOST = "(i.86|x86_64).*-linux" 26COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
25COMPATIBLE_HOST_libc-musl = "null" 27COMPATIBLE_HOST_libc-musl = "null"
@@ -27,8 +29,13 @@ COMPATIBLE_HOST_libc-musl = "null"
27S = "${WORKDIR}/git" 29S = "${WORKDIR}/git"
28EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'" 30EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'"
29 31
32# The ledmon sources include headers in ${S}/config to build but not in CFLAGS.
33# We need to add this include path in CFLAGS.
34CFLAGS += "-I${S}/config"
35
30do_install_append() { 36do_install_append() {
31 install -d ${D}/${systemd_unitdir}/system 37 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
32 oe_runmake DESTDIR=${D} install 38 install -d ${D}${systemd_unitdir}/system
33 oe_runmake DESTDIR=${D}${systemd_unitdir}/system install-systemd 39 install -m 0755 ${S}/systemd/ledmon.service ${D}${systemd_unitdir}/system
40 fi
34} 41}