summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-bsp/ledmon/ledmon_git.bb')
-rw-r--r--meta-oe/recipes-bsp/ledmon/ledmon_git.bb17
1 files changed, 12 insertions, 5 deletions
diff --git a/meta-oe/recipes-bsp/ledmon/ledmon_git.bb b/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
index 74ae56c67..f9ae9aad9 100644
--- a/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
+++ b/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
@@ -11,15 +11,17 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
11 11
12DEPENDS = "sg3-utils udev" 12DEPENDS = "sg3-utils udev"
13 13
14inherit systemd 14inherit autotools systemd
15 15
16SYSTEMD_SERVICE_${PN} = "ledmon.service" 16SYSTEMD_SERVICE_${PN} = "ledmon.service"
17 17
18# 0.93
18SRC_URI = "git://github.com/intel/ledmon;branch=master \ 19SRC_URI = "git://github.com/intel/ledmon;branch=master \
19 file://0002-include-sys-select.h-and-sys-types.h.patch \ 20 file://0002-include-sys-select.h-and-sys-types.h.patch \
21 file://0001-Don-t-build-with-Werror-to-fix-compile-error.patch \
20 " 22 "
21 23
22SRCREV = "ad1304ca1363d727425a1f23703c523e21feae4f" 24SRCREV = "1d72f9cb5c9163b2ecdf19709935720e65f5b90e"
23 25
24COMPATIBLE_HOST = "(i.86|x86_64).*-linux" 26COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
25COMPATIBLE_HOST_libc-musl = "null" 27COMPATIBLE_HOST_libc-musl = "null"
@@ -27,8 +29,13 @@ COMPATIBLE_HOST_libc-musl = "null"
27S = "${WORKDIR}/git" 29S = "${WORKDIR}/git"
28EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'" 30EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'"
29 31
32# The ledmon sources include headers in ${S}/config to build but not in CFLAGS.
33# We need to add this include path in CFLAGS.
34CFLAGS += "-I${S}/config"
35
30do_install_append() { 36do_install_append() {
31 install -d ${D}/${systemd_unitdir}/system 37 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
32 oe_runmake DESTDIR=${D} install 38 install -d ${D}${systemd_unitdir}/system
33 oe_runmake DESTDIR=${D}${systemd_unitdir}/system install-systemd 39 install -m 0755 ${S}/systemd/ledmon.service ${D}${systemd_unitdir}/system
40 fi
34} 41}