summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/libtevent
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-11-15 16:18:39 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-16 21:57:47 +0100
commit89163f1a8f3a45b8ce56cf77d6ae464dbd32890d (patch)
treeda60e46e77823d0b1b402eda672aeb79c3c766bc /meta-networking/recipes-support/libtevent
parent2bae637b926d71f70b99545c205c7b3c73749af4 (diff)
downloadmeta-openembedded-89163f1a8f3a45b8ce56cf77d6ae464dbd32890d.tar.gz
samba, ctdb, libldb, libtdb, libtevent, talloc: move to meta-networking
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/libtevent')
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent/do-not-check-xsltproc-manpages.patch16
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb30
2 files changed, 46 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/libtevent/libtevent/do-not-check-xsltproc-manpages.patch b/meta-networking/recipes-support/libtevent/libtevent/do-not-check-xsltproc-manpages.patch
new file mode 100644
index 000000000..1ce4dda1c
--- /dev/null
+++ b/meta-networking/recipes-support/libtevent/libtevent/do-not-check-xsltproc-manpages.patch
@@ -0,0 +1,16 @@
1Don't check manpages for xsltproc.
2
3Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
4
5diff -Nurp tevent-0.9.21.orig/lib/talloc/wscript tevent-0.9.21/lib/talloc/wscript
6--- tevent-0.9.21.orig/lib/talloc/wscript 2013-09-08 21:24:14.000000000 +0900
7+++ tevent-0.9.21/lib/talloc/wscript 2015-04-24 16:28:04.085000230 +0900
8@@ -55,7 +55,7 @@ def configure(conf):
9 if conf.env.standalone_talloc:
10 conf.env.TALLOC_COMPAT1 = Options.options.TALLOC_COMPAT1
11
12- conf.CHECK_XSLTPROC_MANPAGES()
13+ conf.find_program('xsltproc', var='XSLTPROC')
14
15 if not conf.env.disable_python:
16 # also disable if we don't have the python libs installed
diff --git a/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb b/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb
new file mode 100644
index 000000000..f297f30e1
--- /dev/null
+++ b/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "http://tevent.samba.org"
3SECTION = "libs"
4LICENSE = "LGPLv3+"
5
6DEPENDS += "talloc libcap"
7RDEPENDS_${PN} += "libtalloc"
8RDEPENDS_python-tevent = "python"
9
10SRC_URI = "http://samba.org/ftp/tevent/tevent-${PV}.tar.gz"
11LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/LGPL-3.0;md5=bfccfe952269fff2b407dd11f2f3083b"
12
13SRC_URI[md5sum] = "3d5a76c0a1b5f724842d785fd055633f"
14SRC_URI[sha256sum] = "f2be7463573dab2d8210cb57fe7e7e2aeb323274cbdc865a6e29ddcfb977f0f4"
15
16inherit waf-samba
17
18S = "${WORKDIR}/tevent-${PV}"
19
20EXTRA_OECONF += "--disable-rpath \
21 --bundled-libraries=NONE \
22 --builtin-libraries=replace \
23 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
24 --without-gettext \
25 "
26
27PACKAGES += "python-tevent python-tevent-dbg"
28
29FILES_python-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
30FILES_python-tevent-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug"