summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb')
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb b/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb
new file mode 100644
index 000000000..f297f30e1
--- /dev/null
+++ b/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "http://tevent.samba.org"
3SECTION = "libs"
4LICENSE = "LGPLv3+"
5
6DEPENDS += "talloc libcap"
7RDEPENDS_${PN} += "libtalloc"
8RDEPENDS_python-tevent = "python"
9
10SRC_URI = "http://samba.org/ftp/tevent/tevent-${PV}.tar.gz"
11LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/LGPL-3.0;md5=bfccfe952269fff2b407dd11f2f3083b"
12
13SRC_URI[md5sum] = "3d5a76c0a1b5f724842d785fd055633f"
14SRC_URI[sha256sum] = "f2be7463573dab2d8210cb57fe7e7e2aeb323274cbdc865a6e29ddcfb977f0f4"
15
16inherit waf-samba
17
18S = "${WORKDIR}/tevent-${PV}"
19
20EXTRA_OECONF += "--disable-rpath \
21 --bundled-libraries=NONE \
22 --builtin-libraries=replace \
23 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
24 --without-gettext \
25 "
26
27PACKAGES += "python-tevent python-tevent-dbg"
28
29FILES_python-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
30FILES_python-tevent-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug"