summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-irc
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-networking/recipes-irc
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-networking/recipes-irc')
-rw-r--r--meta-networking/recipes-irc/znc/znc/0001-Fix-NULL-pointer-dereference-in-webadmin.patch58
-rw-r--r--meta-networking/recipes-irc/znc/znc_git.bb21
2 files changed, 79 insertions, 0 deletions
diff --git a/meta-networking/recipes-irc/znc/znc/0001-Fix-NULL-pointer-dereference-in-webadmin.patch b/meta-networking/recipes-irc/znc/znc/0001-Fix-NULL-pointer-dereference-in-webadmin.patch
new file mode 100644
index 000000000..68e441470
--- /dev/null
+++ b/meta-networking/recipes-irc/znc/znc/0001-Fix-NULL-pointer-dereference-in-webadmin.patch
@@ -0,0 +1,58 @@
1Subject: [PATCH] Fix NULL pointer dereference in webadmin.
2
3Upstream-Status: Backport
4
5commit 2bd410ee5570cea127233f1133ea22f25174eb28 upstream
6
7Triggerable by any non-admin, if webadmin is loaded.
8
9The only affected version is 1.0
10
11Thanks to ChauffeR (Simone Esposito) for reporting this.
12---
13 modules/webadmin.cpp | 8 ++++----
14 1 file changed, 4 insertions(+), 4 deletions(-)
15
16diff --git a/modules/webadmin.cpp b/modules/webadmin.cpp
17index b793c02..816f217 100644
18--- a/modules/webadmin.cpp
19+++ b/modules/webadmin.cpp
20@@ -419,7 +419,7 @@ public:
21 CIRCNetwork* pNetwork = SafeGetNetworkFromParam(WebSock);
22
23 // Admin||Self Check
24- if (!spSession->IsAdmin() && (!spSession->GetUser() || spSession->GetUser() != pNetwork->GetUser())) {
25+ if (!spSession->IsAdmin() && (!spSession->GetUser() || !pNetwork || spSession->GetUser() != pNetwork->GetUser())) {
26 return false;
27 }
28
29@@ -448,7 +448,7 @@ public:
30 CIRCNetwork* pNetwork = SafeGetNetworkFromParam(WebSock);
31
32 // Admin||Self Check
33- if (!spSession->IsAdmin() && (!spSession->GetUser() || spSession->GetUser() != pNetwork->GetUser())) {
34+ if (!spSession->IsAdmin() && (!spSession->GetUser() || !pNetwork || spSession->GetUser() != pNetwork->GetUser())) {
35 return false;
36 }
37
38@@ -472,7 +472,7 @@ public:
39 CIRCNetwork* pNetwork = SafeGetNetworkFromParam(WebSock);
40
41 // Admin||Self Check
42- if (!spSession->IsAdmin() && (!spSession->GetUser() || spSession->GetUser() != pNetwork->GetUser())) {
43+ if (!spSession->IsAdmin() && (!spSession->GetUser() || !pNetwork || spSession->GetUser() != pNetwork->GetUser())) {
44 return false;
45 }
46
47@@ -486,7 +486,7 @@ public:
48 CIRCNetwork* pNetwork = SafeGetNetworkFromParam(WebSock);
49
50 // Admin||Self Check
51- if (!spSession->IsAdmin() && (!spSession->GetUser() || spSession->GetUser() != pNetwork->GetUser())) {
52+ if (!spSession->IsAdmin() && (!spSession->GetUser() || !pNetwork || spSession->GetUser() != pNetwork->GetUser())) {
53 return false;
54 }
55
56--
571.8.5.2.233.g932f7e4
58
diff --git a/meta-networking/recipes-irc/znc/znc_git.bb b/meta-networking/recipes-irc/znc/znc_git.bb
new file mode 100644
index 000000000..77db25b33
--- /dev/null
+++ b/meta-networking/recipes-irc/znc/znc_git.bb
@@ -0,0 +1,21 @@
1SUMMARY = "ZNC, an advanced IRC bouncer"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
4
5DEPENDS = "openssl"
6
7PV = "1.0+git"
8
9SRCREV = "ef59c23068547c132cb678092fba9a21317fd5f2"
10SRC_URI = "git://github.com/znc/znc.git \
11 file://0001-Fix-NULL-pointer-dereference-in-webadmin.patch \
12 "
13
14S = "${WORKDIR}/git"
15
16inherit autotools-brokensep pkgconfig
17
18# ZNC has a custom autogen.sh that states that this command is needed *and* expected to fail
19do_configure_prepend() {
20 automake --add-missing || true
21}