summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-irc/znc/znc_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-irc/znc/znc_git.bb')
-rw-r--r--meta-networking/recipes-irc/znc/znc_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-networking/recipes-irc/znc/znc_git.bb b/meta-networking/recipes-irc/znc/znc_git.bb
new file mode 100644
index 000000000..77db25b33
--- /dev/null
+++ b/meta-networking/recipes-irc/znc/znc_git.bb
@@ -0,0 +1,21 @@
1SUMMARY = "ZNC, an advanced IRC bouncer"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
4
5DEPENDS = "openssl"
6
7PV = "1.0+git"
8
9SRCREV = "ef59c23068547c132cb678092fba9a21317fd5f2"
10SRC_URI = "git://github.com/znc/znc.git \
11 file://0001-Fix-NULL-pointer-dereference-in-webadmin.patch \
12 "
13
14S = "${WORKDIR}/git"
15
16inherit autotools-brokensep pkgconfig
17
18# ZNC has a custom autogen.sh that states that this command is needed *and* expected to fail
19do_configure_prepend() {
20 automake --add-missing || true
21}