summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/ufw/ufw
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-03-04 13:42:20 +0000
committerKhem Raj <raj.khem@gmail.com>2022-03-04 17:41:45 -0800
commit3e2ed1dcc0887964bc4034f863fce7e24c70570e (patch)
tree7965777a6448846d83ebe5c15d86583b064c9440 /meta-networking/recipes-connectivity/ufw/ufw
parent06c810a80e16c6fd086b486bf0d9b712940ad886 (diff)
downloadmeta-openembedded-3e2ed1dcc0887964bc4034f863fce7e24c70570e.tar.gz
ufw: port to setuptools, use setuptools_legacy
This package has a traditional setup.py which has a custom install command, which isn't supported with the modern wheel/pip installation method. Until upstream has moved away from distutils, use setuptools_legacy so the installation is correct. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/ufw/ufw')
-rw-r--r--meta-networking/recipes-connectivity/ufw/ufw/setuptools.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/ufw/ufw/setuptools.patch b/meta-networking/recipes-connectivity/ufw/ufw/setuptools.patch
new file mode 100644
index 000000000..ad5391cb9
--- /dev/null
+++ b/meta-networking/recipes-connectivity/ufw/ufw/setuptools.patch
@@ -0,0 +1,20 @@
1Move to setuptools as distutils is now deprecated.
2
3Upstream-Status: Submitted [https://code.launchpad.net/~tgamblin/ufw/distutils-to-setuptools]
4Signed-off-by: Ross Burton <ross.burton@arm.com>
5
6diff --git a/setup.py b/setup.py
7index cb67a6a..de648d3 100644
8--- a/setup.py
9+++ b/setup.py
10@@ -25,8 +25,8 @@
11 #
12
13 from __future__ import print_function
14-from distutils.command.install import install as _install
15-from distutils.core import setup
16+from setuptools.command.install import install as _install
17+from setuptools import setup
18 import errno
19 import os
20 import re