summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-03-04 13:42:20 +0000
committerKhem Raj <raj.khem@gmail.com>2022-03-04 17:41:45 -0800
commit3e2ed1dcc0887964bc4034f863fce7e24c70570e (patch)
tree7965777a6448846d83ebe5c15d86583b064c9440
parent06c810a80e16c6fd086b486bf0d9b712940ad886 (diff)
downloadmeta-openembedded-3e2ed1dcc0887964bc4034f863fce7e24c70570e.tar.gz
ufw: port to setuptools, use setuptools_legacy
This package has a traditional setup.py which has a custom install command, which isn't supported with the modern wheel/pip installation method. Until upstream has moved away from distutils, use setuptools_legacy so the installation is correct. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/ufw/ufw/setuptools.patch20
-rw-r--r--meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb3
2 files changed, 22 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/ufw/ufw/setuptools.patch b/meta-networking/recipes-connectivity/ufw/ufw/setuptools.patch
new file mode 100644
index 000000000..ad5391cb9
--- /dev/null
+++ b/meta-networking/recipes-connectivity/ufw/ufw/setuptools.patch
@@ -0,0 +1,20 @@
1Move to setuptools as distutils is now deprecated.
2
3Upstream-Status: Submitted [https://code.launchpad.net/~tgamblin/ufw/distutils-to-setuptools]
4Signed-off-by: Ross Burton <ross.burton@arm.com>
5
6diff --git a/setup.py b/setup.py
7index cb67a6a..de648d3 100644
8--- a/setup.py
9+++ b/setup.py
10@@ -25,8 +25,8 @@
11 #
12
13 from __future__ import print_function
14-from distutils.command.install import install as _install
15-from distutils.core import setup
16+from setuptools.command.install import install as _install
17+from setuptools import setup
18 import errno
19 import os
20 import re
diff --git a/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb b/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb
index c427e4ffd..70216a85e 100644
--- a/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb
+++ b/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb
@@ -12,12 +12,13 @@ SRC_URI = "https://launchpad.net/ufw/0.36/0.36.1/+download/ufw-0.36.1.tar.gz \
12 file://0001-optimize-boot.patch \ 12 file://0001-optimize-boot.patch \
13 file://0002-add-an-option-to-specify-iptables-location.patch \ 13 file://0002-add-an-option-to-specify-iptables-location.patch \
14 file://0003-only-make-one-reference-to-env.patch \ 14 file://0003-only-make-one-reference-to-env.patch \
15 file://setuptools.patch \
15 " 16 "
16SRC_URI[sha256sum] = "1c57e78fbf2970f0cc9c56ea87a231e6d83d825e55b9e31e2c88b91b0ea03c8c" 17SRC_URI[sha256sum] = "1c57e78fbf2970f0cc9c56ea87a231e6d83d825e55b9e31e2c88b91b0ea03c8c"
17 18
18UPSTREAM_CHECK_URI = "https://launchpad.net/ufw" 19UPSTREAM_CHECK_URI = "https://launchpad.net/ufw"
19 20
20inherit distutils3 features_check systemd update-rc.d 21inherit setuptools3_legacy features_check systemd update-rc.d
21 22
22RDEPENDS:${PN} = " \ 23RDEPENDS:${PN} = " \
23 iptables \ 24 iptables \