summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2024-08-14 10:30:09 +0200
committerKhem Raj <raj.khem@gmail.com>2024-09-01 15:54:30 -0700
commit84d6e138cb558cea9155e5a392e2ff7647e2e688 (patch)
tree816a1e846cecedb61817337825a37c59fcd7edd8 /meta-gnome/recipes-gnome
parentc8f4a786402063d160fa16284c16c8fca8165a5a (diff)
downloadmeta-openembedded-84d6e138cb558cea9155e5a392e2ff7647e2e688.tar.gz
cleanup after polkit fix
This commit removes the need to fix polkit permissions: https://git.openembedded.org/meta-openembedded/commit/?h=master-next&id=d5e90541f8e35916abc930b2da6de037b23d51a1 That allows to do some cleanup Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.2.bb12
-rw-r--r--meta-gnome/recipes-gnome/gvfs/gvfs_1.54.0.bb11
2 files changed, 2 insertions, 21 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.2.bb b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.2.bb
index 152e803b5..ae96caf94 100644
--- a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.2.bb
+++ b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.2.bb
@@ -33,7 +33,7 @@ DEPENDS = " \
33 upower \ 33 upower \
34" 34"
35 35
36inherit gtk-icon-cache pkgconfig gnomebase gsettings gettext upstream-version-is-even bash-completion features_check useradd 36inherit gtk-icon-cache pkgconfig gnomebase gsettings gettext upstream-version-is-even bash-completion features_check
37 37
38REQUIRED_DISTRO_FEATURES += "opengl polkit pulseaudio systemd x11" 38REQUIRED_DISTRO_FEATURES += "opengl polkit pulseaudio systemd x11"
39 39
@@ -52,16 +52,6 @@ EXTRA_OEMESON += "-Doe_sysroot=${STAGING_DIR_HOST}"
52 52
53export XDG_DATA_DIRS = "${STAGING_DATADIR}" 53export XDG_DATA_DIRS = "${STAGING_DATADIR}"
54 54
55USERADD_PACKAGES = "${PN}"
56USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 polkitd"
57
58do_install:append() {
59 if [ -d ${D}${datadir}/polkit-1/rules.d ]; then
60 chmod 700 ${D}${datadir}/polkit-1/rules.d
61 chown polkitd:root ${D}${datadir}/polkit-1/rules.d
62 fi
63}
64
65PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src" 55PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
66 56
67FILES:${PN} += " \ 57FILES:${PN} += " \
diff --git a/meta-gnome/recipes-gnome/gvfs/gvfs_1.54.0.bb b/meta-gnome/recipes-gnome/gvfs/gvfs_1.54.0.bb
index 01cdb4eef..6549b1900 100644
--- a/meta-gnome/recipes-gnome/gvfs/gvfs_1.54.0.bb
+++ b/meta-gnome/recipes-gnome/gvfs/gvfs_1.54.0.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "gvfs is a userspace virtual filesystem"
2LICENSE = "LGPL-2.0-only" 2LICENSE = "LGPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=05df38dd77c35ec8431f212410a3329e" 3LIC_FILES_CHKSUM = "file://COPYING;md5=05df38dd77c35ec8431f212410a3329e"
4 4
5inherit gnomebase gsettings bash-completion gettext upstream-version-is-even features_check useradd 5inherit gnomebase gsettings bash-completion gettext upstream-version-is-even features_check
6 6
7DEPENDS += "\ 7DEPENDS += "\
8 dbus \ 8 dbus \
@@ -77,16 +77,7 @@ PACKAGECONFIG[fuse] = "-Dfuse=true, -Dfuse=false, fuse3"
77# libcdio-paranoia recipe doesn't exist yet 77# libcdio-paranoia recipe doesn't exist yet
78PACKAGECONFIG[cdda] = "-Dcdda=true, -Dcdda=false, libcdio-paranoia" 78PACKAGECONFIG[cdda] = "-Dcdda=true, -Dcdda=false, libcdio-paranoia"
79 79
80USERADD_PACKAGES = "${PN}"
81USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 polkitd"
82
83do_install:append() { 80do_install:append() {
84 if ${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'true', 'false', d)}; then
85 # Fix up permissions on polkit rules.d to work with rpm4 constraints
86 chmod 700 ${D}${datadir}/polkit-1/rules.d
87 chown polkitd:root ${D}${datadir}/polkit-1/rules.d
88 fi
89
90 # After rebuilds (not from scracth) it can happen that the executables in 81 # After rebuilds (not from scracth) it can happen that the executables in
91 # libexec ar missing executable permission flag. Not sure but it came up 82 # libexec ar missing executable permission flag. Not sure but it came up
92 # during transition to meson. Looked into build files and logs but could 83 # during transition to meson. Looked into build files and logs but could